1. weslexcore's Avatar
    Phone - Samsung Galaxy S7
    Card - Samsung Evo 64gb

    The card had been working for a long time with no issues, was formatted to be used as internal storage so that I could move applications to it. The card was encrypted and when I go to decrypt the card (attempting to recover with my laptop) on the phone it has "Decrypting SD Card" as a notification but I have yet to have it complete. The notification just stays there and when I click it it goes away but gives no further information.

    I can plug it into my computer and see the JPG's and other files but am unable to open them (recovering pictures is my main concern here, just got back from a Eurotrip). When it is plugged into my phone it shows as "SD Card Ready" under storage, but all the applications, music and photos that I had on the card are not showing on the phone.

    Thank you for any help you can give and let me know if you have any questions!

    Photos of notification shown and what it appears as under my storage settings - Android SD Card - Album on Imgur
    Dragomir1991 likes this.
    06-09-2016 04:07 PM
  2. weslexcore's Avatar
    SOLUTION

    Alright, what I did to fix the issue (YAY) was to:
    - turn my lock screen security to none, keeping fingerprint data.
    - I then went and started encrypting the sd card again. It failed as usual and I restarted the phone and when it came up it stated the SD Card was successfully encrypted.
    - Went to my gallery and all my photos are showing.

    I am now completing a backup to google photos and then going to try and decrypt to hopefully keep this from happening in the future!
  3. weslexcore's Avatar
    SOLUTION

    Alright, what I did to fix the issue (YAY) was to:
    - turn my lock screen security to none, keeping fingerprint data.
    - I then went and started encrypting the sd card again. It failed as usual and I restarted the phone and when it came up it stated the SD Card was successfully encrypted.
    - Went to my gallery and all my photos are showing.

    I am now completing a backup to google photos and then going to try and decrypt to hopefully keep this from happening in the future!
    Corbean, jojkos and Dragomir1991 like this.
    06-09-2016 05:37 PM
  4. Tanya De la Morena's Avatar
    Hey Weslexcore!

    You should consider sticking around and joining our community! Everyone just helping each other out and talking everything tech. Check out our full site and thank you for signing up and trusting us with your tech needs!
    basanagouda kamat likes this.
    06-09-2016 08:48 PM
  5. cary1234's Avatar
    I registered in this website just to say thank you so much to this solution, I'm trying to fix this issues for more than 3 hours. Glad that I've read your post.
    09-20-2016 10:44 PM
  6. Corbean's Avatar
    Thanks. Worked for me too.
    09-27-2016 02:29 AM
  7. Jerry Jacob's Avatar
    I was about to give up on my SD card and then I saw this post. Worked like a charm. Thank you
    10-11-2016 03:45 AM
  8. jojkos's Avatar
    wow, that actually really did work thanks a lot..very weird bug
    Dragomir1991 likes this.
    12-11-2016 03:13 PM
  9. pyryn's Avatar
    Created an account here just to thank you! This fix worked like a dream when nothing else would. Weird, glad I came across this thread randomly. It's really ****ty to think that I came so close to losing everything....definitely making sure to back up everything now.
    12-18-2016 11:38 PM
  10. Rip's Avatar
    I set lock screen security to none, kept fingerprint data and selected Encrypt SD card.
    Screen now shows "Checking SD card..." for the last 25 minutes. Is this what I should be seeing?
    GodisGoodURnot likes this.
    12-19-2016 09:49 AM
  11. androidattorney's Avatar
    Hello all, I wanted to report this error happened to me and at first this trick worked so if it does for you IMMEDIATELY save your data because the next day, it stopped working again. And this was after I naively spent quite some time moving every possible app onto the SD card.

    You'll probably recognize I am writing this because I did NOT take said brilliant advice, and today found everything on the card was missing again and no combination of safe mode, reboots, power downs, recovery mode/clearing cache and spamming the settings/encrypt choices (or decrypt) would get the system to see the card again.

    To let you what did not work...I put the card into an adapter and copied all its files onto a regular SD card and then told the phone to encrypt that. Even though it said it did the result was still unreadable stuff. So here's what I did that worked for me. (And I am backing up my photos as I write this you know, just in case.(

    1. I removed the phone password but kept fingerprints as suggested above
    2. I used a partition editor to delete the partitions on a different SD card I did not care about so that it was unusable. I put that in the phone and went to settings/storage and it said the card needed to be set up for use, I said OK, and when prompted I agreed to have it encrypted.
    3. the phone recognized the new SD card and I was thinking (incorrectly) just copy files from the old SD card and that might just work. It did not. So perhaps the encryption is based in part on the card itself. I don't know, seemed like a great idea. <<FAIL>>
    4. Then I figured perhaps this was a phone software error/misconfiguration, and the setup of the blank card fixed the phone's ability to "see" the SD card. So I put the original SD card back in the phone. Surprisingly, the phone could see the card but the contents were still encrypted and the gallery app showed broken image place holders instead of the photos.
    5. So I went to settings and elected to decrypt the SD card, that took a while but it did it successfully in theory. When I checked in gallery it STILL showed broken image place holders :/
    6. Then I chose encrypt again. And it took a while and did it. THIS WORKED. After encrypting all of the files and moved apps reappeared.


    So my take on this is there is a subtle bug that I tripped somehow that caused the phone to not see any SD cards correctly. But when I forced it to deal with a blank one it had to set it up and that process fixed things. And I am not convinced I needed to decrypt it, I am thinking I could have simply gone ahead with the re-encryption after the detour into setting up a blank SD card.

    So to recap I'd try this:

    1. Remove phone password but kept fingerprints as suggested
    2. Get a different SD card, use a partition editor / somehow erase the thing to be unformatted
    3. Put erased SD card in the phone, go to settings/storage, set up card for use, and when prompted agree to encrypting it
    4. Remove the now set up SD card and put back in the old SD card
    5. POSSIBLY OPTIONAL: decrypt the old SD card
    6. Choose to encrypt the old SD card again


    I hope it helps.
    12-23-2016 07:55 PM
  12. Mauricio Hevia's Avatar
    What I did to fix the issue was clicking the volume and the turn on button at the same time until it gets restarted, and it worked! Hope to work for you!
    Dragomir1991 likes this.
    12-27-2016 01:21 PM
  13. Agoforza's Avatar
    Perfect.....its work... thanks!!!!
    Dragomir1991 likes this.
    01-31-2017 02:33 AM
  14. scav666's Avatar
    hi!
    I got the same issue and your workaround worked for me. Do you know maybe ehow to encrypt SD card and not having this issue in the fututre ?
    02-24-2017 03:09 PM
  15. Slambs05's Avatar
    Just wanted to say a massive thanks for this tip! I was really worried I had lost all my files, pictures etc. This tip worked a treat😊
    Dragomir1991 likes this.
    05-21-2017 02:30 PM
  16. Tim Masters1's Avatar
    Thank you so much! Worked perfectly. Never would have thought about doing that.

    SOLUTION

    Alright, what I did to fix the issue (YAY) was to:
    - turn my lock screen security to none, keeping fingerprint data.
    - I then went and started encrypting the sd card again. It failed as usual and I restarted the phone and when it came up it stated the SD Card was successfully encrypted.
    - Went to my gallery and all my photos are showing.

    I am now completing a backup to google photos and then going to try and decrypt to hopefully keep this from happening in the future!
    Dragomir1991 likes this.
    10-13-2018 12:57 AM
  17. Dragomir1991's Avatar
    Thank you very much! works like magic. I have a Samsung J5 2015, and I searching info for this problem about 4 days... And, finnaly, because of you, I have decrypt my old J5. I have a 64 GB Hama, iwth oly 20 GB occupated and I was scared that all my personal files are gone. Thank you very much for telling us what to do . I recomend those steps. Don't worry, your personal files will be just good. Thank you a lot man ! and greetings from Romania.
    12-29-2018 03:59 PM
  18. Dragomir1991's Avatar
    wow, that actually really did work thanks a lot..very weird bug
    Very weird. And I think that this happend after you restore at the factory reset. Crypt/decrypt doesn't do something great ...
    12-29-2018 04:04 PM
  19. Dragomir1991's Avatar
    hi!
    I got the same issue and your workaround worked for me. Do you know maybe ehow to encrypt SD card and not having this issue in the fututre ?
    You can't . Is a weird bug caused by android...
    12-29-2018 04:06 PM
  20. Rukbat's Avatar
    One note here - removing the password but keeping the fingerprint normally keeps pattern or PIN backup (pattern is just swiping a numeric PIN pad) so there's still some encryption. If you set the lock to None, there's no fingerprint lock either.
    12-30-2018 12:56 AM

Similar Threads

  1. Replies: 1
    Last Post: 07-19-2016, 11:48 AM
  2. Replies: 1
    Last Post: 06-16-2016, 04:52 AM
  3. Replies: 3
    Last Post: 06-11-2016, 12:28 AM
  4. is my verizon s3 phone unlocked after 2 ye contract?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-09-2016, 05:55 PM
  5. Is there a way to stop my controller from navigating menus
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-09-2016, 03:17 PM
LINK TO POST COPIED TO CLIPBOARD