1. PhoneMANx's Avatar
    I noticed yesterday morning after the July updates, my SD card will no longer mount properly. It shows "Ready" on storage settings screen. But, I cannot browse it or, mount it. I didn't have much on there I cared about, so I took it out of the phone. Windows 10 can read it fine. So I formatted it, and put it back in, still the same, "Ready". So I took it out, formatted it in windows as NTFS, put it back in the phone, and it said it needed to be formatted. OK, good. Did that. Finishes and just says "Ready". This appears to be a problem with the OS, I've rebooted the phone, booted to recovery and cleared the cache partition. Nothing. This is a Samsung Evo card that had been working for months.

    Edit: I found and tested another SD card, same behavior.

    So i'm puzzled. Anybody else see this issue or have any ideas?
    07-21-2016 09:57 AM
  2. dpham00's Avatar
    Hmmm I would try to contact Samsung for a warranty replacement
    07-21-2016 05:17 PM

Similar Threads

  1. Why won't my Windows 10 read my Samsung micro sdhc?
    By mjt6722 in forum General Help and How To
    Replies: 5
    Last Post: 07-29-2016, 02:57 PM
  2. Replies: 12
    Last Post: 07-28-2016, 10:11 AM
  3. Moto mod purse available on Verizon site
    By Clocks in forum Moto Mods
    Replies: 4
    Last Post: 07-26-2016, 01:45 PM
  4. Micromax D303 pc not connect please help or charging ways?
    By 1199 in forum General Help and How To
    Replies: 1
    Last Post: 07-24-2016, 06:55 PM
  5. Replies: 2
    Last Post: 07-22-2016, 07:42 PM
LINK TO POST COPIED TO CLIPBOARD