03-22-2018 02:47 PM
36 12
tools
  1. strikeIII's Avatar
    Hello,

    From the native Samsung Text App whenever I tap on a link it opens in some kind of built in browser of the Text App. I have to click on More and open with browser in order for it to open in Chrome.

    Is there a way to stop the links from opening in this built in browser and have it go straight to Chrome?

    TIA

    EDIT: I understand I can use a different text app but I'd like to know if there is an option to disable this from the Samsung Native Text App.
    08-04-2016 02:21 PM
  2. VDub2174's Avatar
    Have you tried clearing defaults with the stock browser (settings > applications > applications manager > internet > set as default)?
    08-04-2016 02:30 PM
  3. strikeIII's Avatar
    Have you tried clearing defaults with the stock browser (settings > applications > applications manager > internet > set as default)?
    Yes, Chrome is already set as my default browser. It's like the stock SMS app has it's own little browser built in that opens when you tap on a link. In that little browser I have to click on the More option to "Open in Browser" which then opens in my default browser which is Chrome. In the SMS app I don't see any settings to turn this behavior off and open straight to Chrome.
    08-04-2016 02:48 PM
  4. Bungdirt's Avatar
    Yes, Chrome is already set as my default browser. It's like the stock SMS app has it's own little browser built in that opens when you tap on a link. In that little browser I have to click on the More option to "Open in Browser" which then opens in my default browser which is Chrome. In the SMS app I don't see any settings to turn this behavior off and open straight to Chrome.
    Any luck on this? Every link i click on wont load with the default broswer, i have to hit open in browser every time.
    08-09-2016 01:09 PM
  5. edubb256's Avatar
    I looked in this back when I used to use Chrome. I don't think there is any way to change this. It seems to me the Samsung browser is hardcoded to the Messages app.
    08-09-2016 06:01 PM
  6. vixenwench's Avatar
    I'm having the same issue. I found this from Samsung:

    Opening URL on Messaging App of Samsung Galaxy S7 in-app browser type

    It was posted August 3rd, but there's nothing about how to turn it off. Ugh.
    08-10-2016 11:21 AM
  7. katech725's Avatar
    I'm having the same issue. I found this from Samsung:

    Opening URL on Messaging App of Samsung Galaxy S7 in-app browser type

    It was posted August 3rd, but there's nothing about how to turn it off. Ugh.

    So, it's not quite a fix and may not work for everyone, but I've discovered that by utilizing the "swipe down to minimize" feature on the little browser window (drag down on the top bar), it seems to force the web page to load when it transitions to a stasis view. Again, more a workaround until Samsung fixes their buggy little "feature" or gives the option to select an external browser, but I guess it's something.
    08-15-2016 09:56 PM
  8. strikeIII's Avatar
    Any luck on this? Every link i click on wont load with the default broswer, i have to hit open in browser every time.
    Still no luck. I've switched to FB Messenger to handle my text messages now.
    08-19-2016 03:09 PM
  9. Bus180's Avatar
    Still no luck. I've switched to FB Messenger to handle my text messages now.
    It's Chrome Custom Tabs. I have no idea how to get my SMS links to open with just my browser. Not sure why this changed.
    08-20-2016 08:19 PM
  10. Kampnman's Avatar
    I have the same problem with my S7 Edge. Both Verizon and Samsung Corp Techs were unable to help this past week working for hours to resolve it. It seems the link takes you to an intermediate Samsung what-to-be-browser that is unable to open link (blank screen) from factory Samsung Messager app. You then must select "more", then "open in browser" for it to do anything. Or simply download some other message app. Must be a bug from last update? Samsung needs to figure it out quickly as they are losing us to someone else's apps that do not have the problem.
    08-22-2016 11:57 PM
  11. Sim-X's Avatar
    Same issue on my galaxy s7 edge Sprint. I hate the built in browser it's junk and doesn't work half the time. I did find some settings for messages if you pull it up under applications but they are of course grayed out. I have tried some 3rd party apps but don't really care for any. If anyone finds a fix please share.
    08-23-2016 07:25 AM
  12. strikeIII's Avatar
    I just switched to Google Messenger and giving that a try for a bit. FB messenger was starting to annoy me. Lol.
    08-24-2016 09:32 AM
  13. WatermelonSlim's Avatar
    Same problem on my Note 7. I guess there is no fix..
    08-26-2016 01:09 PM
  14. Melissa is Me's Avatar
    I have the same problem with my tmobile Galaxy s6 Edge. I hate that I am forced to go to "open in browser". Really kinda sucks... Hope they come up with a fix soon.
    08-27-2016 10:19 AM
  15. Michael Beck3's Avatar
    I have the same issue - I receive job notifications all day via text w/ links in them and on my Note 4 it worked fine, but on my new Note 7 it opens what I presume is a Webview minibrowser that only partially loads, I then had to use the drop down menu to load it into Chrome, which reloaded the page, which finally opened the link into the app that it was associated with in the system to begin with - WTH?!?!
    So the only fix I found was to replace the stock app with the Google messaging app which opens the links correctly.
    While it doesn't solve the issue, I'm glad for my OCD sake to hear others are having the same issue and that it's not my phone and can stop looking for hidden settings, etc.
    08-27-2016 01:56 PM
  16. kevjitzoo's Avatar
    To fix this you have to go to Developer Options and turn off all of the animations. For some reason, the messenger does not like the transition where the window pulls from the bottom when launching a URL.
    08-28-2016 05:55 PM
  17. Initialcap's Avatar
    I've noticed this issue too. A work around to get the samsung browser to render is to rotate the device, then rotate it back. I know this doesn't answer the question about opening in Chrome, but for me its a bit quicker to just rotate. As a developer, that communicates links to users via sms, I'm experimenting with chrome specific protocol (googlechrome://urladdress.com) to force chrome to open when clicked on.
    08-29-2016 04:41 PM
  18. txgolf95's Avatar
    This seems to be an issue with Android Web View, if you force stop it and disable it. It works. Settings>Applications> Application Manager> Android WebView> Force Stop> Disable.
    08-29-2016 04:50 PM
  19. Bus180's Avatar
    Says you will lose your data. Which is it refering to?
    08-29-2016 06:42 PM
  20. WatermelonSlim's Avatar
    This seems to be an issue with Android Web View, if you force stop it and disable it. It works. Settings>Applications> Application Manager> Android WebView> Force Stop> Disable.
    This did not work for me on my Note 7.
    08-29-2016 06:49 PM
  21. Chris Vizzini's Avatar
    Yes same problem. I don't even mind it opening a link in its own mini browser from the messaging app but anytime I click on a link, the page is blank even though you can see the loading progress bar at the top. It completes the load but still blank white. Arg.

    Update:
    It is a Android System Webview issue. I force stopped then disabled. It reverts to the shipped version. 49.0.2623.105

    Re-enabled. Works, page loads no blank screen.

    If I update it to the latest version, 52.0.2743.98, goes back to blank.
    08-30-2016 07:57 PM
  22. Goldryder's Avatar
    Oh my garsh, THANK YOU! That fixed it for me.
    08-31-2016 06:54 PM
  23. Ben Danson's Avatar
    That fixed it! So great! Thank you very much. Perfect solution to an aggravating problem.
    09-03-2016 09:37 PM
  24. seajypsy's Avatar
    This worked for me. Thanks so much!
    09-04-2016 05:29 PM
  25. TheREALpamalam's Avatar
    Chris = JEEN-YUSS!

    Worked great, thank you. Fixed two phones with this issue, S6's.
    09-05-2016 08:12 PM
36 12

Similar Threads

  1. Replies: 2
    Last Post: 08-16-2016, 01:34 AM
  2. Messaging App Crashes after ~10000 Messages
    By jm101 in forum Moto X (2014)
    Replies: 3
    Last Post: 08-06-2016, 01:32 AM
  3. Heads up if ordering from Tmobile. Just pre ordered, fee.
    By Blues Fan in forum Samsung Galaxy Note 7
    Replies: 32
    Last Post: 08-05-2016, 02:43 PM
  4. Replies: 0
    Last Post: 08-04-2016, 02:16 PM
  5. How do I clear voice mails from my S6 (it's full)
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-04-2016, 01:31 PM
LINK TO POST COPIED TO CLIPBOARD