1. cornwallvoid's Avatar
    I have had my Samsung Galaxy S7 (US non rooted) for about a week, and I have noticed that photo messages are not working correctly. I can send them to other people, but I can't receive them. This is driving me nuts.

    Troubleshooting that I have tried:
    Tested MMS from iPhone (failed)
    Tested MMS from Android phone (failed)
    Used default Messages (failed)
    Used Google Messenger (failed)
    Checked that Mobile Data was on (it was)
    Disabled Wi-Fi to use only data (nothing changed)
    Checked for Samsung update (already newest version)
    Checked APN, reset APN, added custom APN (for T-Mobile)
    Called T-Mobile to makes sure it wasn't them (it doesn't seem to be)
    Clear cache for Messages app (nothing changed)
    Cleared device cache (nothing changed)
    Reset phone back to factory settings (nothing changed)

    I may have forgot some other steps as I have been working on it nonstop. I really could use some help. If anyone has any ideas, please let me know. Thank you in advance.
    12-29-2016 12:02 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you also tried Safe Mode? https://support.t-mobile.com/docs/DOC-28008
    12-29-2016 12:26 AM
  3. cornwallvoid's Avatar
    Thank you for the welcome.

    I had not yet tried safe mode. I just gave it a test, and I am seeing no change; still not receiving any images. I find it interesting that the sending phones all seem to show the message as completely sent. I figure they would get an error saying it failed, as you would with no signal. I also tried sending my phone a photo text from itself, and that came through. Of course, that is assuming it went through the network in the first place. It seems like something is working, but that makes what is broken that much more confusing.
    12-29-2016 04:02 AM
  4. B. Diddy's Avatar
    Hmm, not sure what to try next. Just to be certain, these are the APN settings you're using, correct? https://support.t-mobile.com/docs/DOC-2090
    12-29-2016 08:41 PM
  5. cornwallvoid's Avatar
    Yes, and no. T-Mobile seems to have multiple documents on APN for this phone. There is the very basic one you provided, one for the S7, and then the default installation APN settings. For the most part they are the same. APN Type is shown as:
    1. default,supl,mms (default and simple document)
    2. Internet+MMS (simple and S7 document)
    3. Or not set (S7 document)
    Setting it as 1 and 3 seem to provide no change. Setting it as 2 makes seem to cause an error, and the phone automatically switches it to the default APN. [EDIT: I can get this settings to stay active, but no change in receiving MMS] Other carriers seem to use some variant on 1 ("default,mms,supl", "mms", or "default,mms,supl,hipri,fota") I read moving mms, to the middle made it work for some people, but I haven't had any luck with that.

    Another difference is the APN Protocol and Roaming Protocol. The default is IPv6 then IPv4. The other is IPv4/IPv6 then IPv4. Changing them doesn't seem to make a difference. All the other carriers seem to choice IPv4 only.

    Lastly, the S7 specific document lists MMS protocol: WAP 2.0, but that option is not present in the APN settings. It seems like it could be important, but I wonder if the document was not updated from a previous version. Although that setting is listed in all Samsung specific phones.
    12-30-2016 01:17 AM
  6. B. Diddy's Avatar
    Hmm, weird. I'll tell you what the settings are on my Nexus 6P, just in case this combination is useful (although it probably won't be):

    Name: T-Mobile GPRS
    APN: fast.t-mobile.com
    Proxy: Not set
    Port: Not set
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: Not set
    MMS Proxy: Not set
    MMS Port: Not set
    MCC: 310
    MNC: 260
    Authentication type: Not net
    APN type: default,supl
    APN protocol: IPv6
    APN roaming protocol: IPv4
    Bearer: Unspecified
    MVNO type: None
    12-30-2016 01:10 PM
  7. cornwallvoid's Avatar
    Those settings didn't seem to work, but it did however let me discover something new. With bad APN settings, the sending phone will fail delivery of the MMS. So it seems like my settings for the APN are correct, but somewhere the message gets lost. Now to figure out where and why.
    12-30-2016 03:43 PM
  8. cornwallvoid's Avatar
    ... it seems like my settings for the APN are correct, but somewhere the message gets lost. Now to figure out where and why.
    Based on this new fact, I contacted T-Mobile again. After a long chat about the issue, they decided to try suspending my line and then reactivating it. Ten seconds later, MMS was working fine. It seems there was a problem on their end after all, and I needed to just talk to the right person. The agent said they were still going to investigate the issue further since it is not typical. If I hear anything more, I'll try to post further details.

    B. Diddy thank you very much for your help!
    B. Diddy likes this.
    12-31-2016 02:28 AM
  9. B. Diddy's Avatar
    Excellent! Glad things are back to normal.
    01-02-2017 06:00 PM

Similar Threads

  1. why do I have 4gb of cached Data!?!?!??
    By mvasquez009 in forum Google Pixel & Pixel XL
    Replies: 16
    Last Post: 12-30-2016, 04:05 PM
  2. Can I get a download of instruction book to print out
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-29-2016, 02:31 PM
  3. Why can't I download my pictures onto the computer?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 12-29-2016, 03:32 AM
  4. why does screen lock type not allow me to open it
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-28-2016, 09:32 PM
  5. can i use my i-ph earphones on samsung galxgrdprime
    By karen volker in forum Ask a Question
    Replies: 0
    Last Post: 12-28-2016, 09:16 PM
LINK TO POST COPIED TO CLIPBOARD