10-02-2018 03:47 AM
27 12
tools
  1. CHRISALLEN3285's Avatar
    Hello Everyone!!!! I need your help. I'm not receiving gmail notifications on my phone. I've tried some troubleshooting steps. I've gone to Settings > Device > Notifications and turned gmail notifications on. I've gone into the gmail app itself and went to settings and have turned notifications on. It seems as though if I go into my inbox and take my thumb and swipe down to refresh my inbox e-mails show up. I don't know what else to do or what else to try. Can anyone help?
    01-30-2017 02:07 AM
  2. Tim1954's Avatar
    Have you got the email client synching?
    01-30-2017 05:59 AM
  3. CHRISALLEN3285's Avatar
    Have you got the email client synching?
    As far as I know yes
    01-30-2017 01:13 PM
  4. B. Diddy's Avatar
    Any power-saving modes or apps turned on or installed? Also, is Restrict Background Data turned on in Settings>Data Usage?
    01-30-2017 05:23 PM
  5. CHRISALLEN3285's Avatar
    Any power-saving modes or apps turned on or installed? Also, is Restrict Background Data turned on in Settings>Data Usage?
    Power saving mode is off. Ultra power saving mode is off. The only apps that I have installed on the phone that didn't come pre-installed on the phone are Gmail, YouTube, The Weather Channel for Samsung, BR Team Stream, Whatsapp, Viber, Facebook Messenger, and iTranslate. As far as I know Restrict background data is not on.
    01-30-2017 07:10 PM
  6. B. Diddy's Avatar
    To make sure Restrict Background Data is off, go to Settings>Data Usage, select Gmail, and make sure the Restrict option isn't checked there. I mention this because it's possible to restrict data for specific apps (rather than doing it universally).
    01-30-2017 07:14 PM
  7. CHRISALLEN3285's Avatar
    To make sure Restrict Background Data is off, go to Settings>Data Usage, select Gmail, and make sure the Restrict option isn't checked there. I mention this because it's possible to restrict data for specific apps (rather than doing it universally).
    So I go to Settings > Connections > Data usage and when I scroll through the list of applications Gmail is no where to be found.
    01-30-2017 10:29 PM
  8. B. Diddy's Avatar
    If you swipe down the Quick Settings, is the Auto Sync toggle turned on? I'm assuming it is, since you said "as far as as I know" to the question about syncing. But let's just double check.
    01-30-2017 11:33 PM
  9. CHRISALLEN3285's Avatar
    If you swipe down the Quick Settings, is the Auto Sync toggle turned on? I'm assuming it is, since you said "as far as as I know" to the question about syncing. But let's just double check.
    When I click on Settings and then go to Quick Settings there is no Auto Sync toggle. There's just Sounds and vibrations, Display, Themes, Lock screen and security, Battery, and Help.
    01-31-2017 04:23 PM
  10. B. Diddy's Avatar
    If you haven't actually laid eyes on the main auto-sync setting, it's still a good idea to confirm it's on. Where it's located can depend on the phone. On the Nexus 6P, it's at Settings>Accounts, then Menu. In other phones, I've seen it in Settings>Data Usage. If your settings menu has a search function, just search for auto-sync.
    Laura Knotek likes this.
    01-31-2017 05:31 PM
  11. CHRISALLEN3285's Avatar
    If you haven't actually laid eyes on the main auto-sync setting, it's still a good idea to confirm it's on. Where it's located can depend on the phone. On the Nexus 6P, it's at Settings>Accounts, then Menu. In other phones, I've seen it in Settings>Data Usage. If your settings menu has a search function, just search for auto-sync.
    So I went to Settings and tapped search at the top and typed in auto-sync and it says no results found.
    01-31-2017 10:32 PM
  12. B. Diddy's Avatar
    Did you look in those menu locations, then? It's tucked away somewhere -- you just need to find it.

    I just checked my wife's Note5, which is most likely the same as your S7 -- I found the option in the Settings>Accounts menu, after tapping More.
    01-31-2017 11:33 PM
  13. CHRISALLEN3285's Avatar
    Ok I found it. When I tap More though it gives me two options: Turn off auto sync or help so that must mean that auto sync is turned on.
    02-01-2017 12:53 AM
  14. B. Diddy's Avatar
    Ok, let's back up a little bit -- are any apps serving up notifications normally? That is, is it just Gmail that seems to be the problem?
    02-01-2017 01:32 AM
  15. CHRISALLEN3285's Avatar
    Ok, let's back up a little bit -- are any apps serving up notifications normally? That is, is it just Gmail that seems to be the problem?
    Yes! Whatsapp, Viber, Messages, etc are all working normally. Yes, it's just Gmail that seems to be the problem.
    02-01-2017 12:11 PM
  16. B. Diddy's Avatar
    You might not be alone -- check out this other thread: http://forums.androidcentral.com/mot...g-trouble.html

    Do you have multiple Gmail accounts in the Gmail app, or just one?
    02-01-2017 03:53 PM
  17. CHRISALLEN3285's Avatar
    You might not be alone -- check out this other thread: http://forums.androidcentral.com/mot...g-trouble.html

    Do you have multiple Gmail accounts in the Gmail app, or just one?
    I have just one Gmail account in the Gmail app.
    02-01-2017 06:28 PM
  18. Mondi back-up's Avatar
    Solution - you should turn on the notifications. To do so, the following:

    *Open your Gmail app and go to Settings.
    *Tap on one of the accounts which is listed below (your email accounts) and check Notifications

    *Enjoy!

    PS: in my case the notifications were not received since the moment I removed Inbox app (a gmail app)
    06-20-2017 02:44 AM
  19. lincolnelectra's Avatar
    Can I open this back up?
    I'm having a lot of trouble with gmail notifications on my S7. I checked all the steps as listed by B. Diddy and they're all a go.
    I have 12 gmail accounts on my phone, and only get occasional alerts to new emails. If I log in to my account on a PC then I immediately get a notification on my phone for any new messages I have (thanks for nothing), or if I open gmail and view all my accounts and pull down to refresh, I will usually get notifications within a couple minutes. But I don't like that I have to try to remember to constantly do that (because I almost never remember). I have a couple business emails in there and it's going to start impacting my business any minute now!!
    I have not tried uninstalling and reinstalling, because since I have 12 accounts it will be such a big pain in my butt, but if that's a likely solution then I guess I can give it a go...

    Please offer any other suggestions you may have!

    Thanks in advance!
    01-25-2018 10:16 PM
  20. Steve Stillwell's Avatar
    I am having the same problem. Notifications and synching turned on, no restrictions to background data for the app. It is clearly a problem with the app and not anything we've done, as all my other apps including outlook work just fine and I get emails on outlook instantly. I just missed an important deadline because this app didn't notify me that I received an email. Where is the support for this app? Who do I contact?
    02-27-2018 10:29 PM
  21. Ricky Chen's Avatar
    Had a similar problem where out of no where I stopped receiving notifications. What worked for me was going into the gmail app info and disabling the app. After enabling it again all my notifications started working.

    Hope this helps
    Tardigrade likes this.
    05-27-2018 12:27 AM
  22. Tardigrade's Avatar
    Had a similar problem where out of no where I stopped receiving notifications. What worked for me was going into the gmail app info and disabling the app. After enabling it again all my notifications started working.

    Hope this helps
    The only helpful reply for a problem that's obviously not just about settings!
    Thank you - this sorted my notifications out
    07-04-2018 11:38 AM
  23. Micko179's Avatar
    Hello Everyone!!!! I need your help. I'm not receiving gmail notifications on my phone. I've tried some troubleshooting steps. I've gone to Settings > Device > Notifications and turned gmail notifications on. I've gone into the gmail app itself and went to settings and have turned notifications on. It seems as though if I go into my inbox and take my thumb and swipe down to refresh my inbox e-mails show up. I don't know what else to do or what else to try. Can anyone help?
    This has been plaguing me for about a year now!

    What worked for me was, go to settings in Gmail, click your @gmail account, then Inbox notifications, click/enable Label notifications, click notify for every message! Done!
    07-06-2018 04:12 PM
  24. DanielYao1234's Avatar
    This has been plaguing me for about a year now!

    What worked for me was, go to settings in Gmail, click your @gmail account, then Inbox notifications, click/enable Label notifications, click notify for every message! Done!
    Did everything above including this one. Still not work.

    Have a feeling that it's Samsung and Gmail don't like each other. So I installed another email app, setup gmail. Done.
    07-12-2018 12:41 PM
  25. Lane10's Avatar
    This worked for me.
    09-06-2018 09:29 AM
27 12

Similar Threads

  1. Dismissing notifications on watch
    By Brucewayne797 in forum Samsung Gear S2
    Replies: 1
    Last Post: 01-30-2017, 07:25 PM
  2. Replies: 2
    Last Post: 01-30-2017, 02:09 AM
  3. Why I did not get Proper output from json webservice in webview?
    By AC Question in forum Software Development and Hacking
    Replies: 1
    Last Post: 01-30-2017, 01:58 AM
  4. Whys do I get a notification ringing note on S4 irregularly
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-30-2017, 01:30 AM
  5. Replies: 0
    Last Post: 01-29-2017, 10:18 PM
LINK TO POST COPIED TO CLIPBOARD