1. authority11's Avatar
    Prior to my updating to Nougat, I used to receive emails notifications on my S7 instantly when sent (i.e. same as I received them on my desktop GMail. After updating to Nougat, I now have a 3-4 minute delay receiving GMail push notifications on my phone. My work email that I have on my phone (Outlook based) receives notifications instantly, however.

    Anybody have any ideas? I have already moved the GMail app to be "not optimized" for battery/doze purposes.
    03-14-2017 04:34 PM
  2. Distrack's Avatar
    Prior to my updating to Nougat, I used to receive emails notifications on my S7 instantly when sent (i.e. same as I received them on my desktop GMail. After updating to Nougat, I now have a 3-4 minute delay receiving GMail push notifications on my phone. My work email that I have on my phone (Outlook based) receives notifications instantly, however.

    Anybody have any ideas? I have already moved the GMail app to be "not optimized" for battery/doze purposes.

    just got Nougat (finally) and I have the same problem. Also my S7 can take more than 20 minutes before it finally connect to the WiFi when I get home.

    Last Samsung phone for me.
    03-20-2017 12:19 PM
  3. Mark8768's Avatar
    Prior to my updating to Nougat, I used to receive emails notifications on my S7 instantly when sent (i.e. same as I received them on my desktop GMail. After updating to Nougat, I now have a 3-4 minute delay receiving GMail push notifications on my phone. My work email that I have on my phone (Outlook based) receives notifications instantly, however.

    Anybody have any ideas? I have already moved the GMail app to be "not optimized" for battery/doze purposes.
    Just started having this issue the last couple days.. no fix yet
    03-21-2017 03:51 PM
  4. TechNut79's Avatar
    Have any of you tried to remove your Google account from your phone and add it again?
    03-21-2017 04:06 PM
  5. gluttonfp's Avatar
    Prior to my updating to Nougat, I used to receive emails notifications on my S7 instantly when sent (i.e. same as I received them on my desktop GMail. After updating to Nougat, I now have a 3-4 minute delay receiving GMail push notifications on my phone. My work email that I have on my phone (Outlook based) receives notifications instantly, however.

    Anybody have any ideas? I have already moved the GMail app to be "not optimized" for battery/doze purposes.
    I installed the Nougat update on my S7 last night, and just realized that my Gmail isn't syncing at all. I can see all of my previous messages, but didn't receive any new email on my phone since before the update last night. The Hotmail account that I access through the "Email" app on my phone seems fine. Did anyone find a solution yet?
    03-29-2017 06:05 PM
  6. peekayro's Avatar
    I've been experiencing the same issue. Crazy delays, very annoying!
    I find myself constantly checking my gmail for messages and everytime, there are a few more that pop up.

    What to do??? Has anything worked for anyone?
    03-30-2017 02:14 PM
  7. TechNut79's Avatar
    See my reply above. Did it work for anyone?
    03-30-2017 06:26 PM
  8. Rich Bruck's Avatar
    See my reply above. Did it work for anyone?
    04-04-2017 10:06 PM
  9. Rich Bruck's Avatar
    Yes -- I tried it. Didn't work. Gmail so not syncing.
    04-04-2017 10:06 PM
  10. jkayakj's Avatar
    Make sure the Samsung optimization thing isn't killing the app... Go into the app settings and then battery and make sure it says "not optimized"
    04-04-2017 10:50 PM
  11. Mahi R's Avatar
    My gmail won't sync when the screen is in sleep mode for a while. Which literally sucks, as I need to turn the screen on to see there is any notification. When I woke up in the morning and check the phone I saw no gmail notification but after few mins I saw notifications coming one by one, which is ridiculous. Because the email were sent hours ago.
    Any solution to it?
    04-10-2017 01:04 PM
  12. TechNut79's Avatar
    Go into your battery settings and check to make sure GMail isn't optimized. That's probably doing it.
    04-10-2017 05:59 PM
  13. whosright's Avatar
    Just started having this issue the last couple days.. no fix yet
    In my s-7 I go into applications>application manager>open Gmail> scroll down and make sure Notifications is set to allowed.
    TechNut79 likes this.
    04-11-2017 05:49 PM
  14. Distrack's Avatar
    In my s-7 I go into applications>application manager>open Gmail> scroll down and make sure Notifications is set to allowed.
    it is obviously set to allowed since we receive the notification but sometimes only after 2-5 minutes (even 20 minutes sometimes) after my tablets/Thunderbird/backup phone received them.

    Very annoying.

    I disabled the battery optimization and will report back in a few days.
    TechNut79 and Wesley1 like this.
    04-12-2017 07:03 PM
  15. Distrack's Avatar
    Make sure the Samsung optimization thing isn't killing the app... Go into the app settings and then battery and make sure it says "not optimized"
    well that works for me, Thanks a lot !
    04-13-2017 12:38 PM
  16. whosright's Avatar
    it is obviously set to allowed since we receive the notification but sometimes only after 2-5 minutes (even 20 minutes sometimes) after my tablets/Thunderbird/backup phone received them.

    Very annoying.

    I disabled the battery optimization and will report back in a few days.
    Go into settings> accounts> g-mail> make sure sync e-mail is toggled on! Also go to settings> notifications> scroll down to g-mail, make sure it is toggled on. Last, go to Settings> applications> application manager> scroll down to g-mail> tap to OPEN> scroll to notification...make sure it says allowed. If it says blocked, change to allow...That is everything I can suggest checking, good luck!
    04-13-2017 06:14 PM
  17. Distrack's Avatar
    Go into settings> accounts> g-mail> make sure sync e-mail is toggled on! Also go to settings> notifications> scroll down to g-mail, make sure it is toggled on. Last, go to Settings> applications> application manager> scroll down to g-mail> tap to OPEN> scroll to notification...make sure it says allowed. If it says blocked, change to allow...That is everything I can suggest checking, good luck!
    read the messages above your's, problem solved (in my case)
    04-15-2017 07:01 PM

Similar Threads

  1. Samsung Email App - not getting VIP notifications?
    By wk123 in forum Samsung Galaxy S7
    Replies: 13
    Last Post: 10-21-2017, 11:52 AM
  2. How do I remove my exchange account from gmail?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-14-2017, 03:47 PM
  3. Phone calls cutting out because of battery notification
    By DaniJean44 in forum Samsung Galaxy S6
    Replies: 4
    Last Post: 03-14-2017, 03:45 PM
  4. Replies: 1
    Last Post: 03-14-2017, 03:27 PM
  5. Huawei P7mini stuck after factory reset
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-14-2017, 01:40 PM
LINK TO POST COPIED TO CLIPBOARD