1. AC Question's Avatar
    All right, so I think I've absolutely screwed my S7 over.
    Before I begin, it's an International S7 with stock android 7.0, just recently got the update.
    I originally wanted to root my S7 and did and attempted to do so with Odin and a CF-auto-root.
    When I booted up after Odin did its thing, I got stuck in a boot-loop of Samsung flashing and got obviously pretty worried. Did my best to do different things to fix it, googled solutions with no luck.
    I deleted the cache partition and factory reset it a couple times through the recovery menu but had no luck with the boot-loop, or so I thought.
    I left it for a solid hour and came back to find it working fine, and booting into stock android...
    Unfortunately, when I came back into my factory reset android, my Wifi wouldn't turn on and my camera wouldn't turn on. I've tried factory resetting it once again, restarting it, etc. With no luck.

    Now I'm at odds to how I can fix my camera and Wifi, obviously two very important things in my phone. I had thought that if I loaded a custom ROM on to it I might have some luck but trying to install TWRP wouldn't work (also didn't work on my S6 I've been testing on parallel to my S7 while I've had this crisis) and now I really don't know what to do. USB Debugging and OEM unlocking are both on, on both devices with no luck.

    Please help and advise me on what to do next. Thanks!
    04-08-2017 06:07 PM
  2. smvim's Avatar
    ... my Wifi wouldn't turn on and my camera wouldn't turn on. I've tried factory resetting it once again, restarting it, etc. With no luck.
    Going by what you've stated above, I'm going to take a guess that it's related to the ROM you used. Either it has some kind of corruption or it's not the exact ROM for your S7. You might want to try re-downloading it and try to re-flash again. Also which version of Odin did you use? Try using the version recommended for the version of Android you're flashing:
    Download Odin (All Versions) for Samsung Galaxy Devices
    Something just isn't right -- if you couldn't get a custom Recovery installed that might also be part of the problem.

    If all else fails, try going back to a stock ROM instead. At least get your S7 back up and running and then take on the project of flashing a custom ROM again. (Note, a custom Recovery isn't required for stock ROMs, but a custom Recovery is a must when there's a custom ROM.). I'd recommend using either updato or sammobile for Samsung stock ROMs, both sites verify the firmware to be legit. You're International S7 model I.D. is SF-G930F, yes?
    Download Firmware – Samsung Update
    If you do re-flash the ROM again, you might want to then boot up into Recovery Mode and wipe the system cache partition. And as far as Factory Resets, keep in mind that only wipes the /data partition, where your personal data is stored. It does not have any affect on any of the system partitions at all. A FR won't fix a corrupted operating system because it does not have anything to do with the actual operating system.
    CalumWebb0 likes this.
    04-08-2017 09:27 PM
  3. CalumWebb0's Avatar
    Hey smvim,
    Thanks for your response.

    To be entirely honest I genuinely doubt that I installed a ROM as I had hoped to download Samsung's stock ROM to my SF-G930F. Unfortunately, because SamMobile was down, I couldn't. That was until my S7 miraculously awoke, but with WIFI, Bluetooth, Mobile Hotspot, Camera all not functioning and frequent restarts out of the blue. As well as, of course breaching my Kies Warranty and in turn infringing my store warranty which would've entitled me to a new S7 had I not attempted to Root it in the first place...

    Initially, I had tried to root with CF-Auto-Root which caused the initial problems and I did so with Odin3.10.6 which looking through your provided links was the incorrect choice.

    BTW, the CF-Auto-Root version I installed was "CF-Auto-Root-herolte-heroltexx-smg930f.tar" Which I thought was correct for my model.

    What does suprise me, is that I did clear both the system cache partition and Factory Reset multiple times, with no luck in regard to my Camera and the other problems mentioned above... I did this through the Android Recovery Menu but unfortunately, I can't access that now because in my attempt to install TWRP I have the message "Recovery is not Seandroid enforcing".

    I think I'm going to go ahead and try to flash the Samsung stock ROM once it downloads, but will I not need to first wipe my phone before hand?

    Many Thanks, your help and links have been incredibly useful!
    04-10-2017 12:03 PM

Similar Threads

  1. why can't I update my Galaxy J5 SM-J500F?
    By AC Question in forum Ask a Question
    Replies: 9
    Last Post: 05-13-2017, 03:59 PM
  2. Replies: 2
    Last Post: 04-09-2017, 03:24 PM
  3. I dropped my phone, a Galaxy 5s and it will not turn on.
    By AC Question in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-09-2017, 12:26 AM