1. firesinis's Avatar
    - Bought new October 2016, unlocked Exynos Galaxy S7

    - Have been using it without issues until roughly one month ago, when it started to randomly freeze reboot itself, sometimes after corrupting the graphics of whatever screen it was on just prior to rebooting. I chalked it up to it needing a Factory Reset, which I was planning to do shortly.

    - Last week I had the issue where the phone worked but the screen didn't turn on; the LED worked, I could hear notifications etc but the screen would remain unlit. I forced it to reboot by holding power and volume down, and it seemingly returned to normal after the reboot.

    - Yesterday morning I was browsing Facebook when the phone froze and I got a corrupted screen, except this time instead of rebooting it just shut down itself and became unresponsive. Plugging it on wasn't doing anything, no orange charging LED; power and volume down didn't work.
    Went on the phone with a Samsung rep and they told me to plug it to the charger and hold power + home + volume down for 15 seconds; A blue screen came on warning about installing a custom OS, rep told me to push volume down and decline the installation. I did, the phone turned itself off, then the battery charging icon on the middle of the screen came on as well as the orange LED. I let it charge up to about 30% and then tried to turn the phone on; the phone started bootlooping at the point where it animates the Samsung logo.

    - Thought I'd try to wipe the cache partition, so I pressed power + home + volume up and it came to the blue maintenance screen with the white droid, but instead of proceeding to the part where it shows a dead droid, several black rectangles started to blink in and out across the whole screen, not always on the same places. Then shortly the phone went dead again, without responding to anything.

    - After maybe half an hour I could get it to the blue custom OS screen again with power + home + volume down, and upon pressing volume down to decline I could get the battery charging icon again, but after a few seconds the green animated dots that come up when it's charging just froze, the phone went black, and that's it.

    - Can't get it to respond to anything since; power + home + vol [up/down] doesn't do anything. Samsung rep has no help to offer except suggesting I take it to an authorized repair center.
    Anything else I can try?
    07-25-2017 08:17 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. I would consider contacting Samsung. You should still be within their warranty period.
    07-25-2017 09:55 AM
  3. CWinkler's Avatar
    Sounds like you have been in contact with Samsung, and you should be under warranty. Unsure how close you are to authorized repair center and if they'd honor warranty. Might also try your carrier and see if they have any replacement program. I've had several phone issues, and my carrier (US Cellular) has helped with replacement (refurbished) phones so that I was never without phone. Your carrier might offer something similar.
    07-26-2017 07:16 AM

Similar Threads

  1. Replies: 9
    Last Post: 08-07-2017, 09:06 AM
  2. My phone is not charging properly
    By jacob_trolls420 in forum General Help and How To
    Replies: 2
    Last Post: 07-26-2017, 03:00 AM
  3. Replies: 1
    Last Post: 07-25-2017, 08:22 AM
  4. What is this new weird icon?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-25-2017, 07:57 AM
  5. Replies: 0
    Last Post: 07-25-2017, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD