1. monicakm's Avatar
    I joined the Google Beta program when I needed the beta version of Google Play Services last month to fix the packet flooding issue with casting devices such as Chromecast and Google Home. It fixed it but I forgot to leave the beta program. Now Google Play Services (GPS) has a new beta update and it seems to have made things worse again with my Google Home devices and GPM. I've left the beta program and have tried the instructions I've found on line on how to uninstall GPS and then reinstall to the latest non-beta version (v11.9.75).

    If I go to Settings/App Manager/GPS, Disable is grayed out. If I tap on the 3 vertical dots in the upper right corner to "uninstall updates"/Replace this app with the factory version?/ok, it says "can't uninstall because this pkg is an active device administrator. I found the following but can't find it on my S7...If the Disable checkbox is grayed out, then you have to carry out an intermediate step: go to Settings > Security > Device administrators and disable the Android Device Manager. Nor can I find anything that resembles Security/Device Administrators.

    If I go to the App Store, I have an option to Deactivate. I get the following message, "this app is a device admin and must be deactivated before uninstalling". I click OK and nothing happens. I'm running Android 7.0

    Does anyone have a way for me to remove this version and get back to the non-beta version of Google Play Services?

    Thanks!
    02-08-2018 12:03 AM
  2. monicakm's Avatar
    Further reading says I have to root my S7 to uninstall GPS. Not gonna do that! Is there a way to roll back to the stable version?
    02-08-2018 12:11 AM
  3. chanchan05's Avatar
    Open settings, tap the magnifying glass on the upper right, type device admin, and it will take you straight there.

    On the S7 the settings you were looking for are under lock screen and security>other security settings>device administrators. But there's always the settings search anyways. You can use that to look for most settings options.
    02-08-2018 12:11 AM
  4. monicakm's Avatar
    chancechan, typing device admin results in "no results found". Under Lockscreen and Security/Other Security Settings (I looked there before posting here) I don't have a device administrators option I have Phone Administrators but the only thing under that is
    Find My Phone
    Alfred
    Capitol One
    Lookout
    Mastermind
    Wait....let's see what happens when I UNcheck "Find My Phone". It's the only thing checked.
    Bingo! Now I have the option of disabling GPS. After disabling it I set GPS back to factory defaults
    and v.11.5.09. And now I can update to the latest non-beta version (11.9.75). WHEW!!!
    Thanks so much for your help. I saw the Phone Admin but didn't see how those apps had
    anything to do with what I was looking for. I just needed a little guidance Thanks again!
    02-08-2018 02:21 AM
  5. chanchan05's Avatar
    Well that's weird. That's how my S7Edge on Nougat is setup
    02-08-2018 03:06 AM
  6. monicakm's Avatar
    Might be a carrier thing. I'm on Verizon.
    02-08-2018 02:15 PM

Similar Threads

  1. Alarm - issues with Allen set but not going off
    By Madam ImAdam in forum Ask a Question
    Replies: 6
    Last Post: 02-15-2018, 10:05 AM
  2. Why my recent message come to the top of list?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2018, 01:25 PM
  3. What feature have i disabled to store contacts
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2018, 12:08 AM
  4. How can I connect my Lenovo A5000 to computer?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-07-2018, 10:23 PM
  5. Can anyone tell me what this symbol means?
    By theanondude in forum Samsung Galaxy S7 edge
    Replies: 0
    Last Post: 02-07-2018, 10:13 PM
LINK TO POST COPIED TO CLIPBOARD