1. jackvogel's Avatar
    My Galaxy S7 has recently develop a problem. YouTube videos will not load while I'm using mobile data. This includes both the app and in browsers. It works just fine over Wi-Fi.

    In a browser I simply get a timeout error. In the app the names of the videos and the channels all load up but the chanel icons are just dots and the thumbnails of the videos are all gray with the video's time length in the bottom right corner. If I tap a video it goes to that videos page with all of the recommendations still grayed out and the video never actually loads. I've checked the settings and made sure that the YouTube app has permission to use mobile data and I've already cleared its data cache several times.

    Anyone got a clue on this one?

    EDIT: Problem persists, even if wifi is off. Also, I tested this out on the Vimeo app. No problem getting their videos to load so the problem seems to be exclusively with YouTube.
    CPDICKERSON likes this.
    05-23-2018 06:12 AM
  2. pkcable's Avatar
    Yes couple of things, maybe it IS your connection, have you run any speed tests on it?

    https://play.google.com/store/apps/d...roid.speedtest

    Also maybe a weak WiFi signal is messing you up? Try turning off the WiFi radio in your settings, THEN try YouTube.
    05-23-2018 07:59 AM
  3. jackvogel's Avatar
    Yes couple of things, maybe it IS your connection, have you run any speed tests on it?

    https://play.google.com/store/apps/d...roid.speedtest

    Also maybe a weak WiFi signal is messing you up? Try turning off the WiFi radio in your settings, THEN try YouTube.
    DL speed is testing at 67 MBPS and the problem persists even if I turn the Wi-Fi off.
    05-23-2018 08:34 AM
  4. pkcable's Avatar
    Ok I was poking around in my YouTube app looking for a setting that might be the root of your problem, and guess what I found? Click on the upper right hand corner of the YouTube app, on your avatar, which takes you to Account, then click on Settings, then General, and then you will see the second toggle Limit Mobile Data Usage, make sure THAT is turned off!
    05-23-2018 11:42 AM
  5. jackvogel's Avatar
    Nope, that setting is already off.
    05-23-2018 01:25 PM
  6. pkcable's Avatar
    Nope, that setting is already off.
    I wonder if its a carrier issue? They probably have the ability to block video or slow it down. In fact I know some of them do it! And of course any restrictions they place would not apply when WiFi is active. Try calling your carrier, in a similar situation calling the carrier worked for my friend. She was suddenly blocked for many/most websites. It seems someone accidently turned on content blockers on he browsing at the carrier level. This is usually done by parents on their children, BUT my friend is a 50 something woman! lol The carrier was able to fix it. Maybe your situation is similar (but different) and they can help?
    05-23-2018 02:32 PM
  7. Rajveer Singh Rathore's Avatar
    Just go to your mobile's setting then go to apps and then go to data usage control and search for youtube and click on allow instead of wifi only.
    My problem was solved by this.
    12-06-2018 01:51 AM

Similar Threads

  1. Replies: 1
    Last Post: 05-25-2018, 09:48 PM
  2. I can't send a message on my samsung 8 using my gmail account. Help please.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-22-2018, 09:42 PM
  3. I have a problem with storing new data.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-22-2018, 08:59 PM
  4. Not able to use samsung icon x for whatsapp calling
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-22-2018, 07:32 PM
  5. my data stop working on galaxy j7 sky pro
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-22-2018, 06:57 PM
LINK TO POST COPIED TO CLIPBOARD