1. amyinva's Avatar
    Photos sent by text won't download at all, keep getting errors. I have it set to auto-retrieve MMS. Mobile data is turned on. Is there a setting I'm missing?
    04-21-2017 08:36 AM
  2. cnjvh's Avatar
    Some phones/carriers won't allow MMS over Wi-Fi. Try leaving cell data on and turning Wi-Fi off while trying to access the MMS message.
    Morty2264 likes this.
    04-21-2017 08:58 AM
  3. cboekhoven's Avatar
    I am running into the same problem with my S8+ on verizon. I can disable Wi-Fi and sure enough the MMS comes through no problem. Problem is, I could receive MMS while Wi-Fi was enabled on my Pixel XL that was on Verizon so this doesn't seem like a case of the "my carrier is blocking this from happening the way common sense would lead you to believe it should work". It seems like a legitimate bug/problem.
    04-24-2017 09:11 AM
  4. thoml67's Avatar
    Me and a co worker are having the same problem on Tmo. Can't send or receive MMS or group text messages while WiFi is turned on however just like you, when I turn off WiFi, they work. I had a Nexus 6 on Project Fi and had no issues whatsoever.
    04-24-2017 09:25 AM
  5. gtixpress's Avatar
    I noticed an issue this weekend in that Google's "Android Messages" won't send MMS while Wifi is connected. Just normal SMS would work. However, with Wifi connected, the default Verizon Messages+ app would send MMS just fine. Pretty annoying.
    04-24-2017 11:19 AM
  6. psurob55's Avatar
    had an issue with MMS on verizon using textra the other day. Went away after a reboot.
    04-24-2017 11:31 AM
  7. Morty2264's Avatar
    Are you still experiencing this issue, OP? As another user stated, try keeping your WiFi off while trying to download MMS; and see what happens!
    04-24-2017 11:35 AM
  8. kevron75's Avatar
    Leaving wifi off to retrieve an MMS is not a good answer. I rely heavily on MMS messages as my work sends group messages among employees. I need to hear the notification without manually turning off wifi. I also need to leave wifi on for several reasons including applications we use at work which require wifi. This is a serious issue for me which needs to be addressed by Samsung ASAP.
    04-24-2017 02:13 PM
  9. PJRed2008's Avatar
    This is a serious issue for me which needs to be addressed by Samsung ASAP.
    Have you lodged a ticket with Samsung support? Also, as noted above, have you tried other message apps?
    04-24-2017 02:22 PM
  10. thoml67's Avatar
    I installed Textra and it resolved the issue. Seems to be with the stock Android messaging app that it doesn't work on.
    Morty2264 likes this.
    04-24-2017 03:15 PM
  11. Morty2264's Avatar
    I installed Textra and it resolved the issue. Seems to be with the stock Android messaging app that it doesn't work on.
    Textra is an amazing app! I've upgraded to the pro version and it was well worth it! Glad your issue is fixed!
    thoml67 likes this.
    04-24-2017 08:03 PM
  12. Tahoe916's Avatar
    I think it's related to wifi calling being the default. Turning off wifi calling may fix it. I've had this problem with my last two phones and using Textra was my solution as well.
    tube517 likes this.
    04-24-2017 08:40 PM
  13. amyinva's Avatar
    Sorry so late in coming back to this. I switched to Textra, rebooted my phone and it's been ok since. Thanks all!
    Almeuit likes this.
    04-26-2017 12:14 PM
  14. Almeuit's Avatar
    Sorry so late in coming back to this. I switched to Textra, rebooted my phone and it's been ok since. Thanks all!
    Nice .
    04-26-2017 12:16 PM
  15. rpoli86's Avatar
    I've been using Textra for a year now and this MMS problem is still happening on the GS8+. It's driving me crazy as my company relies on texting heavily for work.
    06-22-2017 09:49 AM
  16. tube517's Avatar
    I think it's related to wifi calling being the default. Turning off wifi calling may fix it. I've had this problem with my last two phones and using Textra was my solution as well.
    This is usually the answer. Turning off wifi calling is the first thing I do when faced w/this issue.

    For T-mobile, I usually have to add a new APN setting with ipv4/ipv6 replacing ipv6 and keeping the other settings from the default setting.
    06-23-2017 08:59 AM
  17. Almeuit's Avatar
    I think it's related to wifi calling being the default. Turning off wifi calling may fix it. I've had this problem with my last two phones and using Textra was my solution as well.
    This very well could be the problem. I don't have WiFi calling on at all and don't run into any issues with MMS on my Verizon S8 w/ Textra (or phones before it).
    06-23-2017 09:41 AM

Similar Threads

  1. Annoying pop up on silent mode
    By marsnd in forum Ask a Question
    Replies: 1
    Last Post: 04-22-2017, 09:25 AM
  2. galaxy tabs2 wont read sd card on plugin card reader
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-21-2017, 06:58 PM
  3. Replies: 1
    Last Post: 04-21-2017, 06:56 PM
  4. Replies: 1
    Last Post: 04-21-2017, 06:50 PM
  5. Replies: 1
    Last Post: 04-21-2017, 08:55 AM
LINK TO POST COPIED TO CLIPBOARD