05-01-2018 04:19 PM
62 123
tools
  1. PCPIMP's Avatar
    This is the one I use to disable heads up notifications. It a little work to setup the ADB if you not familiar with using command prompt. But it works great. No more heads up.

    Search Xda for how to install ADB.
    Worked Great on my S8+ THANKS!!!
    08-12-2017 06:08 PM
  2. My two cents's Avatar
    Desperate for a solution here. I hate the pop up. Pls can someone provide a solution. The ADB option does not work on S8 plus.
    There is a two-step workaround:
    1. Enable Chat Heads in Messenger settings. You can get there by tapping your profile icon on top right corner of the app.
    2. Remove Appear on Top permission from Messenger by going to Android's App settings, from the three dot menu, pick Special Access and then Apps that can appear on top, scroll down to Messenger and flick the switch off.

    Now all Messenger popups are disabled because Chat Heads cannot work without Appear on Top permission and all you get is regular notification bar icon and notification sound on new messages.

    This guide is for Samusung phones only. Basic idea is the same for other brands as well but the menu structure may vary.
    08-26-2017 07:32 AM
  3. Wil-Br's Avatar
    I found a solution, first go to settings 》notifications 》 from all apps choose the application you want to hide the notifications from ( whatsapp for example) and inside the (app notification) choose the option show silently. This will not allow the heads up preview to show but it will allow the icon to apear in the upper corner as u receive a message unfortunately you will miss the sound/ and vibration as well. But i downloaded a third party application ( good vibrations ) and choose this application to sound/vibrate when i receive a WhatsApp message. And problem is solved...yahuuuu... i hope it works for you if it does i appreciate your support in folowing me on Instagram ( mayyoub )

    -------- Portuguese ----------

    Muito obrigado.

    Eu tenho um Samsung A5 2017 (Brasil). Com o Android 6.0 eu posso desligar os popups, porém, quando atualizou para android 7 nougat, simplesmente removeram a opção para desativar popup do whatsapp.

    Com sua ajuda, em Configurações / Notificações / Whatsapp eu ativei SILENCIO. Mas, não tinha mais a notificação por som ou vibração.

    Instalei o app "Good Vibrations", e ativei a vibração para mensagens para o Whatsapp.

    Problema resolvido. Obrigado.

    --------- English ---------

    Thank you very much.

    I have a Samsung A5 2017 (Brazil). With Android 6.0 I can turn off popups, however, when upgraded to android 7 nougat, they simply removed the option to disable whatsapp popup.

    With your help, in Settings / Notifications / Whatsapp I activated SILENCE. But I no longer had the notification by sound or vibration.

    I installed the "Good Vibrations" app, and I activated the vibration for messages to Whatsapp.

    Problem solved. Thank you.

    ----------
    08-31-2017 07:33 AM
  4. Wil-Br's Avatar
    There is a two-step workaround:
    1. Enable Chat Heads in Messenger settings. You can get there by tapping your profile icon on top right corner of the app.
    2. Remove Appear on Top permission from Messenger by going to Android's App settings, from the three dot menu, pick Special Access and then Apps that can appear on top, scroll down to Messenger and flick the switch off.

    Now all Messenger popups are disabled because Chat Heads cannot work without Appear on Top permission and all you get is regular notification bar icon and notification sound on new messages.

    This guide is for Samusung phones only. Basic idea is the same for other brands as well but the menu structure may vary.

    ---- Portuguese -------

    Isso não funciona para o Samsung A5 com Android 7 nougat. O whatsapp não aparece na lista de aplicativos com "special permissions"

    Testei de tudo e só funcionou usando o modo SILENCIOSO para o Whatsapp e instalando o "Good Vibrations" aplicativo para ativar a vibração com mensagens do Whatsapp.

    ---------- English --------

    This does not work for the Samsung A5 with Android 7 nougat. Whatsapp does not appear in the list of applications with "special permissions"

    I tested everything and only worked using SILENT mode for WhatsApp and installing the "Good Vibrations" application to activate the vibration with WhatsApp messages.

    ----
    08-31-2017 07:38 AM
  5. Adidasfan-90's Avatar
    Figured out the fix.

    1.Messaging app info
    2. More settings
    3. Tap on notifications
    4. Disable "preview messages

    This is for the s8/s8+
    09-04-2017 02:12 AM
  6. Reviews Points's Avatar
    Samsung Galaxy S8 How to disable notification Pop-Up - Resolved If you receive a new WhatsApp or text message on your Samsung Galaxy S8, you will be shown a small pop-up at the top of the screen, if you are working with the smartphone or playing a game. If you want to deactivate this type of notification of new messages, then this works on the Samsung Galaxy S8 as follows: How to disable Android Pop-Up for WhatsApp and messages Open the app menu and there the Android system settings Go to "Display" and "Side screen" Tap "Side light" and deactivate it using the master control You have now disabled the pop-up. However, you are now also notified via pop-up within WhatsApp. To do this, you must also deactivate this setting. Disable pop-up notification from WhatsApp on the Samsung Galaxy S8: To do so, please open WhatsApp. In the upper right corner, touch the icon with the three dots, and then tap Settings. Select notifications and then select "Pop-Up Notification": No pop-up You now have the pop-up, which is deactivated by the Android system (for WhatsApp and SMS), and the notification pop-up of WhatsApp.
    09-10-2017 08:26 AM
  7. anon(10339219)'s Avatar
    I moved WhatsApp over to the Private Folder (a Samsung app) and this stops message previews. You still get the icon, sound, and vibration, but must actually open the Private Folder to access the app.
    10-17-2017 10:00 AM
  8. Ihawki's Avatar
    So I've been too lazy to post this but after moving to a note8 I realized the pain you all are feeling and that I would feel if I thought my $600-1000 phone couldn't do this. The solution is the best mentioned yet, trust me. I tripped upon the answer to this before I even knew it wasn't possible otherwise. Let's just say this is Bixby's shining moment.

    So to be clear, this allows you to TOGGLE the ability to receive notification for apps WITHOUT the pop-up bubble coming up AT ALL. You will still see the icon in your notification bar (which I'm assuming you all want) and receive any sound/vibration you have set up..just no pop up message whatsoever.

    There is one caveat here..it is that it's an all or nothing toggle. All apps lose the pop up HUD or they all have it. However, when you see how easy it is to toggle it back you'll probably be okay with this.

    Instructions:

    -Download bxactions. This is an app that allows you to use the bixby button for non bixby commands such as opening other apps or utilities etc. It allows a few different types of button pushes to allow a few different custom commands.

    -follow directions to enable "control mode". (note: does require adb but it was super easy to do, granted it took me a couple tries to get it to work for some reason while doing nothing different)

    -go into bxactions settings and look for the different actions the types of button pushes can enable and you'll see one for HUD notifications.

    -hand someone your phone and don't want them to see your pop ups? Simply press, double press or hold the bixby button to disable. They hand it back? Just perform the same press or the button.

    This was used daily on my S8+ for a couple months. Just got a Note8 and about to do the same (hence feeling your pain).

    Note: I can't remember if you can use bixby as well as enable these custom button presses. Hopefully someone will look this up.

    Hope that helps!
    10-23-2017 09:36 PM
  9. andresinclan's Avatar
    I found a solution, first go to settings 》notifications 》 from all apps choose the application you want to hide the notifications from ( whatsapp for example) and inside the (app notification) choose the option show silently. This will not allow the heads up preview to show but it will allow the icon to apear in the upper corner as u receive a message unfortunately you will miss the sound/ and vibration as well. But i downloaded a third party application ( good vibrations ) and choose this application to sound/vibrate when i receive a WhatsApp message. And problem is solved...yahuuuu... i hope it works for you if it does i appreciate your support in folowing me on Instagram ( mayyoub )
    Give this man a beer !! This indeed solves the problem!!
    I now can receive acoustic and vibrational notifications while I'm in the HOME SCREEN of my galaxy s8
    The good vibrations app can be downoaded from the third-party app downloader named Apptoide (https://aptoide.mx.aptoide.com); the app - icon is the android character in blue, surrounded by vibration waves.
    12-08-2017 02:11 PM
  10. XOXO2510's Avatar
    I FOUND A SOLUTION WITHOUT HAVING TO INSTALL ANY EXTRA APPS!

    So we have all been getting the annoying heads up notifications that we don't want appearing on our phone when it's unlocked right?! Well I found a solution after playing round with my phone. First I changed the notification settings in my apps for example WhatsApp, Facebook messenger etc by going to settings > notifications > select each app you want to stop heads up from > allow notifications > show silently. Toggle this to on.

    Now wait I've not finished, the go back into settings > accessibility > notification reminder and turn this on. Then turn sound on and vibrate on and select the apps you wish to receive notifications from. Then there you have it , this stops the heads up but then then reminds you 1 minute later that you have a notification! I'm sure a 1 minute wait won't hurt to stop those heads up!
    12-14-2017 04:22 PM
  11. Rawan Khaled's Avatar
    I found a solution, first go to settings 》notifications 》 from all apps choose the application you want to hide the notifications from ( whatsapp for example) and inside the (app notification) choose the option show silently. This will not allow the heads up preview to show but it will allow the icon to apear in the upper corner as u receive a message unfortunately you will miss the sound/ and vibration as well. But i downloaded a third party application ( good vibrations ) and choose this application to sound/vibrate when i receive a WhatsApp message. And problem is solved...yahuuuu... i hope it works for you if it does i appreciate your support in folowing me on Instagram ( mayyoub )
    Does this solution disable the LED? Because I did all what you said and I don't get the LED notification
    03-10-2018 05:20 AM
  12. Sara Khan3's Avatar
    OMG...like u all..i was also too much annoyed with this whatsapp message preview on screen from almost 6 months...i also tried many things bt failed...yesterday i read all these comments..tried some of them..bt it was not exactly what i wanted..so a while ago i was searching by myself and guess what i found the solution..m soo happy guys..i was too much tensed abt this..well let me help u too..
    Go to Setting>Apps>whatsapp
    Then click on notifications
    It wil further open
    Under Chats category,u wil see Group Notifications and Message notifications
    Click on Message notifications..it wil further open
    U wil see "Importance" written under the On button..Click on "Importance"..there wil be options like Urgent,High,medium,low
    Select "High"
    This is it...u only have to uncheck Urgent and Check High...even u wil also see that under High,it wil be written that there wil be only sound notification..
    Check this and try it...
    Its too much easy..and m so relieved now..may ur problem get fixed too
    And yes u should turn off the pop up notification from whatsapp also..cz may be it wil cause a problem..bt i had made it off already
    05-01-2018 04:19 PM
62 123

Similar Threads

  1. Verizon Galaxy S8 Switching languages with S8+
    By Bugwart in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 09-07-2017, 07:56 PM
  2. My new S8+ doesn't show up in My Products on Samsung Shop app
    By Praetorian27 in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 04-23-2017, 10:49 PM
  3. does gionee m5 lite get nougat update?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-23-2017, 03:49 PM
  4. Replies: 2
    Last Post: 04-23-2017, 01:27 PM
LINK TO POST COPIED TO CLIPBOARD