05-01-2018 04:19 PM
62 123
tools
  1. widget2k13's Avatar
    same as the issue i had on the s7 , can't stop the preview on the home screen when you get a whatsapp etc.
    there was a fix on the s7 that worked perfect but since getting the s8 im back to square one as the fix for the s7 doesnt work on the s8
    why can samsung not just leave the option in to hide the popup and leave the sound/vibration on ? they did it all the way through up to nougat
    04-23-2017 01:53 PM
  2. cedjunior's Avatar
    Are you referring to the notifications on the lock screen? That can be disabled in the Lock Screen and Security options.
    04-23-2017 03:15 PM
  3. widget2k13's Avatar
    No not on the lock screen on the main home screen, when you get a message or WhatsApp etc it shows a notification on top of screen with the message so everyone can see your private messages if your phones unlocked or as mine is always in a phone holder in the car, you used to be able to turn this off up until they released nouget on the s7
    04-23-2017 03:34 PM
  4. cedjunior's Avatar
    Ah. I hadn't noticed that because I use a lock screen, but I got a message earlier and sure enough it showed up at the top of the home screen. I don't know about whatsapp, but I disabled it in the stock messaging app by going to Message Settings>Notifications and disabled Pop-up display and Preview message.
    04-23-2017 06:26 PM
  5. widget2k13's Avatar
    If I disable pop up display the only option is to to stop all, so no pop up no alert no sound and no vibration, you have to have everything or nothing, they did the same on s7 it's ridiculous but some clever person found a way around it with a adb program but it doesn't work on s8
    04-24-2017 01:39 AM
  6. widget2k13's Avatar
    Here is a link to the post on the s7 I started
    http://forums.androidcentral.com/sam...fications.html
    04-24-2017 01:43 AM
  7. widget2k13's Avatar
    Am I the only one that has this annoying problem? It's making me want to send my phone back, you can't have any privacy while your phones on, that is so wrong, what are Samsung thinking about surely people don't want other people seeing their messages all the time?
    04-25-2017 01:47 AM
  8. the_munc_e's Avatar
    Use a different text app and don't use WhatsApp
    04-25-2017 04:45 AM
  9. widget2k13's Avatar
    It's not just WhatsApp its everything
    04-25-2017 05:17 AM
  10. ol_jackburton's Avatar
    It's not just WhatsApp its everything
    with textra you have the option to make the heads up not show any of the message text, just that you have one.
    04-25-2017 05:38 AM
  11. widget2k13's Avatar
    You have that option in WhatsApp as well but it doesn't work
    04-25-2017 06:49 AM
  12. mundo472's Avatar
    Am I the only one that has this annoying problem? It's making me want to send my phone back, you can't have any privacy while your phones on, that is so wrong, what are Samsung thinking about surely people don't want other people seeing their messages all the time?
    No, you aren't. And it's very frustrating. May do a video call to support later to figure out how to customize notifications for apps (like having just a notification in hub but not a pop-up) as well as for specific contacts.
    04-26-2017 07:54 AM
  13. stascha's Avatar
    same issues with my S8 - really anoying. if this cannot be solved i'll switch back to my Huawei Mate 9 as there are much more possibilities about the notification
    s8 and nougat heads up notifications-detail-4-5-2.jpg
    04-27-2017 03:49 AM
  14. widget2k13's Avatar
    That's what it should be like on this, don't know why they can't of just included an option to turn off notification heads up or at least to hide the content but still let you know you have a message, can't have my phone unlocked lying around or in my car controlling my music now otherwise anyone can see my messages, absolutely crazy
    04-27-2017 09:10 AM
  15. Beulahaso's Avatar
    You can actually hide the notification but you have to select one by one on the application you want hidden like Skype , emails, text messages, whatsapp etc. Go to settings then notification choose advanced. Here you have a list of the application you want to hide. I hope this helps.
    04-29-2017 02:19 AM
  16. widget2k13's Avatar
    yes you can hide them but you dont get any notification at all, i want to get notification just not splashed on the top of my screen showing my private messages to anyone who may be looking at my phone at the time
    it makes you paranoid to show anyone anything on your phone like photos etc because if a message comes through etc they can read it, its a stupid crazy idea and one i really dont like and can see me getting rid of the phone if there is no way to fix it
    04-29-2017 03:21 AM
  17. widget2k13's Avatar
    No, you aren't. And it's very frustrating. May do a video call to support later to figure out how to customize notifications for apps (like having just a notification in hub but not a pop-up) as well as for specific contacts.
    did you get anywhere with this with samsung ?
    04-29-2017 03:22 AM
  18. mundo472's Avatar
    did you get anywhere with this with samsung ?
    Never made the call but noticed the "block notifications" button at bottom of the notification pull-down which seems to allow individual app block
    Attached Thumbnails s8 and nougat heads up notifications-20541.jpg  
    04-29-2017 07:15 AM
  19. NickPatong's Avatar
    omg I thought i was the only one who can't deactivate this stupid notification, it's very annoying .. not only because ppl next to you can read your messages but the popup always show up where i have to click something and i have to wait when gone , really really really frustrating.. io hope someone can find a solution or samsung will add an option on the next bugfix update
    04-29-2017 09:28 AM
  20. widget2k13's Avatar
    Never made the call but noticed the "block notifications" button at bottom of the notification pull-down which seems to allow individual app block
    thats ok and fine if you dont want a notification at all from the app but thats not what i need, i still want the notification but just with some privacy
    04-29-2017 05:53 PM
  21. swaziboy's Avatar
    thats ok and fine if you dont want a notification at all from the app but thats not what i need, i still want the notification but just with some privacy
    Hi there. I understand the issue that ur having, I'm having it with WhatsApp and Viber on my s8. Have you found a solution?
    05-03-2017 04:38 PM
  22. widget2k13's Avatar
    no solution yet sorry, seems not many people are too bothered about it ? dont know why not as it drives me crazy.
    05-03-2017 05:39 PM
  23. anon(10230979)'s Avatar
    Am I the only one that has this annoying problem? It's making me want to send my phone back, you can't have any privacy while your phones on, that is so wrong, what are Samsung thinking about surely people don't want other people seeing their messages all the time?
    The ADB thing works for Samsung S8+

    adb shell settings put global heads_up_notifications_enabled 0
    vjoom likes this.
    05-04-2017 07:08 AM
  24. Lacerrbeam's Avatar
    I figured out the issue. Just fixed it on mind. It's in the beacon flashlight settings.
    05-04-2017 06:50 PM
  25. widget2k13's Avatar
    The ADB thing works for Samsung S8+

    adb shell settings put global heads_up_notifications_enabled 0
    Done that loads of times it doesn't work on mine
    05-05-2017 09:26 AM
62 123

Similar Threads

  1. Verizon Galaxy S8 Switching languages with S8+
    By Bugwart in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 09-07-2017, 07:56 PM
  2. My new S8+ doesn't show up in My Products on Samsung Shop app
    By Praetorian27 in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 04-23-2017, 10:49 PM
  3. does gionee m5 lite get nougat update?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-23-2017, 03:49 PM
  4. Replies: 2
    Last Post: 04-23-2017, 01:27 PM
LINK TO POST COPIED TO CLIPBOARD