1. Jacy Hung's Avatar
    I have my Galaxy S8 on hand since the 19th of April, and so far have had a total of 2 issues, one of which being the red tint issue.

    There's this other issue that I just stumbled across, and it's bothering the hell out of me. Sometimes I'd notice that the wifi symbol on the status bar would show an exclamation mark and the wifi would suddenly stop working. All I would do is move my phone a couple inches away and it'll start working again. I can't even watch a YouTube video without suddenly "losing" connection and having to move my phone a bit to resume video playback.

    I thought this was weird because my past phones has never had a wifi range issue. I decided to further diagnose the issue.

    Not only am I not getting a decent connection to the wifi network, the speeds I'm getting off my wifi network are horrendous! I took a comparison against my old phone, the Nexus 6P, and tried MULTIPLE speedtests (on the same server), all with the same kind of results. Extremely slow speeds on the S8 and faster on the 6P. (See Image Below)

    So I'm wondering, am I the only one that has this issue, or are there others out there who are experiencing this as well?

    Like seriously, what kind of madness is this? HUGE difference..
    (I know 19mbps isn't the slowest but I was actually lucky to achieve that speed, usually it's lower than 10mbps.)

    Also, if you look closely at the picture, you can see the wifi symbol in the status bar has the exclamation mark!

    Wifi Stability Issues on the S8-dsc01021.jpg
    04-26-2017 10:54 PM
  2. SpookDroid's Avatar
    Have you tried changing the channel on your router? This could be the issue, especially if on 5GHz
    04-26-2017 11:39 PM
  3. Jacy Hung's Avatar
    Have you tried changing the channel on your router? This could be the issue, especially if on 5GHz
    Both 2.4GHz and 5GHz gave me the issue. BUT.. I figured it out. On the phone's end, make sure Connections > Wi-Fi > ADVANCED > Hotspot 2.0 is ticked to OFF. It was ticked ON for me, and as soon as I ticked it off, I got 71Mbps down. Luckily it was just a stupid toggle and not some major issue.

    Wifi Stability Issues on the S8-screenshot_20170426-210223.jpgWifi Stability Issues on the S8-screenshot_20170426-210214.jpg
    SpookDroid likes this.
    04-27-2017 12:03 AM
  4. Almeuit's Avatar
    Glad you got it fixed. I was going to say the ! usually means it won't use it (so the speed test would have been LTE or something).
    Jacy Hung likes this.
    04-27-2017 01:17 AM
  5. SpookDroid's Avatar
    Glad you got it fixed. I was going to say the ! usually means it won't use it (so the speed test would have been LTE or something).
    Yup. This.
    04-27-2017 10:03 AM
  6. anon(607340)'s Avatar
    Both 2.4GHz and 5GHz gave me the issue. BUT.. I figured it out. On the phone's end, make sure Connections > Wi-Fi > ADVANCED > Hotspot 2.0 is ticked to OFF. It was ticked ON for me, and as soon as I ticked it off, I got 71Mbps down. Luckily it was just a stupid toggle and not some major issue.

    Click image for larger version. 

Name:	Screenshot_20170426-210223.jpg 
Views:	77 
Size:	173.9 KB 
ID:	258371Click image for larger version. 

Name:	Screenshot_20170426-210214.jpg 
Views:	76 
Size:	139.1 KB 
ID:	258372

    More people should be aware of this setting.. IMO it's a security risk for those who value their privacy. Randomly connecting to unknown Wifi's that don't have password protection is never a good idea, and that's basically what it does. I always turn it off.
    04-27-2017 11:31 AM
  7. matty2213's Avatar
    I'm having this very issue, however as you can see, I do not have this option. Mine is an S8+ on EE (U.K), if that has anything to do with it. I've also noticed that when this exclamation bar pops up, it seems to also effect my macbook, but the moment I disconnect my phone from the wifi, the internet on my macbook starts to work again.
    I'm fairly sure this isn't a problem with my router as I've never experienced this before on any device.
    I'm really unsure of what to do as this is becoming a very bothering issue.
    Attached Thumbnails Wifi Stability Issues on the S8-screenshot_20170430-161721.jpg  
    04-30-2017 11:24 AM
  8. Mrrikki's Avatar
    Strange I don't seem to have that setting on my UK phone. WiFi is working well.
    Attached Thumbnails Wifi Stability Issues on the S8-505.jpg  
    04-30-2017 12:29 PM
  9. SpookDroid's Avatar
    I'm having this very issue, however as you can see, I do not have this option. Mine is an S8+ on EE (U.K), if that has anything to do with it. I've also noticed that when this exclamation bar pops up, it seems to also effect my macbook, but the moment I disconnect my phone from the wifi, the internet on my macbook starts to work again.
    I'm fairly sure this isn't a problem with my router as I've never experienced this before on any device.
    I'm really unsure of what to do as this is becoming a very bothering issue.
    It might still be a router issue (ish). Some routers seem to have a problem with Samsung radios unless their latest firmware is applied. You can also try changing channels on your network to see if that alleviates the issue.
    04-30-2017 04:30 PM
  10. steveh552's Avatar
    After reading this I did a test side by side with my iphone 7plus and S8 and the iPhone constantly had 3-4mbs more down than the S8. I don't have a fast connection, only 30mb down and did not even achieve that on either device but it maybe because my son is on playstation and the router is designed to handle that as priority.
    04-30-2017 04:43 PM
  11. Jacy Hung's Avatar
    Just wanted to do a quick update on my issue. So it seems that even after ticking off that box"Hotspot 2.0" to off, the issue still remained.

    I simply ignored it and didn't look further into the issue until today. I looked at some of my routers settings and reverted everything that I had configured previously to my default settings, and my S8 is getting great signal from the 2.4GHz wifi network (still not getting a good enough connection on the 5GHz band). Wifi speeds are much better than before.

    Looks like my S8 just didn't like how I configured my router.
    05-15-2017 03:38 AM
  12. Alec Hanson's Avatar
    I had not changes any settings until I had this issue. The strange thing is that I have an S8 which works fine but my S8+ doesn't.

    So not sure the router issue is the answer for me and not Hotspot 2.0 option
    05-18-2017 06:46 AM
  13. slingshot202's Avatar
    Been scrolling for a bit now, sure I Posted earlier than this, I have this issue on an S8. But multiple routers in my house, a NetGear and an ActionTech. Really annoying because I am unable to watch anything of significance - that is usually when it crashes.
    05-30-2017 05:59 PM
  14. Kalvin Kerns's Avatar
    Been scrolling for a bit now, sure I Posted earlier than this, I have this issue on an S8. But multiple routers in my house, a NetGear and an ActionTech. Really annoying because I am unable to watch anything of significance - that is usually when it crashes.
    Same. I use a router and a wall outlet WiFi booster thing (not at home to give you the proper technical name lol).

    I set it up to look like one SSID, but it's really two. The hand off between them is not seamless unfortunately. It's the worst on my S8 than any of my other devices to.
    05-30-2017 07:03 PM
  15. Jacy Hung's Avatar
    I'm unaware if anyone else has this issue, but my S8 for some reason, loses wifi signal when I'm covering the top back of my phone.

    If I move closer to the router though, it only loses 1 bar. It does the same on my friends Galaxy S8+.

    Here's my thread on the Samsung forum if you would like to read it.

    https://us.community.samsung.com/t5/.../112505#M26535
    05-31-2017 02:41 AM
  16. alantwm's Avatar
    Dunno if this helps anyone, but I resolved the wifi issues with my S8+ by changing my router setup from b+g+n to just b+g (no n protocol). Before, my Internet was constantly dropping, particularly on streaming video. Since the router protocol change, I've had no issues.
    05-31-2017 10:49 AM
  17. joe_fresh's Avatar
    This has been happening on my S8+, and my Moto Z force. The wife on her s7 and nexus 7. I have reset my router changed settings etc.
    05-31-2017 08:42 PM
  18. mlbyanks11's Avatar
    I question some things people suggest here. First of all adjusting a router in this case wont work. This wifi connectivity is a known issue along with bluetooth connectivity issues. So making adjustments to your router will do nothing if its happening no matter what wifi you're on. Secondly, I had the same issue with wifi dropping the way its described here. I got a warranty replacement and no more issues. Fast charging wireless works fine too. I suggest getting the device replaced.
    06-01-2017 10:36 AM
  19. slingshot202's Avatar
    I question some things people suggest here. First of all adjusting a router in this case wont work. This wifi connectivity is a known issue along with bluetooth connectivity issues. So making adjustments to your router will do nothing if its happening no matter what wifi you're on. Secondly, I had the same issue with wifi dropping the way its described here. I got a warranty replacement and no more issues. Fast charging wireless works fine too. I suggest getting the device replaced.
    Device replacement seems a hefty step, I'm only having wifi issues at the moment.

    There is nothing else noted on this problem? I'm surprised the phone supplier would swap the phone out so fast for the wifi issue.

    I need to see if this happens on other wifi systems. I have two routers at home and it happens on both.

    CJ
    06-02-2017 10:19 AM

Similar Threads

  1. Replies: 16
    Last Post: 11-21-2017, 03:05 AM
  2. T-Mobile Galaxy S8 Calling T-Mobile users: WiFi Calling
    By Ageeb in forum Samsung Galaxy S8 & S8+
    Replies: 14
    Last Post: 04-29-2017, 12:31 PM
  3. Nixon Mission - Complication Display Issue (confused)
    By Hilton_K in forum Android Wear
    Replies: 2
    Last Post: 04-27-2017, 06:11 PM
  4. AT&T Galaxy S8 Persistent Network & Wifi issues?
    By quickexc in forum Samsung Galaxy S8 & S8+
    Replies: 0
    Last Post: 04-26-2017, 04:52 PM
  5. getting cellular and wifi data usage for a specific time
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2017, 03:56 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.