1. dlee1001's Avatar
    On my S8+, I have my Gmail sync set to on so that I can get e-mails as they arrive. But I don't get any notifications when my screen is off. I have to turn the screen on for the notification to show up. I'm using the Gmail app and my settings are configured so that I have it notify me for every message.

    As an example of this scenario, I have my bank e-mail me every time I use my debit card for a transaction at the store. Those e-mails are always sent immediately after the transaction. But if I have my phone in my pocket with the screen turned off, I don't get the notification. As soon as I wake the screen, however, I do get the notification. I get instant notifications while I'm using the phone, but not when it's asleep. I'm using the phone with Power Saving mode off.

    Is there a setting I'm missing that I can change so that Gmail will notify me with new messages even when the phone is asleep? The Gmail app is not listed anywhere in the App Power Saving list and it is not possible to add it to the list.

    I don't know if this behavior is limited to just the Gmail app, but it seems to be the most prevalent in that app. Does anyone else have similar problems in other apps?
    04-30-2017 03:02 PM
  2. AdamHLG's Avatar
    Try looking in app manager for Gmail and look at the various permission and notification settings.
    04-30-2017 03:18 PM
  3. dlee1001's Avatar
    Try looking in app manager for Gmail and look at the various permission and notification settings.
    I just looked and everything is the way it should be; notifications are allowed, and permissions are set to storage (I don't use contacts or calendar enough to give Gmail those permissions).
    04-30-2017 03:22 PM
  4. Misterb's Avatar
    I just looked and everything is the way it should be; notifications are allowed, and permissions are set to storage (I don't use contacts or calendar enough to give Gmail those permissions).
    Is it set within the Gmail general settings for each account to notify you of each new email individually? If not, turn that on and see if it helps
    04-30-2017 03:53 PM
  5. PJRed2008's Avatar
    I see the same behavior but it's not consistent on mine. Everything set as it should be. Notifications do not work the same as the S7e, not sure why as its the same OS essentially, but I don't like it so far.
    04-30-2017 04:06 PM
  6. erasat's Avatar
    Go to Settings-Device Maintenance-Battery-Battery Usage (below the estimated Battery Life)-3 dots at the top right-Optimize battery usage.

    In there change to All Apps in the drop down and look for Gmail turn it off. All the issues address related to the Doze feature that will basically shut down background processes of those apps to save battery in sleep mode. Not an S8 issue as this has been happening for quite some time now in most if not all devices with Nougat and if I remember correctly, also happened on Marshmallow.
    04-30-2017 06:47 PM
  7. Misterb's Avatar
    Go to Settings-Device Maintenance-Power-Battery-Battery Usage (below the estimated Battery Life)-3 dots at the top right-Optimize battery usage.

    In there change to All Apps in the drop down and look for Gmail turn it off. All the issues address related to the Doze feature that will basically shut down background processes of those apps to save battery in sleep mode. Not an S8 issue as this has been happening for quite some time now in most if not all devices with Nougat and if I remember correctly, also happened on Marshmallow.
    I couldn't get there following those instructions, but found it under settings, battery. Thanks. I just turned it off for Gmail, and will see how it goes
    04-30-2017 07:00 PM
  8. dlee1001's Avatar
    I couldn't get there following those instructions, but found it under settings, battery. Thanks. I just turned it off for Gmail, and will see how it goes
    Same here; I was able to find the "Optimize battery usage" menu in the Battery Usage screen by tapping the three dots on the upper right side of the screen. So then I turned off optimization for Gmail and other apps that I get notifications from on a regular basis (like Facebook, Messenger, and Messaging, which is the stock texting app).

    Hopefully that should fix it. I'll report back with the results soon.
    04-30-2017 07:07 PM
  9. erasat's Avatar
    Same here; I was able to find the "Optimize battery usage" menu in the Battery Usage screen by tapping the three dots on the upper right side of the screen. So then I turned off optimization for Gmail and other apps that I get notifications from on a regular basis (like Facebook, Messenger, and Messaging, which is the stock texting app).

    Hopefully that should fix it. I'll report back with the results soon.
    It may be different based on carriers, but on my T-Mobile's one, besides that I added a wrong Power right before battery, with the rest I surely can get to that menu.

    That and with any shortcut you may find that takes you directly to Battery usage, like with any other launcher you may be using.
    04-30-2017 07:15 PM
  10. dlee1001's Avatar
    Going in the settings and turning off optimization for Gmail seems to have done the trick. I am now getting notifications as the e-mails arrive, even after the phone has been asleep for a while. Thank you for your help!
    Vipmediastar likes this.
    05-01-2017 05:53 AM
  11. erasat's Avatar
    Going in the settings and turning off optimization for Gmail seems to have done the trick. I am now getting notifications as the e-mails arrive, even after the phone has been asleep for a while. Thank you for your help!
    You're welcome.

    It's important that these little things gets spread every where, just like you there are tons of people with the same issue, you can even see a lot of them here on this forums, sometimes I find myself getting tired of posting the same, again and again, but I also get frustrated when I see that no one else seem to be passing the information to others so what people think is an Android issue by default they may know that it's just one of the huge amount of things you can turn on or off on any Android. So, people, all this things that you read on this forums, help us passing them to as much people as we can.

    Just saying...
    05-01-2017 08:59 AM
  12. novasquid's Avatar
    on my att s8+, turning off optimization for gmail hasn't worked and i still can't get notifications to show on the screen when the screen is off. it wasn't a big deal, but it's getting tiring having to open up my phone and go into gmail each time i hear the new mail sound (i know, first world problems). love the s8+ otherwise.

    anyone have any other ideas? i went through every setting and turned on (or off) the obvious ones (e.g. lock screen and security, notifications) but it's still not working.
    05-03-2017 11:20 AM
  13. PJRed2008's Avatar
    anyone have any other ideas? i went through every setting and turned on (or off) the obvious ones (e.g. lock screen and security, notifications) but it's still not working.
    Although a pain, my only suggestion would be to remove your gmail account, reboot and then add it back. You shouldn't lose anything by doing that.
    05-03-2017 11:28 AM
  14. novasquid's Avatar
    so i just noticed that with the screen off, i'll get the sound and led notifications, but the screen won't turn on to show the notification. i pressed the side power button to light up the screen, and there's the notification banner showing my gmail alert. so it appears the screen notification is kind of working, but it's not lighting up the screen to show the notification.

    any thoughts on which setting would control the screen on notifications? i've tried toggling "always on display" and that didn't work. screen still stays off when notifications arrive.
    05-03-2017 11:41 AM
  15. AlyHUD's Avatar
    Well u might have the same problem I had...And the answer was pretty simple -
    https://forums.androidcentral.com/e?...token=OAiA4Z5x
    The part "This setting is only available if a Screen lock type is setup." Mine was set to None and the notification icons would just not show up ever on my lock screen, I tried all other listed options on the internet and only this worked. Hope this helps.
    07-19-2017 01:02 AM
  16. Bhagavatula Bhaskara Subbarao's Avatar
    I am not getting Gmail notification on my mobile lock screen. Please help me
    08-17-2018 05:21 AM

Similar Threads

  1. Can Anyone Help me get rid of This Line?
    By ethbow in forum LG G5
    Replies: 7
    Last Post: 05-01-2017, 02:02 PM
  2. S8 Contact pictures/pop up notification
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-30-2017, 08:11 PM
  3. Replies: 1
    Last Post: 04-30-2017, 04:11 PM
  4. Replies: 1
    Last Post: 04-30-2017, 04:09 PM
  5. Replies: 2
    Last Post: 04-30-2017, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD