1. anpease's Avatar
    Hi,
    I have read somewhere else that to add a photo to a contact I click on the contact, then details, then edit, and then click on the icon of the camera to add the photo.
    However, I do not have that icon there, I just have name, number and email address.
    This is on a Samsung Galaxy S8 Plus.
    Can anyone please help?
    Many thanks.
    05-09-2017 03:02 AM
  2. new2sg8's Avatar
    I was wondering about the same issue.
    05-09-2017 03:27 AM
  3. munnarg's Avatar
    Do you not have these screens? Contacts Photo-screenshot_20170509-115132.pngContacts Photo-screenshot_20170509-115223.png
    05-09-2017 10:52 AM
  4. ol_jackburton's Avatar
    What contact app are you using.
    05-09-2017 11:40 AM
  5. NeoTreo's Avatar
    Try this, Phone:Contacts: select yourself or other contact : Edit: press the "-" on the top right corner which takes you to your gallery app. If something is not already in your gallery via the camera, just transfer a jpeg to your gallery and use it. Don't forget to SAVE it.

    I tried it, it works.
    05-09-2017 03:08 PM
  6. new2sg8's Avatar
    That does work. The problem I was having was, I could update my personal contact photo in the phone. But it was not changing another contact photo, which was google. I just unlinked them, so my personal profile info is phone only. Thanks for including the pix, it helped.
    05-09-2017 10:03 PM
  7. anpease's Avatar
    I am using the Contacts app that came with the phone, but when I click on Edit I just get this...
    Attached Thumbnails Contacts Photo-phone.jpg  
    05-10-2017 10:52 AM
  8. teristark's Avatar
    Is it because it is saved to your SIM card? I have one I accidentally saved to my SIM and my screen looks the same as yours. The ones I saved to google or my SD I am able to add pictures.
    05-10-2017 05:30 PM
  9. anpease's Avatar
    Sorry...been away for a few days. Yes, it is due to the SIM card contacts. Transferred them all to my phone, and I can now add the photos.
    Many thanks to everyone for their help.
    Much appreciated.
    kevinpleasants likes this.
    05-15-2017 12:57 PM
  10. erasat's Avatar
    Sorry...been away for a few days. Yes, it is due to the SIM card contacts. Transferred them all to my phone, and I can now add the photos.
    Many thanks to everyone for their help.
    Much appreciated.
    I'd suggest you to move those contacts from the phone to your Google account. As you may know, having them on the SIM card or the phone just means that if by any chance your phone is lost or stolen or gets hard bricked, you will lose your Contacts.

    Use the Import/Export option on your Contacts App settings and export them to your phone then use the Import option and it will ask you where to store them, just select Google.
    05-15-2017 01:42 PM
  11. anpease's Avatar
    I already have them backed up on my PC. But will back them up on Google account as well. Thanks.
    05-16-2017 12:34 AM
  12. uncreativeartist's Avatar
    You could always go to the photo you want as a profile photo and set it as profile photo. Go to gallery, click on the folder the photo is located, click on photo, click on the infamous three dots upper right corner scroll to set as profile picture and then select the contact you want the photo for.
    05-16-2017 07:42 AM
  13. anpease's Avatar
    It's all sorted now, thanks.
    05-16-2017 07:53 AM

Similar Threads

  1. Why does my contact not display the names
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 05-08-2017, 09:15 PM
  2. LG G6 - won't attach photos
    By AC Question in forum LG G6
    Replies: 1
    Last Post: 05-08-2017, 04:52 PM
  3. Replies: 1
    Last Post: 05-08-2017, 04:42 PM
  4. LG G6 - won't attach photos
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-08-2017, 02:21 PM
  5. Replies: 0
    Last Post: 05-08-2017, 01:18 PM
LINK TO POST COPIED TO CLIPBOARD