1. oneformula's Avatar
    When using the stock messaging app, how do I make it default to v chrome rather than the Samsung browser?

    Thank you. And have a great day.
    05-15-2017 09:07 PM
  2. erasat's Avatar
    Settings-Apps-Options (3 dots at the top right)-Default Apps
    oneformula likes this.
    05-15-2017 09:11 PM
  3. strikeIII's Avatar
    You can't. This is why I use Textra. Samsung has been doing this for awhile now on their past devices as well.
    05-15-2017 10:13 PM
  4. strikeIII's Avatar
    In the past when you opened a link and it went to their mini browser, if you would go into menu you had the option to open it in your default browser but now the only option is Samsung Browser. Horrible!
    05-15-2017 10:19 PM
  5. jstwondrng's Avatar
    I'm having an issue with clicking links in Google Mail and it opening in a mini browser instead of Chrome. Not sure if this is the same issue the OP is having but any way to change this to open the link in Chrome?

    J
    05-16-2017 10:34 AM
  6. strikeIII's Avatar
    I'm having an issue with clicking links in Google Mail and it opening in a mini browser instead of Chrome. Not sure if this is the same issue the OP is having but any way to change this to open the link in Chrome?

    J
    I use Google Inbox app instead of the Gmail app. It opens links directly to Chrome. All these apps are starting to use like mini browsers or browsers within the apps and it's getting annoying. I think Facebook was the first to start doing this but at least they give the option to turn that completely off.
    05-16-2017 10:35 PM
  7. jstwondrng's Avatar
    I use Google Inbox app instead of the Gmail app. It opens links directly to Chrome. All these apps are starting to use like mini browsers or browsers within the apps and it's getting annoying. I think Facebook was the first to start doing this but at least they give the option to turn that completely off.
    It really is annoying. The part that kills me is, there isn't a simple setting to change this from using a mini browser to Chrome being the "main" browser for everything.

    J
    05-17-2017 08:46 AM
  8. erasat's Avatar
    If you go to Gmail for example, on General Settings, you will find "Open web links in Gmail" by default is on, so it opens on the Gmail app "browser", it then gives an option when you open a link to open it on Chrome or Samsung Browser, by turning this off the phone will go to the Browser default app and open that one.

    Now coming back to the OP question on how to do this on the default Messages app, well, the only setting I can see that may be related to this is in Messages-Settings-More Settings-Show Web previews. I know that it doesn't sound like this is the issue, but it's the only thing in settings that deals with Web Links. Turn it off and see if it helps.

    **Edit** - I just tried the above and it doesn't work as the OP wants. Gmail has this specific setting where to turn it off and it opens the Default browser app, but for Messages, it opens Samsung browser, I just noticed that for me it hasn't been an issue, first, because I barely use Messages, I always use WhatsApp, but second, I'm using Samsung Browser as my default browser so for me either way is a non issue.

    Only thing I can think of is to disable the Samsung browser (You will need a Package disabler for that) and see if by doing that it forces the app to go to the phone's default browser app, in your case, chrome.
    05-17-2017 02:31 PM
  9. BH Lombardy's Avatar
    On my Galaxy S8, I did the following...

    Settings > Apps > Samsung Internet > "Browser App" ... and changed the option from Samsung Internet to Chrome.
    Now links in my email and other options open Chrome instead of Samsung internet.

    This works in the stock Email app, and Gmail (for those who dont use Inbox).

    Other apps that have their own mini-browser often have an option to turn off the internal browser. (Twitter is one example) If you turn off the internal browser option in the app, AND if you've adjusted the setting as above it will open Chrome instead of Samsung Internet.

    Unfortunately, this isnt a 100% fix across the board... There are still other apps that have their own mini-browser and don't allow you to turn it off (like the stock "Messages" app for SMS). These will still use their internal mini-browser... and there's no way around it -- not that I've uncovered anyway. (i'd prefer if my SMS links opened in Chrome, but I havent found a way around that yet).

    But I've found that this will alleviate at least a few more frustrations.
    07-28-2017 10:11 AM
  10. Kittoe's Avatar
    Settings-Apps-Options (3 dots at the top right)-Default Apps
    This worked on my note 8 .Back to come lol
    04-09-2018 12:28 PM
  11. thusgaard's Avatar
    Here's what works for me :
    Remove Samsung Internet. Then instead of "Open in Samsung Internet" you should get "Open in Browser".
    07-07-2018 03:16 AM
  12. Klarobass 94's Avatar
    If you go to Gmail for example, on General Settings, you will find "Open web links in Gmail" by default is on, so it opens on the Gmail app "browser", it then gives an option when you open a link to open it on Chrome or Samsung Browser, by turning this off the phone will go to the Browser default app and open that one.

    Now coming back to the OP question on how to do this on the default Messages app, well, the only setting I can see that may be related to this is in Messages-Settings-More Settings-Show Web previews. I know that it doesn't sound like this is the issue, but it's the only thing in settings that deals with Web Links. Turn it off and see if it helps.

    **Edit** - I just tried the above and it doesn't work as the OP wants. Gmail has this specific setting where to turn it off and it opens the Default browser app, but for Messages, it opens Samsung browser, I just noticed that for me it hasn't been an issue, first, because I barely use Messages, I always use WhatsApp, but second, I'm using Samsung Browser as my default browser so for me either way is a non issue.

    Only thing I can think of is to disable the Samsung browser (You will need a Package disabler for that) and see if by doing that it forces the app to go to the phone's default browser app, in your case, chrome.
    I have a Samsung Galaxy S9 plus and did this and my links from Gmail are still Opening in Samsung internet. And I changed browser app to chrome, yet it's still opening in Samsung internet. This is annoying.
    09-13-2018 09:49 PM
  13. Klarobass 94's Avatar
    Here's what works for me :
    Remove Samsung Internet. Then instead of "Open in Samsung Internet" you should get "Open in Browser".
    How do I do that? When I go to apps in the settings, the option disable is greyed out, so it doesn't allow me to disable the app?
    09-13-2018 10:16 PM

Similar Threads

  1. Confirmed Countries the XT1607 Works In
    By Cainamzak in forum Moto G4 Play
    Replies: 4
    Last Post: 08-24-2017, 01:01 PM
  2. Samsung Galaxy S8+ Verizon sms messages are split in sections
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-16-2017, 04:50 PM
  3. Replies: 1
    Last Post: 05-16-2017, 02:47 AM
  4. Replies: 1
    Last Post: 05-15-2017, 08:20 PM
  5. Replies: 0
    Last Post: 05-15-2017, 08:20 PM
LINK TO POST COPIED TO CLIPBOARD