1. kwitel's Avatar
    This thing pops up multiple times per day.

    How to I get it to stop?

    I only have the stock samsung one and Swiftkey installed and I use the latter.

    Should I force stop the Samsung app?
    05-20-2017 10:25 PM
  2. SpookDroid's Avatar
    You can't force-stop the stock keyboard (only if you root, and even then, I suggest you don't. If anything happens you're left without a stock keyboard to type in your password at boot).

    Do you get the pop-up randomly or when you start typing on a text field? Is SwiftKey selected as your default keyboard? The selection icon at the bottom of the screen and on the notification bar when you're typing won't ever go away, but if you have a keyboard selected as a default, the selection pop-up shouldn't just, well, pop up on its own, just if you select the Select Keyboard button or notification.

    Do you use SideSync? I had a similar issue when I used it but all it did was go back to setting the stock Samsung keyboard as the default, but never random pop ups (and this was on an S7... I haven't had that issue on the 8).
    05-20-2017 10:42 PM
  3. BeyondtheTech#AC's Avatar
    You could use the BK Package Disabler and actually disable the Samsung Keyboard, but if you ever need to boot into safe mode (which will disable all third-party stuff), you'll have no keyboard control and may require a factory reset.
    05-20-2017 11:44 PM
  4. kwitel's Avatar
    You can't force-stop the stock keyboard (only if you root, and even then, I suggest you don't. If anything happens you're left without a stock keyboard to type in your password at boot).

    Do you get the pop-up randomly or when you start typing on a text field? Is SwiftKey selected as your default keyboard? The selection icon at the bottom of the screen and on the notification bar when you're typing won't ever go away, but if you have a keyboard selected as a default, the selection pop-up shouldn't just, well, pop up on its own, just if you select the Select Keyboard button or notification.

    Do you use SideSync? I had a similar issue when I used it but all it did was go back to setting the stock Samsung keyboard as the default, but never random pop ups (and this was on an S7... I haven't had that issue on the 8).
    I do randomly get the popus but they come quite often.
    Swiftkey is my defauly keyboard and I do not use SideSync.

    Im surprised no one else is getting this...
    05-21-2017 01:09 AM
  5. goodintentions's Avatar
    The window doesn't popup randomly. Bottom right hand corner just right of the back button there is a button that lets you quickly change keyboard. This button is only there if you have more than 1 keyboard enabled. In order to prevent this button from existing, you need to disable all keyboards but 1.

    If you want to use another keyboard, say the GO keyboard, you need to select GO and disable all the other keyboards, including the samsung default.
    05-21-2017 03:14 AM
  6. SpookDroid's Avatar
    The window doesn't popup randomly. Bottom right hand corner just right of the back button there is a button that lets you quickly change keyboard. This button is only there if you have more than 1 keyboard enabled. In order to prevent this button from existing, you need to disable all keyboards but 1.

    If you want to use another keyboard, say the GO keyboard, you need to select GO and disable all the other keyboards, including the samsung default.
    That icon only appears IF you are actively selecting a text input field, it's not there all the time. Also, as we've said before, while disabling the stock keyboard IS an option, it is one that is ill-advised. Should anything go wrong and 3rd party keyboards not be active, if the stock one is disabled there will be no way to access the device at boot if a secure lockscreen is selected.
    05-22-2017 12:40 AM
  7. kwitel's Avatar
    The window doesn't popup randomly. Bottom right hand corner just right of the back button there is a button that lets you quickly change keyboard. This button is only there if you have more than 1 keyboard enabled. In order to prevent this button from existing, you need to disable all keyboards but 1.

    If you want to use another keyboard, say the GO keyboard, you need to select GO and disable all the other keyboards, including the samsung default.
    You nailed it.
    I didnt even notice that little keyboard icon there.
    What is liekly happening is that I am accidentally brushing up agains it making that annoying dialog box popup.

    I have turned off the other keyboards but have left on Google Voice Typing as I do use that quite often.

    Unfortunately the icon is still.

    Not a very smart UI decision, in my opinion...
    H3aTeRzz likes this.
    05-22-2017 12:56 AM
  8. SpookDroid's Avatar
    You nailed it.
    I didnt even notice that little keyboard icon there.
    What is liekly happening is that I am accidentally brushing up agains it making that annoying dialog box popup.

    I have turned off the other keyboards but have left on Google Voice Typing as I do use that quite often.

    Unfortunately the icon is still.

    Not a very smart UI decision, in my opinion...
    People complained that changing keyboards was 'not simple' and required you to pull down on the notification shade, which in some apps, lost 'focus' of the text input field and caused the keyboard option to go away. So now that we have virtual buttons, voilá! You can do that without having to pull down on the shade! Which now irks a different set of people. Just goes to show that you can never please everyone haha

    But anyway, that icon shouldn´t be there all the time, just when you´re writing text.
    05-22-2017 01:14 PM
  9. xtreme381's Avatar
    I share your pain. I get this pop up multiple times a day because I use SwiftKey. The base of my thumb touches this button when I'm swiping with one hand. I've tried to see if I could disable or move the button but unfortunately there's nothing I can do. I'm afraid we have to live with this pain as the only way to get rid of it is use the default keyboard
    05-22-2017 03:35 PM
  10. Steph6n's Avatar
    I do randomly get the popus but they come quite often.
    Swiftkey is my defauly keyboard and I do not use SideSync.

    Im surprised no one else is getting this...
    I get the same thing on my S7, and I believe it's because I downloaded and installed and use as default Google keyboard.
    07-14-2017 08:20 PM
  11. Kevin Freels's Avatar
    But it would be extremely simple to please everyone. They already built in the ability to relocate the soft keys into a different order. You can easily choose to have the soft keys always showing or to have them disappear when not needed. How much code would it really take to Simply provide a toggle that allows the easy access to keyboard changes to be turned on and off? Or it could just be in the main menu just like airplane mode is which I'm sure is used a lot less frequently.
    And seriously how many times does a person change their keyboard? Usually once one has chosen a keyboard that they like they want that keyboard all the time. It makes no sense to hop around between keyboards where various characters are in different places. And the idea that the icon is only there when you are typing is actually kind of silly. Because that's the only time it's annoying. LOL
    The fact is having it there when you use an alternate keyboard is a pain in the butt. It is too easy to accidentally hit and suddenly have your keyboard change on you.
    I really don't buy into the idea that they put it there because people found that changing their keyboard was too complex. People who change keyboards do so infrequently once they have landed on the one they like. And those who do seek out other keyboards usually aren't people who are uncomfortable going into the settings and making the change.
    Creating a feature that causes people to "accidentally" revert to the Samsung keyboard really doesn't seem to benefit Samsung either. I really can't think of anything they gain by doing so. But it does annoy a lot of customers and there are plenty of other ways to make keyboard changes quick and easy for those who want to customize their phones but don't even know how to find a setting to do so. I really think it belongs in the pull-down menu.
    Unfortunately I believe it this is a case of a developer making a change to justify their job because they are bereft if any new good ideas. Hopefully an update in the near future will allow us to toggle this off.
    12-20-2017 09:16 AM
  12. Gayle Lynn's Avatar
    Use of a password manager with its own keyboard.

    Accidentally hit a toggle switch.
    12-20-2017 10:35 AM
  13. Android Professional's Avatar
    This thing pops up multiple times per day.

    How to I get it to stop?

    I only have the stock samsung one and Swiftkey installed and I use the latter.

    Should I force stop the Samsung app?
    drag down the top menu, tap and hold the select keyboard notification and gently slide it over til you can lock it halfway or so and click the gear. then click the virtual keyboard yellow text where it says no sound and turn off the app icon badges and set don't show notifications.

    Job Done.
    04-05-2019 02:58 AM

Similar Threads

  1. Gear S2- Do you always need to have your phone with you?
    By AC Question in forum Samsung Gear S2
    Replies: 7
    Last Post: 06-18-2017, 09:47 PM
  2. Lookout has stopped
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-21-2017, 06:19 AM
  3. Replies: 1
    Last Post: 05-21-2017, 01:04 AM
  4. How can I get the previous software reinstalled.?
    By Armani4me in forum General Help and How To
    Replies: 2
    Last Post: 05-20-2017, 09:33 PM
  5. Replies: 1
    Last Post: 05-20-2017, 08:01 PM
LINK TO POST COPIED TO CLIPBOARD