03-03-2018 01:13 PM
29 12
tools
  1. twowetsocks's Avatar
    I have a Galaxy S8 plus and I use AT&T. I never had poor phone reception till I got this phone. I was having calls dropped and bad clarity. I exchanged it for a new phone and got a new SIM card, reset my network settings and nothing fixed it. Then I found out that if you turn off the "ENHANCED LTE settings" it can fix the phone reception. So far it's fixed it. Let me know if you had a similar problem.
    05-27-2017 08:19 PM
  2. PJRed2008's Avatar
    Welcome to the forum! and thanks for the fixit post! Not on AT&T myself, but hopefully your post can help some folks with similar problem.
    05-27-2017 09:31 PM
  3. T48's Avatar
    The S8+ has been the best phone for me in terms of reception & am on ATT. Just checked & the enhanced LTE is on.
    Glad you found something to make yours work. But would still be curious if something else is causing the issue?
    05-31-2017 12:50 PM
  4. belodion's Avatar
    This thread might be better in the S8 forum, so I'll move it.
    05-31-2017 05:31 PM
  5. dejanh's Avatar
    Where do you find this setting?
    06-01-2017 09:50 AM
  6. ABOSWORTH007's Avatar
    Where do you find this setting?
    Just go to your settings and hit the search button at the top and type "Enhanced" and you will find it.

    Or Settings, Connections, mobile networks, Enhanced LTE Settings.
    06-01-2017 09:55 AM
  7. justafew's Avatar
    I have a Galaxy S8 plus and I use AT&T. I never had poor phone reception till I got this phone. I was having calls dropped and bad clarity. I exchanged it for a new phone and got a new SIM card, reset my network settings and nothing fixed it. Then I found out that if you turn off the "ENHANCED LTE settings" it can fix the phone reception. So far it's fixed it. Let me know if you had a similar problem.

    Just be aware that I had this turned off on My Galaxy S7 for similar reasons, but whenever my brother on an iPhone sent me a long text message (not sure how many characters, but a lot), I would never receive it. Never had this issue with anyone else, but he was dealing with my parent's estate after they both passed away suddenly, so it wasn't typical to get as long a message from others. But once my wife sent me a long one that I missed and I realized there must be something else going on (not just my brother's iPhone).

    After I enabled this option again, I never had a problem again. So if you have this disabled and realize you are missing texts, either have your them send you shorter texts or re-enable this option.
    06-01-2017 11:15 AM
  8. PJRed2008's Avatar
    sent me a long text message (not sure how many characters, but a lot), I would never receive it.
    I don't get many texts but I thought they had a very low (145?) character limit? All of the ones I've gotten have been quite short.
    06-01-2017 11:25 AM
  9. trucksmoveamerica#AC's Avatar
    Verizon phones are having the same issue, and it looks as it is the same fix.
    06-01-2017 02:12 PM
  10. mlblack16's Avatar
    Verizon phones are having the same issue, and it looks as it is the same fix.
    Where did you find the setting? I'm not having any reception issues, but curious in case I did. I tried the search in settings and nothing comes up.
    06-01-2017 04:22 PM
  11. trucksmoveamerica#AC's Avatar
    Where did you find the setting? I'm not having any reception issues, but curious in case I did. I tried the search in settings and nothing comes up.
    It's in settings, select advanced calling and select advanced calling again, then select what I circled below.

    06-01-2017 04:25 PM
  12. Almeuit's Avatar
    Verizon phones are having the same issue, and it looks as it is the same fix.
    Are they? My LTE is just fine on mine and I have Advanced Calling on with Video / Voice.
    06-01-2017 04:28 PM
  13. trucksmoveamerica#AC's Avatar
    Are they? My LTE is just fine on mine and I have Advanced Calling on with Video / Voice.
    For me I have. I did this did she no dropped calls for a week now.
    06-01-2017 04:29 PM
  14. Almeuit's Avatar
    For me I have. I did this did she no dropped calls for a week now.
    Odd. I haven't had a dropped call once yet and I got the phone on release day from Best Buy (preorder).
    blaine07 likes this.
    06-01-2017 04:38 PM
  15. trucksmoveamerica#AC's Avatar
    Odd. I haven't had a dropped call once yet and I got the phone on release day from Best Buy (preorder).
    Same here. All I know dropped calls went away after changing that setting. There posts about other Verizon users, that's where I got this idea.
    06-01-2017 04:44 PM
  16. Almeuit's Avatar
    Same here. All I know dropped calls went away after changing that setting. There posts about other Verizon users, that's where I got this idea.
    Well that is what I am saying is I have had the setting on this entire time and I have had no dropped calls. I have even done some video calls with a buddy on WiFi and via LTE without a hiccup. You're saying it fixed yours so I assume you had some whereas I never have since getting the S8+.
    06-01-2017 04:46 PM
  17. trucksmoveamerica#AC's Avatar
    Well that is what I am saying is I have had the setting on this entire time and I have had no dropped calls. I have even done some video calls with a buddy on WiFi and via LTE without a hiccup. You're saying it fixed yours so I assume you had some whereas I never have since getting the S8+.
    I don't know why some are effected and some aren't, I don't do video calling so is this fixes it for me, great. Time will tell, but week in and no issues, but I know how that goes. I'm still in the testing phase for me.
    06-01-2017 04:48 PM
  18. dejanh's Avatar
    Just go to your settings and hit the search button at the top and type "Enhanced" and you will find it.

    Or Settings, Connections, mobile networks, Enhanced LTE Settings.
    Ah, never-mind. This is a carrier specific setting. I don't have that. Thanks though.
    06-01-2017 06:24 PM
  19. ABOSWORTH007's Avatar
    Ah, never-mind. This is a carrier specific setting. I don't have that. Thanks though.
    Oh gotcha. What carrier?
    06-01-2017 06:26 PM
  20. skipatrol's Avatar
    I disabled mine and actually lost a bar.
    06-01-2017 09:40 PM
  21. dejanh's Avatar
    Oh gotcha. What carrier?
    Bell Canada.
    06-01-2017 11:26 PM
  22. Almeuit's Avatar
    I disabled mine and actually lost a bar.
    Ignore bars. -dBm signal is the truth :P.
    T48 likes this.
    06-01-2017 11:40 PM
  23. jerseygirl's Avatar
    I've been experiencing poor reception in my home, I was hoping this might help but enhanced LTE is checked off. I set up the wifi calling, that doesn't seem much better either. I'll have to give at&t a call.... from my landline, lol
    06-02-2017 01:20 AM
  24. T48's Avatar
    I've been experiencing poor reception in my home, I was hoping this might help but enhanced LTE is checked off. I set up the wifi calling, that doesn't seem much better either. I'll have to give at&t a call.... from my landline, lol
    When you call ATT, ask them for a micro cell signal booster. When I had a Galaxy S3 with little to no reception at home, that really helped. Still have it plugged in & lights up on the S8+. The improved reception allowed me to cancel my home phone at the time.

    Link goes to att's site directly to info about their micro cell network extender.

    https://www.att.com/att/microcell/
    06-02-2017 07:45 AM
  25. Horsesgirl's Avatar
    I also am having the same issue and was fortunate enough to still have my S7 on hand, so we bounced the Sim card back and forth between the two phones and it does in fact seem to be the S8...I'm going to give the suggested fix a try and see if it works because I too was thinking I had a lemon and needed a new phone and simply card.
    08-11-2017 07:19 PM
29 12

Similar Threads

  1. The google search bar on my galaxy s8 changed
    By Manuel OP in forum Samsung Galaxy S8 & S8+
    Replies: 13
    Last Post: 09-16-2017, 09:10 PM
  2. Replies: 1
    Last Post: 06-05-2017, 05:45 AM
  3. thinking of buying S8 or S8+
    By farocco in forum Samsung Galaxy S8 & S8+
    Replies: 15
    Last Post: 05-29-2017, 05:50 PM
  4. How to flash samsung galaxy s3 by its own recovery mode?
    By IBRAR PRINCE in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 05-28-2017, 10:23 AM
  5. Replies: 1
    Last Post: 05-27-2017, 10:17 PM
LINK TO POST COPIED TO CLIPBOARD