1. gorint9's Avatar
    I searched the web and forums for this but did not find anything. So maybe my phone is defective, but before trying to get a replacement, I thought I would ask the users and experts:

    If I set my GS8 (Tmobile) to cellular preferred (under the wifi calling option), it still defaults to wifi calling, even when I have a very strong signal. The only way to make a call on the cellular network is to turn off wifi calling or wifi altogether. Is it just me?

    Why I care:
    • Wifi calling is not very good at switching to cellular if you lose wifi connection (at least on this phone, which is why I started to pay attention)


    Here are the troubleshooting steps I have taken so far:
    • Reset network settings - didn't do anything (other than lose all my network settings
    • Factory reset the phone - issue still there
    • Test with my GS7 edge - issue not present (in the same location, with cellular preferred I place calls on the cell network - pop the SIM in my GS8 and I am immediately on wifi calling)


    Questions:
    • Is anyone else seeing this behavior or do I have a defective device somehow (cell calling works fine if I force it)
    • Could this be software related? If that's the case, I don't want to get a refurb from Tmobile and have the same issue
    • Any suggestions on how to further diagnose / fix this?


    Thanks!
    06-09-2017 10:36 PM
  2. Gary02468's Avatar
    Have you contacted T-Mobile tech support? The WiFi-calling preference seems to be a carrier-specific setting. I don't see that setting here on AT&T--with WiFi Calling enabled, it always prefers cellular if available (though I can force WiFi for calls by turning on Airplane Mode, then re-enabling WiFi).
    06-10-2017 05:26 AM
  3. TylerLV76's Avatar
    I searched the web and forums for this but did not find anything. So maybe my phone is defective, but before trying to get a replacement, I thought I would ask the users and experts:

    If I set my GS8 (Tmobile) to cellular preferred (under the wifi calling option), it still defaults to wifi calling, even when I have a very strong signal. The only way to make a call on the cellular network is to turn off wifi calling or wifi altogether. Is it just me?

    Why I care:
    • Wifi calling is not very good at switching to cellular if you lose wifi connection (at least on this phone, which is why I started to pay attention)


    Here are the troubleshooting steps I have taken so far:
    • Reset network settings - didn't do anything (other than lose all my network settings
    • Factory reset the phone - issue still there
    • Test with my GS7 edge - issue not present (in the same location, with cellular preferred I place calls on the cell network - pop the SIM in my GS8 and I am immediately on wifi calling)


    Questions:
    • Is anyone else seeing this behavior or do I have a defective device somehow (cell calling works fine if I force it)
    • Could this be software related? If that's the case, I don't want to get a refurb from Tmobile and have the same issue
    • Any suggestions on how to further diagnose / fix this?


    Thanks!
    It's not just you and its one of the reasons I turned it off. I kept getting that notification that "calls will be made over wifi even though I set cellular to be preferred. It's something to do with T-mobile software and its only on this device. My G6 doesn't do this and stays on cellular preferred.
    06-10-2017 06:09 AM
  4. jlangner's Avatar
    Same here. I turned mine off since always said calls will be made over wifi even though cellular preferred. Unlimited talk and issues with MMS with enabled over 3rd party text like Textra.
    06-10-2017 08:37 AM
  5. gorint9's Avatar
    tylverlv76, jlanger, thanks for the input. Glad (I suppose) to hear that it's not an issue with my phone
    06-10-2017 11:13 AM
  6. mmakoto's Avatar
    Add me to the list, I noticed this strange behavior on the first week of ownership, I then disabled wifi calling. Never had this problem on my s6e+.
    06-10-2017 12:16 PM
  7. theelite1x87's Avatar
    T-Mobile S8 plus here. Same issue. I've disabled Wi-Fi calling until it's fixed. And just enable it manually if I need it. If I set it to cellular preferred, it'll use Wi-Fi regardless of signal strength. It's clearly a bug in the software
    06-10-2017 08:06 PM
  8. kilovoltaire's Avatar
    Same behavior for me on T-Mobile with a Moto E4, Android 7.1.1, oh well
    07-18-2017 05:10 PM
  9. claykin's Avatar
    Try installing the July patch update released last night. It's only been a short test so far, but looks like this issue may be fixed.

    If they'd only add the ability to set wifi calling to specific WiFi networks I choose.
    07-19-2017 07:37 AM
  10. ABOSWORTH007's Avatar
    Try installing the July patch update released last night. It's only been a short test so far, but looks like this issue may be fixed.

    If they'd only add the ability to set wifi calling to specific WiFi networks I choose.
    That would be a nice feature. I don't have T-Mobile but I have WiFi calling on my AT&T variant and it is a bit wonky. I generally just turn it off. If I leave it on, it sometimes hangs up text messages while I'm at work.
    07-19-2017 08:26 AM
  11. SeanSkiNE's Avatar
    Interestingly, my brand new S9 does the exact same thing. Infuriating. Maybe they will patch this one too.
    03-22-2018 09:26 PM
  12. MrDoh's Avatar
    Works right n my S9 on T-Mobile.
    05-14-2018 06:51 PM

Similar Threads

  1. Replies: 3
    Last Post: 06-11-2017, 05:18 PM
  2. How to opt out of Android O
    By flipbeats in forum Android 8.0 Oreo
    Replies: 2
    Last Post: 06-10-2017, 10:29 AM
  3. screen auto returns to homescreen
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 0
    Last Post: 06-09-2017, 10:30 PM
  4. Where is the Clip Tray located on LG Stylo 2
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-09-2017, 09:55 PM
  5. Replies: 0
    Last Post: 06-09-2017, 08:54 PM
LINK TO POST COPIED TO CLIPBOARD