1. arunma's Avatar
    Hi all. I'm experiencing a very bizarre issue. Yesterday, I connected my Gear VR to my phone for the first time in a couple weeks...and absolutely nothing happened. When I put on the headset I could see a small, magnified part of my desktop for a few seconds, and then the phone reverted to AOD, as though nothing was connected at all. I also tried using the included USB connector to connect a mouse which previously worked with my phone, and again, nothing happened. I've also tried thumb drives and hard drives to no effect. It's as though my phone has somehow lost the ability to provide power to external devices. Things I've tried:

    - Restarting my phone
    - Uninstalling all Oculus and Gear VR apps (curiously, they reinstalled when I turned on my VR controller)
    - Giving permissions to all Facebook-related apps
    - Soft reset by long-pressing the power and volume down buttons
    - The nuclear option, i.e. a full factory reset and restoration from Samsung Cloud

    None of these has had any effect. My phone has not suffered any drops or other physical damage, and the USB-C port appears clear. In fact I'm still able to connect to my computer for file transfers, and I can export video to a TV via a USB-C to HDMI cable. But OTG and Gear VR do absolutely nothing. One possible explanation I've considered is the update I received from T-Mobile about five days ago. However, since I hadn't used my Gear VR in longer than that, I have no way of testing this.

    I contacted T-Mobile, and the best they could do is offer me a warranty replacement. I'd rather not have to set up a whole new phone due to what is likely a software issue. Does anyone have ideas or experience with this problem? Thanks in advance!
    06-10-2017 10:04 AM
  2. TylerLV76's Avatar
    Since you've already nuked it once try a factory reset one more time but set it up as a new phone. Don't restore anything at all. Then test the VR and your OTG devices.
    06-10-2017 10:24 AM
  3. arunma's Avatar
    Since you've already nuked it once try a factory reset one more time but set it up as a new phone. Don't restore anything at all. Then test the VR and your OTG devices.
    Oops, forgot to mention that I tried this too. When I factory reset my phone, I attempted to connect my Gear VR prior to restoring my data from Samsung Cloud. However, Google was already downloading apps in the background, so perhaps this is indeed worth another shot. Thanks for the suggestion!
    06-10-2017 11:14 AM
  4. djm1947's Avatar
    Maybe the issue is with the Gear VR. Have you tried it on another phone?
    06-10-2017 01:32 PM
  5. arunma's Avatar
    Maybe the issue is with the Gear VR. Have you tried it on another phone?
    I haven't, since I don't have any other Samsung phones which are compatible with it. But I do have last year's Gear VR, and I tried my S8+ with it. Same result, unfortunately.
    06-11-2017 09:14 AM
  6. arunma's Avatar
    Well, this morning I finally broke down and took up T-Mobile on their warranty offer. The new phone arrives Wednesday, so I have until then to see if I can figure out what's going on here!
    06-11-2017 09:22 AM
  7. arunma's Avatar
    Quick update on this. I wasn't able to find a solution online (thanks for the suggestions though). I ended up having to go with the warranty replacement. The new phone they gave me was refurbished and had scuff marks on the display, so I politely refused it and had T-Mobile order me a second phone. It arrived today, and appeared to be brand new. I tested USB peripherals and my Gear VR, and not much to my surprise everything works as expected. I'm going to do the following in order:

    1. Complete all Google Play app restorations
    2. Full restore from Samsung Cloud
    3. Thorough tests of USB peripherals (USB thumb drive, mouse, and anything else I've got)
    4. Install the latest T-Mobile OTA update
    5. Re-test USB peripherals and Gear VR

    I'll keep everyone posted on whether or not number 5 works!
    3. Install the T-Mobile OTA update
    kevinpleasants likes this.
    06-19-2017 06:52 PM
  8. arunma's Avatar
    Well, after re-testing, everything worked and I assumed I was on my merry way. I then paired my Gear S3 with my phone, and BAM, I once again killed my ability to pair to the Gear VR or to any USB peripheral. I did a factory reset of my brand new phone and it did nothung.

    Starting to consider jumping ship to iPhone...
    06-19-2017 10:45 PM
  9. TylerLV76's Avatar
    Well, after re-testing, everything worked and I assumed I was on my merry way. I then paired my Gear S3 with my phone, and BAM, I once again killed my ability to pair to the Gear VR or to any USB peripheral. I did a factory reset of my brand new phone and it did nothung.

    Starting to consider jumping ship to iPhone...
    Ok thats extremely odd. Why in the world would pairing it to the S3 cause this kind of issue? Then a reset, which should wipe out everything should have fixed it. Have you contacted Samsung direct after this latest discovery?

    Going to iPhone wont get you VR or USB peripherals so that probably wouldnt be the best idea lol.
    06-20-2017 07:06 AM
  10. pankaj981's Avatar
    It may sound stupid but have you tried to lock the Gear VR to your phone after inserting it in the USB slot? There's a small lock icon on the Gear VR connector. Connect your phone and try locking it. I had the same issue with my S7E and toggling the lock unlock switch kinda triggered it to work again.
    06-20-2017 08:33 AM
  11. arunma's Avatar
    It may sound stupid but have you tried to lock the Gear VR to your phone after inserting it in the USB slot? There's a small lock icon on the Gear VR connector. Connect your phone and try locking it. I had the same issue with my S7E and toggling the lock unlock switch kinda triggered it to work again.
    I appreciate the suggestion. I don't believe I've tried locking the Gear VR after plugging in the phone (rather I have it locked before I plug in my phone). I'll certainly try this out. It'd be ironic if this is what works after everything else I've tried!
    06-20-2017 09:01 AM
  12. pankaj981's Avatar
    I appreciate the suggestion. I don't believe I've tried locking the Gear VR after plugging in the phone (rather I have it locked before I plug in my phone). I'll certainly try this out. It'd be ironic if this is what works after everything else I've tried!
    So did it work?
    06-21-2017 07:02 AM
  13. arunma's Avatar
    So did it work?
    I didn't have time to try this last night, but I am planning to do so tonight. I've decided that if this doesn't work, I'm going to attempt to flash the original firmware back on to my phone. And if that doesn't work, T-Mobile has yet another warranty replacement arriving for me this Friday. Although I'm not sure why I'm expecting a different result from the last time I got a warranty replacement. I guess I can try pairing my watch before I update the software. In any case, I'll keep you all posted!
    06-21-2017 11:32 AM
  14. arunma's Avatar
    Well...I reflashed, and there was no change to my USB port. Last night I raised the white flag and went to T-Mobile for my second warranty replacement in as many weeks. This time, I did not restore my apps from either Google or the Samsung Cloud. I began reinstalling the apps that I regularly use, and so far so good. I've now gone almost 24 hours with functioning USB peripherals. I guess one of the apps I downloaded must have somehow ruined my USB port.

    Of course none of this is helpful. I have no idea what I did previously or how I can avoid it. I've never downloaded an app from anywhere except the Play or Galaxy app stores, and I have absolutely no custom ROMs on my phone. I'm glad to have a working phone, but the underlying software issue is unresolved. Wish there were a way to file a bug report which would be taken seriously.
    06-23-2017 05:32 PM
  15. arunma's Avatar
    Well...that lasted a little over a month. Just earlier this week I once again experienced the same problem. I know I'm somehow responsible, likely due to an app I've downloaded. I just have no idea what I'm doing to my phone that causes this. I had to get yet another warranty replacement from T-Mobile. For those who are counting, yes I'm at three replacements.

    At this point I'm just hoping it'll last until September so I can upgrade to the Note 8. Don't get me wrong, I love everything else about the S8+, but this single problem is immensely frustrating.
    08-03-2017 07:36 PM
  16. justin_l's Avatar
    Well...that lasted a little over a month. Just earlier this week I once again experienced the same problem. I know I'm somehow responsible, likely due to an app I've downloaded. I just have no idea what I'm doing to my phone that causes this. I had to get yet another warranty replacement from T-Mobile. For those who are counting, yes I'm at three replacements.

    At this point I'm just hoping it'll last until September so I can upgrade to the Note 8. Don't get me wrong, I love everything else about the S8+, but this single problem is immensely frustrating.
    For what it's worth, I seem to be having the same issue. Ordering my replacement phone now, let's see if I face the same luck!
    08-05-2017 01:25 AM
  17. arunma's Avatar
    For what it's worth, I seem to be having the same issue. Ordering my replacement phone now, let's see if I face the same luck!
    Wow, sorry to hear that! Based on my experience, I might suggest not restoring your app data from Samsung Cloud. But if you do so anyway, let me know how it goes!

    Here's an interesting data point. Today at work I noticed that one of the conference rooms had a USB-C to DVI cable plugged into a projector. The "duh...what's this button do?" part of my brain kicked in and I plugged it into my phone, causing my phone to randomly crash and reset. Due to the finicky nature of the USB connectivity I figured that I must have done something to my phone again. I tried plugging in a USB thumb drive, and miraculously it worked!

    Further indication, I suppose, that whatever I've done to my phone three times in a row is software-based rather than hardware-based.
    08-17-2017 08:12 PM
  18. werwill's Avatar
    Hi! I'm on the same boat and I was wondering if you finally got your S8/OTG working after connecting the USB-C to DVI cable and the crash you mentioned.

    I'm thinking seriously on taking my S8 to my carrier for a replacement phone.

    Thanks!
    12-27-2017 12:26 PM
  19. Winstin Mizoshiri's Avatar
    I had plugged my mouse(wireless) into my OTG and it worked for a few minutes before stopping. I've tried everything but a factory reset. I don't know why it would have stopped working after working perfectly fine. I would prefer solving this without rooting my phone
    05-21-2018 02:35 AM
  20. bilaliz's Avatar
    Oddly enough I realized couple of days ago that my gear VR also stopped working, and then I plugged in a USB key and it also wouldn't work. Seems like I'm in the same boat as you are.
    Here are the apps that I think I installed after which everything went haywire.
    Aware
    Carrot
    Costco
    Drop
    Designer
    Fit
    Learn Python
    SoloLearn
    SONGily

    Let's share the apps that we installed around the time everything went wrong. And maybe we'll figure out the root cause.
    07-05-2018 01:34 AM
  21. bilaliz's Avatar
    Ok for some reason it started working for me again, the only things I can see that I did differently are
    1- accidently closed all my tabs in the Samsung browser.
    2- set the phone to no longer notify me everytime some app uses the microphone or camera etc.
    3- completed a couple of lessons on solo learn.
    07-10-2018 09:44 PM
  22. bilaliz's Avatar
    All right, so it is a hundred percent nailed down to the sololearn/learn Python app. normally if I put my phone in the VR or attach an accessory it would simply not work. but if I turn on either of the two apps, close them and then put the phone in the VR or attach an accessory the phone recognizes them.
    Btw I am on Koodo S8 in Canada
    07-11-2018 10:59 PM
  23. bilaliz's Avatar
    so the greenify app give me the permanent solution, I greenify solo learn and I have not had this problem since.
    07-18-2018 10:15 PM

Similar Threads

  1. Replies: 3
    Last Post: 06-15-2017, 12:22 PM
  2. Replies: 1
    Last Post: 06-10-2017, 11:57 AM
  3. My s7 s view flip cover doesn't my s7 edge gold
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2017, 09:42 AM
  4. My s7 s view flip cover doesn't detect my s7 edge gold
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2017, 09:42 AM
  5. Chrashing to lock screen om S Galaxy Tab S2 8.0
    By Brenthard in forum Ask a Question
    Replies: 0
    Last Post: 06-10-2017, 09:40 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD