1. dmoss7's Avatar
    One issue I have with this device is that any time I restart it, the WIFI automatically turns on. I have unlimited data and pretty much have WIFI turned off 95% of the time. I just want it to retain the setting it was on when the device is restarted. So really, this isn't a big issue, more of an annoyance/nuisance. I've looked for a setting in multiple places, but can't find anything. Anyone have any insight?
    06-13-2017 09:14 AM
  2. Tim1954's Avatar
    Have you got WiFi calling on maybe? It's in phone... Settings...
    06-13-2017 09:38 AM
  3. dmoss7's Avatar
    Have you got WiFi calling on maybe? It's in phone... Settings...
    Nope, I do not have WiFi calling activated.
    06-13-2017 10:01 AM
  4. Ecm's Avatar
    OP, do you have Smart Network Switch enabled? From the setting description: "... Smart network switch will automatically turn saved WiFi networks on or off". This may be the culprit.

    Edit: That's under WiFi > Advanced > Smart Network Switch.
    06-13-2017 10:09 AM
  5. dmoss7's Avatar
    OP, do you have Smart Network Switch enabled? From the setting description: "... Smart network switch will automatically turn saved WiFi networks on or off". This may be the culprit.

    Edit: That's under WiFi > Advanced > Smart Network Switch.
    Nope. I pretty much have every WiFi setting turned off that I can think of. The only one I have on is "Keep WiFi on during sleep" because I don't want it to shut off if I choose to update apps over wifi and turn the screen off.
    06-13-2017 10:17 AM
  6. Almeuit's Avatar
    Is WiFi off when you reboot? Mine only stays on if it was on before I rebooted.
    06-13-2017 10:30 AM
  7. dmoss7's Avatar
    Is WiFi off when you reboot? Mine only stays on if it was on before I rebooted.
    Yeah, I pretty much always have it turned off. I only turn it on if I have a lot of app updates to do and turn it off as soon as they're done.
    06-13-2017 10:43 AM
  8. dmoss7's Avatar
    After some more trial and error, I figured out what's causing it. It's my gear s2. Even though it connects to my phone via Bluetooth, it apparently turns my WiFi on when it initially connects to my phone.
    smvim likes this.
    06-13-2017 10:51 AM
  9. Almeuit's Avatar
    After some more trial and error, I figured out what's causing it. It's my gear s2. Even though it connects to my phone via Bluetooth, it apparently turns my WiFi on when it initially connects to my phone.
    Ah -- makes sense. Glad you found the culprit . I don't have a smart watch so that explains why I never ran into it.
    Tim1954 likes this.
    06-13-2017 10:59 AM
  10. rph72's Avatar
    I have the gear s3 and also noticed that wifi would switch on randomly. Now we know why.
    06-13-2017 11:02 AM
  11. Tim1954's Avatar
    Thanks for sharing that with us all!
    Happy days
    06-13-2017 11:21 AM
  12. dmoss7's Avatar
    From a little research and assumptions, the watch turns the wifi on so it can sync the settings. That way, if you are away from your phone (out of BT range), wifi on the watch will try to connect to the same network so you will still receive notifications etc.
    06-13-2017 11:47 AM

Similar Threads

  1. newbie question
    By bbsstmez in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 06-13-2017, 07:04 AM
  2. Developer mode questions
    By jontalk in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 06-12-2017, 03:30 PM
  3. My wifi wont finish authenticating or obtain ip afdress
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-12-2017, 02:46 PM
  4. Gonna buy an Android for the first time! Have some questions
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-12-2017, 01:23 PM
  5. Nexus 6p Wifi disconnects after idling for an hour
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-12-2017, 02:21 AM
LINK TO POST COPIED TO CLIPBOARD