06-20-2018 03:20 PM
26 12
tools
  1. therh's Avatar
    Hello all,

    I recently received an OS update on my S8 and now I do not receive Gmail push notifications. Please help.

    RH
    06-22-2017 07:04 PM
  2. njdan30's Avatar
    Have you tried to toggle notifications? maybe check priority button?
    06-22-2017 07:08 PM
  3. erasat's Avatar
    Hello all,

    I recently received an OS update on my S8 and now I do not receive Gmail push notifications. Please help.

    RH
    There are a lot of threads about your exact issue but in a summary go to battery settings, click battery usage then the 3 vertical dots and go to Optimize battery usage, be sure to have Gmail on the, Apps not optimized option. Doze is print to sleep the apps that are there so you won't get any notifications, I mean if you haven't changed anything after the update.

    Not an S8 related issue, Gmail app has this issue for some time now and it has gotten a lot worse since Nougat and the new Doze feature. Even with the above I still have this once in a while, but thanks God not as much as before, so this definitely helps a lot.
    06-22-2017 07:19 PM
  4. therh's Avatar
    Can you please post a screen shot of what you mean on the "three dots" ?
    06-22-2017 07:41 PM
  5. erasat's Avatar
    Can you please post a screen shot of what you mean on the "three dots" ?
    I'm on my iPad now, but the 3 vertical dots at the top right of most settings menus brings you to a sub menu or settings.
    06-22-2017 07:47 PM
  6. therh's Avatar
    Oh OK, I took a look at set it. But I'm still not getting push notifications. I'd hate to do a hard reset. I have everything backed and can restore my phone in less than an hour if I wanted to, but rather not.
    06-22-2017 08:04 PM
  7. erasat's Avatar
    Oh OK, I took a look at set it. But I'm still not getting push notifications. I'd hate to do a hard reset. I have everything backed and can restore my phone in less than an hour if I wanted to, but rather not.
    No need to, once you do what I posted they will begin arriving again, sometimes immediately, sometimes it will take some tricks, maybe turn sync off and back on then a restart. See if that helps if not believe me don't reset just yet, do a search and you'll see that is more common than you may think.
    06-22-2017 08:16 PM
  8. Misterb's Avatar
    Fix this Google! It's ridiculous to be worse off with notifications, than I was back in 2008 when I had a Blackberry Curve!
    06-22-2017 08:49 PM
  9. njdan30's Avatar
    Go into gmail settings and under notifications click sounds and then toggle for every message
    06-23-2017 01:04 AM
  10. Misterb's Avatar
    Go into gmail settings and under notifications click sounds and then toggle for every messagehttps://uploads.tapatalk-cdn.com/201...90629ba579.jpg
    Already set that way
    06-23-2017 02:08 AM
  11. njdan30's Avatar
    Try going into apps show system apps select gmail clear data and then goto gmail app? that seemed to get my notifications back. Maybe sign out and back in if that doesn't work? mine were giving me issues when I 1st took update but it seems to be working now
    06-23-2017 02:26 AM
  12. therh's Avatar
    Ok I did that, and I have nothing just get but I will check it out in the morning
    06-23-2017 03:09 AM
  13. therh's Avatar
    Well, it seems to not be working. But I found a workaround. I downloaded Inbox from Google and kept Gmail as the default app, and things have been working great. I hope this gets fixed and I do not need a workaround.
    06-23-2017 08:51 AM
  14. sydneycooper1979's Avatar
    Have you rebooted since the update and changing your settings?
    06-23-2017 09:01 AM
  15. JeBe4's Avatar
    Gmail has been lagging for all 9 of my mobile devices so it's something they need to address.

    KEYᵒⁿᵉ
    06-23-2017 09:43 AM
  16. therh's Avatar
    I've tried it all, installing the Inbox app like I said above seams to have solved it.
    06-23-2017 01:25 PM
  17. njdan30's Avatar
    Mine wss having issues lately after this update but went into settings apps then turned on permissions and notifications all good again
    07-07-2017 11:56 PM
  18. whitecollar's Avatar
    I got gmail notifications to turn on (not Inbox which was already working and which I don't really like) but Gmail. To do so I went to Notifications-all aps-Gmail and then touched the little blue I next to gmail which took me to a page where I touched my email address and the had to click yet another box allowing notifications.
    07-08-2017 07:35 AM
  19. imoanbackwards's Avatar
    Ok I registered on this website just to post what worked for me because absolutely none of these worked and I found the actual solution.

    Samsung has been scared of the battery fiasco since the note 7 and since the battery in the s8 is smaller they've basically placed Gmail and all other apps into a power saving mode. I was having push notification problems with Hangouts too by the way.

    1. Go to phone settings.
    2. Click "Apps"
    3. Press the 3 dots at top right corner and press "Special Access"
    4. Press "Optimize Battery Usage"
    5. At the top left it says "apps not optimized", press this until it says "All Apps"
    6. Scroll down to Gmail. You'll notice that it is "on" with a blue indicator on the right. You actually need to turn this "OFF", so that Gmail goes into the "apps not optimized" section.

    This is the only thing that worked for me after clearing cache, reinstalling, and all the other stuff posted.

    I hope this helps. Nougat 7 settings and Samsung s8.
    NMbug likes this.
    11-30-2017 11:47 AM
  20. Pattyzz's Avatar
    Ok I registered on this website just to post what worked for me because absolutely none of these worked and I found the actual solution.

    Samsung has been scared of the battery fiasco since the note 7 and since the battery in the s8 is smaller they've basically placed Gmail and all other apps into a power saving mode. I was having push notification problems with Hangouts too by the way.

    1. Go to phone settings.
    2. Click "Apps"
    3. Press the 3 dots at top right corner and press "Special Access"
    4. Press "Optimize Battery Usage"
    5. At the top left it says "apps not optimized", press this until it says "All Apps"
    6. Scroll down to Gmail. You'll notice that it is "on" with a blue indicator on the right. You actually need to turn this "OFF", so that Gmail goes into the "apps not optimized" section.

    This is the only thing that worked for me after clearing cache, reinstalling, and all the other stuff posted.

    I hope this helps. Nougat 7 settings and Samsung s8.
    12-04-2017 07:52 PM
  21. Pattyzz's Avatar
    Thank you imoanbackwards...the gmail notification you suggest WORKED!!!. Not sure how to reply to you I'm new here. I spent 3hrs trying every combination I could think of, even getting app fiir notication sounds...lol. but donuou know hiiw to change default notification sound, I wentbbto ringtones but wehsst kk select doesn't sound?? But any sound us better than no sound...lol. THANK YOU AGAIN!! I nevrrr thought about going into optimize battery and turning OFF GMAIL....WOW
    12-04-2017 07:59 PM
  22. Pattyzz's Avatar
    Thank you imoanbackwards...the gmail notification you suggest WORKED!!!. Not sure how to reply to you I'm new here. I spent 3hrs trying every combination I could think of, even getting app fiir notication sounds...lol. But any sound is better than no sound...lol. THANK YOU AGAIN!! I nevrrr thought about going into optimize battery and turning OFF GMAIL....WOW
    12-04-2017 08:18 PM
  23. Kats2002's Avatar
    Ok I registered on this website just to post what worked for me because absolutely none of these worked and I found the actual solution.

    Samsung has been scared of the battery fiasco since the note 7 and since the battery in the s8 is smaller they've basically placed Gmail and all other apps into a power saving mode. I was having push notification problems with Hangouts too by the way.

    1. Go to phone settings.
    2. Click "Apps"
    3. Press the 3 dots at top right corner and press "Special Access"
    4. Press "Optimize Battery Usage"
    5. At the top left it says "apps not optimized", press this until it says "All Apps"
    6. Scroll down to Gmail. You'll notice that it is "on" with a blue indicator on the right. You actually need to turn this "OFF", so that Gmail goes into the "apps not optimized" section.

    This is the only thing that worked for me after clearing cache, reinstalling, and all the other stuff posted.

    I hope this helps. Nougat 7 settings and Samsung s8.
    05-20-2018 06:35 PM
  24. Kats2002's Avatar
    This worked! I have been wrapping my head around this issue since getting my new phone a few days ago. It's a Samsung A5.

    Thank You!
    05-20-2018 06:37 PM
  25. NMbug's Avatar
    This worked for me,too,after going through the more obvious steps. Thanks!! I was not able to receive Gmail notifications on my Galaxy S7 until taking the "Special Access" path. Many thanks for including step-by-step instructions.
    06-20-2018 03:06 PM
26 12

Similar Threads

  1. Looking for specific case. Help, please.
    By Racing24 in forum Samsung Galaxy S8 & S8+
    Replies: 4
    Last Post: 06-22-2017, 09:37 PM
  2. whatsapp stopped identifying contacts
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-22-2017, 06:04 PM
  3. Replies: 1
    Last Post: 06-22-2017, 02:25 PM
  4. Help with back up
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2017, 01:25 PM
  5. Javier I need a bit more help
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-22-2017, 12:09 PM
LINK TO POST COPIED TO CLIPBOARD