1. jpwarne's Avatar
    Device: Samsung Galaxy S8+
    Provider: AT&T
    Android Version: 7.0

    I had this issue about a month ago and nothing I tried fixed it until it fixed itself one day. Suddenly, the issue is back.

    Issues:
    * Messaging: The Badge Notification Icon defaults to 1 new even though all have been read, no matter the messaging app I use.
    * Gmail: Inside the app shows I have x number of unread when there are no new emails.
    * Weather Widget: No matter the weather widget I use, the manual Refresh icon will not cause the widget to refresh. If I select the widget to launch the app, I will see updated details in the app, but this still does not update the widget.
    * Play Store: App updates will take a while to download, then at 100% will set for a very long time before it finally installs and leaves the queue to allow for the next app to update. This is not a case of me being impatient. When I was not seeing these issues the updates performed as normal, quick and easy download and install, both over Wifi and Mobile Data.

    Steps Taken to Resolve:
    * Cleared Data on BadgeProvider
    * Restart
    * Master Reset
    * Cleared Cache
    * Deleted Apps/Widgets
    * Reinstalled Apps/Widgets

    Nothing I have done or found online has provided a permanent solution. Last resort is replacing the phone, but I don't see this as being a hardware issue. Can I really be the only one with this issue? Help, Please!
    08-04-2017 02:09 PM
  2. djm1947's Avatar
    Device: Samsung Galaxy S8+
    Provider: AT&T
    Android Version: 7.0

    I had this issue about a month ago and nothing I tried fixed it until it fixed itself one day. Suddenly, the issue is back.

    Issues:
    * Messaging: The Badge Notification Icon defaults to 1 new even though all have been read, no matter the messaging app I use.
    * Gmail: Inside the app shows I have x number of unread when there are no new emails.
    * Weather Widget: No matter the weather widget I use, the manual Refresh icon will not cause the widget to refresh. If I select the widget to launch the app, I will see updated details in the app, but this still does not update the widget.
    * Play Store: App updates will take a while to download, then at 100% will set for a very long time before it finally installs and leaves the queue to allow for the next app to update. This is not a case of me being impatient. When I was not seeing these issues the updates performed as normal, quick and easy download and install, both over Wifi and Mobile Data.

    Steps Taken to Resolve:
    * Cleared Data on BadgeProvider
    * Restart
    * Master Reset
    * Cleared Cache
    * Deleted Apps/Widgets
    * Reinstalled Apps/Widgets

    Nothing I have done or found online has provided a permanent solution. Last resort is replacing the phone, but I don't see this as being a hardware issue. Can I really be the only one with this issue? Help, Please!
    The first item updates immediately and then the following updates take 10 to 20 seconds after download completes the installation begins. I am on Verizon
    08-04-2017 04:23 PM
  3. rdickert's Avatar
    It's a bug with the latest Google App update. It was broken, then fixed, and apparently broken again. In the meantime, disable your Google app and everything will work again (except for Google of course)
    08-04-2017 07:55 PM
  4. jpwarne's Avatar
    It's a bug with the latest Google App update. It was broken, then fixed, and apparently broken again. In the meantime, disable your Google app and everything will work again (except for Google of course)
    That Worked! Thank you, so much! I was scared it was an OS version and I would have to wait for an update at that level. Now, hopefully they can get this back up and running as it should.
    08-07-2017 05:49 PM
  5. bnewton001's Avatar
    That Worked! Thank you, so much! I was scared it was an OS version and I would have to wait for an update at that level. Now, hopefully they can get this back up and running as it should.
    FWIW, as of January 7,2018, I still need to disable the Google app in order to get my badges and widgets to update correctly. I'm using a Galaxy S7 on Verizon running Android v 7.0.

    RDickert I never would have figured out what was causing this problem without your post - thanks!
    01-07-2018 09:03 PM

Similar Threads

  1. S7 Edge will not turn off without password help!!!
    By jackinthebox24 in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 08-06-2017, 11:54 AM
  2. Smule error playing full song
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2017, 09:42 PM
  3. Why can't I redownload apps.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-05-2017, 09:35 PM
  4. Replies: 1
    Last Post: 08-04-2017, 08:27 PM
  5. Why are the Icon Notifications not showing?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-04-2017, 01:34 PM
LINK TO POST COPIED TO CLIPBOARD