1. stuarttunstall's Avatar
    Hi

    Just taken delivery last week of the Samsung Galaxy S8+ handset... beautiful handset apart from one minor issue which is the Samsung mail app

    The issue is it is not giving me any sounds, popup or notifications in the notification bar when emails arrive ... It does show the number of mails on the icon..

    I have checked and all notifications are on, and notifications sound work for everything else...

    I have emailed the app developers who asked for the dump file from the handset and came back with this reply...

    Dear Customer,

    Please see below developer comment.

    You have 9 account in email app. and Email app notified like below from account 1 and 7. but this history is just the latest noti not all noti.

    Account details:
    mId=1
    Account details:
    mId=7

    Notification Stats:

    time=2017-07-31 18:56:58 accId=7 msgId=[608,] type=newemail
    time=2017-07-31 21:31:14 accId=1 msgId=[620,] type=newemail
    time=2017-07-31 23:02:09 accId=7 msgId=[629,] type=newemail
    time=2017-07-31 23:36:40 accId=7 msgId=[630,] type=newemail
    time=2017-08-01 00:27:21 accId=7 msgId=[631,] type=newemail
    time=2017-08-01 01:32:28 accId=7 msgId=[633,] type=newemail

    Also email notification history was saved from notification log.

    AggregatedStats{
    key='com.samsung.android.email.provider',
    numEnqueuedByApp=42,

    post_frequency{user_id=0,pkg=com.samsung.android.e mail.provider,day=0,count=9,muted=2/2,demoted=7}
    post_frequency{user_id=0,pkg=com.samsung.android.e mail.provider,day=1,count=33,muted=15/15,demoted=18}
    post_frequency{user_id=0,pkg=com.samsung.android.e mail.provider,day=2,count=34,muted=7/7,demoted=27}
    post_frequency{user_id=0,pkg=com.samsung.android.e mail.provider,day=3,count=12,muted=7/7,demoted=5}
    post_frequency{user_id=0,pkg=com.samsung.android.e mail.provider,day=4,count=7,muted=2/2,demoted=5}

    This means that there is no problem in email notification setting.

    So when we see the sync history. there was no new email even if email app sync per 15 min.
    Could you check that your mail is properly synced? We want to check that whether this issue is sync issue or notification issue.

    Legacy Sync History:
    time=2017-08-01 05:49:10 accId=3 mbId=12 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=0 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1986
    time=2017-08-01 05:49:13 accId=3 mbId=12 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=0 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1590
    time=2017-08-01 05:49:21 accId=6 mbId=24 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=10 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=2185
    time=2017-08-01 05:49:23 accId=6 mbId=24 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=10 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1509
    time=2017-08-01 05:49:31 accId=7 mbId=28 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=192 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1575
    time=2017-08-01 05:49:33 accId=7 mbId=28 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=192 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1431
    time=2017-08-01 06:05:07 accId=1 mbId=4 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=79 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=2302
    time=2017-08-01 06:05:14 accId=2 mbId=8 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=1 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1772
    time=2017-08-01 06:05:22 accId=6 mbId=24 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=10 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1780
    time=2017-08-01 06:05:30 accId=7 mbId=28 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=192 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1712
    time=2017-08-01 06:05:38 accId=4 mbId=16 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=27 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1603
    time=2017-08-01 06:05:46 accId=3 mbId=12 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=0 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1601
    time=2017-08-01 06:05:54 accId=5 mbId=20 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=5 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1668
    time=2017-08-01 06:06:01 accId=9 mbId=36 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=3 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=866
    time=2017-08-01 06:06:08 accId=8 mbId=32 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=1 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=545
    time=2017-08-01 06:21:10 accId=1 mbId=4 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=79 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=2291
    time=2017-08-01 06:21:17 accId=2 mbId=8 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=1 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1587
    time=2017-08-01 06:21:24 accId=6 mbId=24 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=10 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1559
    time=2017-08-01 06:21:32 accId=7 mbId=28 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=192 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1940
    time=2017-08-01 06:21:40 accId=4 mbId=16 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=27 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1630
    time=2017-08-01 06:21:47 accId=3 mbId=12 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=0 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1645
    time=2017-08-01 06:21:55 accId=5 mbId=20 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=5 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1469
    time=2017-08-01 06:22:01 accId=9 mbId=36 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=3 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=1069
    time=2017-08-01 06:22:08 accId=8 mbId=32 mTotal=0 mFetched=200 mNew=[] mSpam=null mUpdated=0 mDeleted=1 mSyncableMessages=200 mloadMoreCount=1 mSynckey=0:0: mSyncTime=433

    If you have a same problem. Please share detailed issue description and share dump file and email log.

    To enable debug mode:
    1. Go to new account setup page.
    2. Enter email "d@d.d" and password "debug".
    3. Press "Manual setup" button (if there is no "Manual Setup" button, just press left button at the bottom of screen, text is not important).
    4. Check top three checkboxes on debug screen.
    5. Reproduce the issue.
    6. Get BOTH log dump and file emaillog.txt from device. File emailog.txt is located in sdcard root.


    i sent 8 emails one to each account and they all synced on the handset but never sounded...

    I have now done as they requested and sent the email log and the latest dump file, so I will see what happens, failing that I will use MailDroid..

    If you read the play store others have had the same issue since the last update but as usual it is at my end not the app

    Does anyone else have this issue?

    Stuart
    08-05-2017 03:03 AM
  2. mary beth hale's Avatar
    I can get the sound notification but no pop up or badge count on app icon.
    08-05-2017 08:47 PM
  3. stuarttunstall's Avatar
    I can get the sound notification but no pop up or badge count on app icon.
    The badge count always works on mine, it is just the sound/popup I do not get... it is strange, it has worked twice this morning and now silent again

    I have notified them and they have had more requested logs, but I have a felling they are syaing it is working and it is me! ... strange how others on the play store have commented since the last update...

    Will see what they say now...
    08-06-2017 02:23 AM
  4. stuarttunstall's Avatar
    Following a few dump logs and email log Samsung have identified my issue... I can also confirm that changing the emails set up from POP3 to IMAP cured the notification issue and everything worked. SO hopfully they will release the update and I can get back to normal

    Dear Customer,


    We found root cause of this issue from log. We found sync is ok. but there was no notification.
    Because some message have 0 timestamp. so we recognized it is old mail and then no notified it.
    Additionally If there is no message in list. There will be no notification even if new mail is arrived.
    2017-08-08 18:39:01:434 12469 22797 [tPopSyncCommandsQueue1] PopSync| oldestTimeStamp =1502213825000
    2017-08-08 18:39:11:692 12469 22839 [tPopSyncCommandsQueue2] PopSync| oldestTimeStamp =0
    2017-08-08 18:39:14:854 12469 22858 [tPopSyncCommandsQueue3] PopSync| oldestTimeStamp =0
    2017-08-08 18:39:22:254 12469 22890 [tPopSyncCommandsQueue4] PopSync| oldestTimeStamp =0


    Maybe your account have some message which have 0 timestamp message(like 1970 year) or No message in list.
    This issue is only reproduced when using pop account. so if possible, you can configure account as Imap protocol. Notification will be work properly.

    But we can not send email apk because internal policy. we will upload email apk to play store in next release.
    Thank you for helping to solve this issue.

    Thank you.
    Best Regards,
    Samsung Email Team
    08-10-2017 02:24 PM
  5. Bowhunt24's Avatar
    Same here but slightly different. I use samsung mail app for my corp exchange. All was working wonderfully until a week or two ago. No when I get more than one new e-mail, instead of showing the detail on the notification (usually a quick subject and from address) it just says 2 or 3 or however many "new mails" but shows no detail. This must have been a break in latest update. No settings were changed from it working normally to not.
    08-10-2017 03:14 PM
  6. gtffo's Avatar
    Same here but slightly different. I use samsung mail app for my corp exchange. All was working wonderfully until a week or two ago. No when I get more than one new e-mail, instead of showing the detail on the notification (usually a quick subject and from address) it just says 2 or 3 or however many "new mails" but shows no detail. This must have been a break in latest update. No settings were changed from it working normally to not.
    This! I came here to find help to this same problem. Some weeks ago I noticed that the few lines' preview of mails in the notifications does not work anymore. The same in the lock screen. I have checked notification settings for this app and the option "show content in lock screen" (I don't have English language so I don't know the exact name of the setting) is enabled.
    Bowhunt24 likes this.
    08-11-2017 03:53 AM
  7. Bowhunt24's Avatar
    This! I came here to find help to this same problem. Some weeks ago I noticed that the few lines' preview of mails in the notifications does not work anymore. The same in the lock screen. I have checked notification settings for this app and the option "show content in lock screen" (I don't have English language so I don't know the exact name of the setting) is enabled.
    It had to have been a bug in the latest OS or mail app update. Has to be. I made no settings changes in that area and the behavior just changed one day. I bet next update addresses it, hopefully. It's super annoying to not see the preview! ha ha ha. -Evan
    08-11-2017 10:24 AM
  8. justafew's Avatar
    This! I came here to find help to this same problem. Some weeks ago I noticed that the few lines' preview of mails in the notifications does not work anymore. The same in the lock screen. I have checked notification settings for this app and the option "show content in lock screen" (I don't have English language so I don't know the exact name of the setting) is enabled.

    Yep, I noticed this as well and it happened once I updated the email app with the app now appearing in the Google Play store. I thought it was something else causing the issue and I finally ended up wiping/restoring my phone. Once I did that, the notifications were working fine again. I did NOT update to the latest version in the Play Store (4.1.66.2). I'm still currently on version 4.1.53-1.
    If you look at the latest reviews in the Play Store, there are numerous complaints about the same thing. Hoping they don't take much longer to fix it, but I'm going to be careful about updating if/when they do release a fix, to ensure it really does work first.
    In the meantime, I used an app to save an apk of the version that I have. Now if I do update in the future and it's still messed up, I can just revert to that apk rather than wiping my phone again. Safety net!
    Bowhunt24 likes this.
    08-12-2017 10:41 AM

Similar Threads

  1. Replies: 3
    Last Post: 05-01-2018, 05:36 PM
  2. What app is this, picture is from notification bar.??
    By Angel LaBelle in forum General Help and How To
    Replies: 2
    Last Post: 08-05-2017, 08:37 PM
  3. Samsung Galaxy S7 Edge Lock Screen
    By Mthog27 in forum Samsung Galaxy S7 edge
    Replies: 3
    Last Post: 08-05-2017, 04:07 AM
  4. Replies: 1
    Last Post: 08-05-2017, 01:06 AM
  5. Samsung Galaxy Note 8.0 GT-N5110 stuck in boot loop?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-05-2017, 12:07 AM
LINK TO POST COPIED TO CLIPBOARD