1. LondonLumia's Avatar
    Hi guys, wondering if anybody could help with a confusing issue I am having. Looking for past experiences etc.

    So, I bought a Galaxy S8 last week - and I'm loving it.
    Over the past few days, however, it's been a thing that when I plug in the original charger, the S8 will only charge 'normally' - fast charging doesn't happen, despite the setting being on. Occasionally, fast charge might decide to rear it's head, but if you take the cable out and then plug it in again, it disappears in favour of fast charging. This happens regardless of the socket I use.

    A hard reset did nothing (apart from making me spend more time getting the phone how I like it again - grr).

    So, at this point you're thinking it's either gonna be A) the charger or B) the phone, right?

    Well, I've borrowed and used two different fast charge wall plugs with my GS8 and both have fast charged it with no issues. So now you're saying; 'It's the original charger with the problem', right? But this is where it gets interesting;

    You see, I've also tested this apparently-faulty original adapter on two different phones - an S7 and a A5. And both of these will fast charge.
    *It's worth noting that with the A5, there was one incident where plugging it in resulted in no fast-charge - taking the lead out and in again solved this, I'm keeping an eye on it to see if it repeats because this may indicate it's the adapter*

    So this is where I'm at, in a nutshell;
    - Original charger does not fast charge the phone it came with
    - Original charger will apparently fast charge other phones (despite one small blip, see above) and therefore seems to have a grudge with my S8.
    - However, my phone will still charge normally regardless of what I use. It's just fast-charging that's my concern.

    I'm hoping that this issue isn't with my phone and is instead with the adapter, because I really don't want to have to return my much-loved S8 and would rather just fork out for a new adapter. Has anyone else had similar problems before?

    Many thanks in advance.
    08-07-2017 09:06 AM
  2. Fuego's Avatar
    I experienced this chore a couple of days on my S8+. I unplugged the USB-A cable and reseated it. That solved the problem and it hasn't come back.
    08-08-2017 08:18 PM

Similar Threads

  1. Why does my sound not work?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-10-2017, 04:45 AM
  2. What to do if my oppo A37's camera is not working?
    By rei3 in forum Ask a Question
    Replies: 4
    Last Post: 08-07-2017, 12:25 PM
  3. Replies: 1
    Last Post: 08-07-2017, 07:15 AM
  4. Why does this app keep asking for my location
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-07-2017, 06:58 AM
  5. Replies: 0
    Last Post: 08-07-2017, 06:33 AM
LINK TO POST COPIED TO CLIPBOARD