1. OkayKirby's Avatar
    When ever my Galaxy S8+ has been restarted, updated, or shut off and turned back on it stays on the white screen that says the name of my carrier then has its four colorful loading dots.
    This screen stays up to 20 minutes or more when I am in need of my phone turning on now.
    I've never had or seen a phone that took so long to turn on before, my Galaxy S7 took much less.
    What can I do to fix this? I don't have time to wait like this every time I have to restart, update, or turn it back on...
    09-05-2017 12:25 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! That sounds like it could be either faulty firmware or hardware. What happens if you boot into Safe Mode instead? https://support.t-mobile.com/docs/DOC-34283
    09-05-2017 10:29 PM
  3. OkayKirby's Avatar
    Welcome to Android Central! That sounds like it could be either faulty firmware or hardware. What happens if you boot into Safe Mode instead? https://support.t-mobile.com/docs/DOC-34283
    Nothing really changes other than the system being on safe mode. It's load time for turning on is about the same.
    This morning I spent an hour and a half waiting for it to turn on.
    09-06-2017 12:52 AM
  4. B. Diddy's Avatar
    Bring it back to the store where you bought it, and ask for an exchange. If it's too late for that, then contact Samsung directly for warranty replacement.
    09-06-2017 09:53 AM
  5. Ev C's Avatar
    Something is definitely wrong. This phone reboots very fast. Exchange it.
    RiverCity.45 likes this.
    09-06-2017 11:32 AM
  6. SlippySlimm's Avatar
    Factory reset and DON'T restore from any backups. Start fresh. If the problem persists, you need to get it replaced as something is definitely wrong with your device. Mine starts up super quick every time.
    tuscanybay likes this.
    09-06-2017 03:05 PM
  7. rushmore's Avatar
    My Verizon 8+ has over 300 apps installed and only 5gb free. Takes about one minute to restart the device or turn on from cold. Had since launch.
    09-06-2017 09:58 PM
  8. tuscanybay's Avatar
    Factory reset and DON'T restore from any backups. Start fresh. If the problem persists, you need to get it replaced as something is definitely wrong with your device. Mine starts up super quick every time.
    ^^^ Definitely do this before bringing your phone for service or replacement.
    09-07-2017 07:28 AM

Similar Threads

  1. Will the Mate 10 come to USA carriers?
    By dpham00 in forum Huawei Mate 10 & Mate 10 Pro
    Replies: 21
    Last Post: 11-15-2017, 10:39 AM
  2. Netflix adds Note 8 to their HDR lineup, while we still wait
    By Ramon Castillo1 in forum Samsung Galaxy S8 & S8+
    Replies: 5
    Last Post: 09-05-2017, 04:26 PM
  3. Replies: 1
    Last Post: 09-05-2017, 12:21 PM
  4. Easiest Way to Use Bixby to Add Item to Google Tasks?
    By Jon44 in forum Samsung Galaxy S8 & S8+
    Replies: 0
    Last Post: 09-05-2017, 12:01 PM
  5. Bypass my pin on a moto z from another phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-11-2017, 06:26 AM
LINK TO POST COPIED TO CLIPBOARD