08-11-2020 10:33 AM
46 12
  1. Blaz 1's Avatar
    Thank you so much for the answer! I think the Google app assumed that it couldn't save items to the storage, so it saved items inside the app itself. I think that's why we couldn't access it conventionally. Thank you though!
    10-14-2018 05:22 PM
  2. Nonstopdrivel's Avatar
    Anything I saved prior to this still didn't appear, but any new pictures I saved have shown up as expected.
    Thanks so much for the tip. Now the question is how do we recover the files we saved before we granted the Google app internal storage permissions? It's driving me insane that I can see the beautiful pictures I've downloaded from the Backgrounds menu, but I can't access them from any other app -- even Google Photos! -- in order to edit them (for example, to make them fit my screen better) or simply enjoy them for their own sake. Is there any way to restore access to these files without rooting the phone?

    Also, what on earth could be Google's motivation for this design decision? How does it benefit Google to cut off its own apps, not to mention apps released by other developers, from files within that app's directory?

    open the Google app again, tap the Menu button at the lower right, then Saved
    I don't see any Saved option on my phone. Could you provide a screen shot?
    10-20-2018 03:35 PM
  3. B. Diddy's Avatar
    I don't see any Saved option on my phone. Could you provide a screen shot?
    Sorry, it's "Collections," not Saved. I think they might have renamed it since I posted that.
    10-20-2018 07:48 PM
  4. soofyne99's Avatar
    That was so helpful. All I had to do was go into settings>apps>google>and then allow storage permission. YAY
    Robert Mckelvain likes this.
    12-05-2018 01:42 AM
  5. Derpageddon's Avatar
    I have a Note 9 and I'm having this same issue. I found this forum by googling my problem. There are a ton of comments here so I read the first few comments and I noticed some of you were able to find your answer. For me, I followed some of those suggestions and it didn't really work. This is where it says my files go and I cannot find where this location is at all.
    Attached Thumbnails where does the google app save downloaded images?-screenshot_20190115-030432_chrome.jpg  
    01-15-2019 03:15 AM
  6. B. Diddy's Avatar
    Welcome to Android Central! That looks like your browser, not the Google search app. That directory is simply the /Download directory on the user root directory.
    01-15-2019 11:11 AM
  7. Advaera's Avatar
    Unfortunately as far as I can tell, the "Collections" within the Google App only points to material saved online to your Google account, not to files downloaded to the device.

    I used to have a good way to bypass this, the Google "Files" app which Google uses to load attachments to Gmail and Hangouts is cable of accessing the /document folder. I used to be able to use that app to move downloads from there to any other real folder where other apps can access them.

    Unfortunately again Google has now made that app inaccessible from app drawers and replaced it with their new Files Go app which cannot access the /document folder...

    I can verify that the Files app still exists in the All Apps area under settings, but I've spent the better part of the evening trying to find a way to open the app and I haven't figured that out yet. I even tried uninstalling the Files Go app, but Google only allows you to uninstall the updates, not the entire app. Disabling it doesn't trigger the old app to appear in the app drawer either.

    The Files app can definitely still see everything downloaded to the /document folder, and is capable of adding them as attachments to email. For me that's not an option because I have some really large files I need to transfer out of there, but for anyone with pictures or small files you can definitely just email them to yourself. That won't delete them out of the /document folder though.

    If anyone can help find a method to open the Files app in full mode rather than the attach mode that gets called up from other apps, it would be a huge lifesaver!
    01-22-2019 02:36 AM
  8. Advaera's Avatar
    Took me so long just to think of Google Drive!

    OK here's how to get the files out of the Google app download folder.

    Open up the Google Drive App
    Select "+" and then "Upload"
    This will open up the same attachment version of the Files app as Gmail
    By default it's probably in "Recent Files" so use the hamburger icon in the top left to navigate to Downloads.
    I know the files the Google app are not actually in your Downloads folder, but trust me, they show up in the Google Files Download folder.
    Select the files you want, long touch for multiple files.
    There you go! Once all of your files are on your Google Drive you can download them back into your normal Downloads folder and access them from any app.

    Now the only problem is deleting everything that's taking up space in the Google App folder. Without a file manager that can get in there it may take a full wipe and factory reset to do that.

    Hope that helps anyone else dealing with this!
    01-24-2019 01:35 AM
  9. Robert Mckelvain's Avatar
    THANK YOU !!!! This has been eating me up 4 sooo long. Just allow "storage access" n the "permissions" n the "Google" app !!! Thank u, thank u, thank u !
    02-11-2019 11:13 PM
  10. vbkindropzone's Avatar
    Wait. What!? You're absolutely right, it worked. Thanks for that tip!
    Attachment 289122
    Wow !!! It worked. This goddamn thing had been irritating me for ages now. If u were in front of me buddy i wud hv knelt down n kiss ur hand ,(: . . . You are the #Savior . . Godspeed Bud !
    Javier P likes this.
    03-14-2019 09:46 AM
  11. Ryzot's Avatar
    I was running into this same issue where a downloaded image from the Google app was not visible in any of my gallery apps or file browsers. For some reason, the Google App on my phone didn't have Storage permission. After I granted the Google app Storage permission, then pictures I downloaded through the Google App showed up in my galleries and file browsers. Anything I saved prior to this still didn't appear, but any new pictures I saved have shown up as expected. Hope this helps some of you, this was driving me nuts!
    Dude. You are the hero we need, but not the hero we deserve. You should be made a V.I.P. on all troubleshooting websites, and be paid millions of dollars a year because you sir, are one of the good guys.
    Manamoor and shadowsjc like this.
    04-20-2019 01:36 PM
  12. BeepThisIsNotaTest's Avatar
    You nailed it! That fixed the problem for me - genius!
    04-28-2019 12:57 AM
  13. Fire2's Avatar
    Should be directly in the "downloads" app.
    There is no "downloads" app.
    06-09-2019 07:23 PM
  14. Itsa_Me_Mario's Avatar
    There is no "downloads" app.
    There was on my S8+ in 2018 when I posted this, now it's called "My Files". Other devices have different names for basically the same app.
    06-10-2019 10:13 AM
  15. Doc Huard's Avatar
    on my galaxy s8, when i am in the google app and i hit "download image" it downloads the image but i cannot for the life of me figure out how to find the image. it's not visible in the google photos or samsung gallery apps and looking through the file structure i cannot find it anywhere. i get a notification from download manager telling me that it is downloaded, and i know it's being saved because if i download a second copy it appends a -1 to the filename but i cannot figure out how to access the images whatsoever. where are my images?
    This appears to be a permissions issue. If the Google App doesn't have permission for storage it stores downloaded files and images to a protected system directory which you cannot access without root.
    To correct go to Applications > Google > permissions and enable STORAGE.
    That should allow Google to store files to your default location. Images should now show up in your gallery.
    09-09-2019 05:24 PM
  16. WheelOfTheLaw's Avatar
    Like another poster, I created an account to say: holy crap, thank you!

    Why the hell it doesn't just ask for the permission the first time you hit "download" is beyond me...
    11-13-2019 11:08 PM
  17. taintedblakk's Avatar
    You are awesome, I've this problem for so long.. searched other places and asked at best buy.. No one had the solution.
    Thank you.
    01-31-2020 09:12 AM
  18. BasoBaso's Avatar
    Thank goodness I eventually found this site and a solution! Thank you. So simple once you know!!!
    02-16-2020 09:41 AM
  19. Marty42044's Avatar
    I came up with an easy workaround after being equally frustrated. I go to Google, then go to Yahoo -- find my image & download it. I appears in Gallery -- no problem!
    05-08-2020 11:25 AM
  20. B. Diddy's Avatar
    Welcome to Android Central! Are you accessing Yahoo from the Google search app? In that case, you're most likely jumping from the Google search app over to the browser in order to open the Yahoo website. That's why the images are downloading fine -- your browser already has Storage permission turned on. The issue in this thread is for people who are trying to download images directly with the Google search app (in which case it's a simple matter of turning on Storage permission for the Google app in the system settings).
    05-08-2020 02:29 PM
  21. jacksonbrownie's Avatar
    I personally noticed that when the photo has the motion thingy with it, and you click "download", it will always not be able to open the file, and I can never find it on "my files" app in my samsung phone. What you need to do is click the button "export" next to the download button. It gives you the choice to download the photo, or the motion photo which is basically downloaded in the form of a video. Also, when it downloads, it usually appears in the photos app of your phone with the specific date that is attached to the photo, so if the photo was from 2018, you need to scroll down in your photos app until you get to 2018 photos, and it will appear there. For normal photos without motion and videos, the "download" button works fine. I am writing this in 2020 btw, so things clearly changed from first this thread started
    08-11-2020 10:33 AM
46 12

Similar Threads

  1. How can I recover or restore or redownload my deleted Google play store app??
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 05-10-2019, 09:00 PM
  2. I clicked on disabled hangouts...does that mean I have deleted it
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-25-2018, 02:34 PM
  3. Can't capture video and lots of app crashes
    By Ninety-9 SE-L in forum Samsung Galaxy S9 & S9+
    Replies: 1
    Last Post: 04-25-2018, 01:54 PM
  4. Replies: 0
    Last Post: 04-25-2018, 01:03 PM
  5. Replies: 0
    Last Post: 04-25-2018, 01:03 PM