1. mccfarms's Avatar
    I am having trouble with my wifi connections on my samsung phones on my home internet. It is a problem isolated to the phones. My hard wired internet works fine on my iMac and all of my iPads work great. I use an Asus N12 router and have done every reboot etc. that is recommended. Some webpages and apps work on the phones wifi but this is because when I run a speedtest I get good download speeds but zeros on upload. Like I said all other devices work fine. I have also done all of the reboots etc. on the phones as well and no luck. This is driving me nuts. Any help would be greatly appreciated!
    04-27-2018 01:10 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you also tried rebooting the router by unplugging its power for about 30 seconds? If that doesn't help, see this guide for some other tips: http://forums.androidcentral.com/amb...-problems.html
    04-27-2018 03:44 AM
  3. StephaneM60's Avatar
    Hi,
    Some webpages and apps work on the phones wifi but this is because when I run a speedtest I get good download speeds but zeros on upload.
    If download speed is Ok and upload is 0, this may be because you have installed something on your phone like an ad blocker or a vpn software. I'm using Adguard and with the nperf speed test application I'm getting 0 on upload if Adguard is active.

    If you don't have any applications like this installed, then check if your router firmware is up to date (ASUS routers are great but you better update and be prepared to rollback when something wrong with some of your devices)
    04-27-2018 04:42 AM
  4. mccfarms's Avatar
    Yes router is up to date and I have no applications like that installed. Tried phone in safe mode just to be sure with same results
    04-27-2018 07:30 AM
  5. mccfarms's Avatar
    Yes have done that numerous times with no success. All of my devices work fine except my wife's samsung s8 and my s9. Both react exactly the same way. Good download speed and zero upload
    04-27-2018 07:31 AM
  6. StephaneM60's Avatar
    Good download speed and zero upload
    Just to be sure I understand correctly, other that the zero upload in the speed test application, how the S8 and S9 behave with internet access : can you watch YouTube videos, can you use the Samsung browser or Chrome to visit most web sites, can you visit the play store and download some apps ?

    Because you said "Some webpages and apps work" ok, but then what doesn't work (except the speed test)

    Have you been able to test your phone on another Wifi network ?
    04-28-2018 05:50 AM
  7. Baden113's Avatar
    I had same problem with Samsung S9. Poor/ non existent upload speed. Turned off optional "Download Booster" and upload speed returned to normal.
    05-10-2018 05:32 AM
  8. kemersonIA's Avatar
    I have the same issue with my S7 Edge, but only after switching my internet from CenturyLink (worked fine) to Mediacom 360. I would "connect" to the WiFi, but accessing the web I get "the site can't be reached." I have read it might be an Android/WiFi bug related to the latest OS update, but so far nobody can figure it out. Also posted on a different post on this forum.
    06-05-2018 09:01 AM
  9. kemersonIA's Avatar
    06-05-2018 09:02 AM
  10. GuccizBud's Avatar
    If download speed is Ok and upload is 0, this may be because you have installed something on your phone like an ad blocker or a vpn software. I'm using Adguard and with the nperf speed test application I'm getting 0 on upload if Adguard is active.
    Bingo! I had been having a related problem whereby, on mobile data, the S8+ stock browser was being choosy as to which sites to pull up and which sites to hit me with a blank page and "the site can't be reached". Was driving me nuts, and I came very close to calling my provider and telling them to get their collective a⁠ss in gear, lol.

    That's when I read your post and knew immediately I'd hit upon the solution. I had been using a private DNS for system-wide ad blocking, which you can do with Android Pie ⁠— ⁠turned it off, tried accessing two particular sites I hadn't been able to, and both showed up immediately.

    After that it was a matter of switching to another static DNS server and trying it out, and ⁠… so far, so good. We'll see. But at least now, I know what the cause is should the problem reoccur. Thanks man. I um, love you.
    08-08-2019 03:47 PM

Similar Threads

  1. Can't change my lock screen wallpaper to a different pic
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-27-2018, 03:56 PM
  2. Replies: 2
    Last Post: 04-27-2018, 03:50 AM
  3. Replies: 1
    Last Post: 04-27-2018, 03:46 AM
  4. Print in Samsung Email on Marshmallow Samsung Tab S
    By BJB1 in forum Samsung Galaxy Tab S 10.5
    Replies: 0
    Last Post: 04-26-2018, 11:41 PM
  5. My phone won't let me download any videos from facebook
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2018, 11:36 PM
LINK TO POST COPIED TO CLIPBOARD