1. Rick Swiatek's Avatar
    Has anyone had the following issues after the pie update and had a fix for them its driving me crazy and dont know what else to do.
    1. Keep getting moisture detection and wont charge.
    2. Wont fast charge when it does charge.
    3. Will no longer read my SD card.

    I have done nothing different with my phone since the update and it's never been in or near water, already did a partition cache wipe with same results.

    Thank You.
    06-17-2019 10:42 AM
  2. B. Diddy's Avatar
    Items 1 & 2 suggest a problem with the port itself -- the update might have been coincidental. Does it still happen in Safe Mode? https://support.t-mobile.com/docs/DOC-34283

    SD cards have also been known to fail or become corrupted after a system update (this happened on my daughter's Honor 8 recently). Does the SD card still work on other devices, or is it readable on a PC? If not, then the card has probably failed.
    06-17-2019 03:13 PM
  3. Rick Swiatek's Avatar
    fixed the fast charge issue seems it was unchecked after the update. yes my SD card does work in other devices.
    06-17-2019 04:25 PM
  4. B. Diddy's Avatar
    But you're still getting the moisture warning?

    For the SD card, you may have to back up the data on it to your computer, and then reformat the card.
    06-17-2019 05:42 PM
  5. Rick Swiatek's Avatar
    yes still getting the moisture issue. tried reformatting the card and it still wont read also put in another and it doesn't read either, it just doesn't detect an SD card.
    06-17-2019 10:33 PM
  6. B. Diddy's Avatar
    Assuming that it still happens in Safe Mode, the next step would probably be a factory reset. If that doesn't work, you may need to reinstall the firmware, using either Smart Switch or Odin.
    mustang7757 likes this.
    06-18-2019 02:13 PM
  7. Virginia Smith42's Avatar
    I wont be a lot of help except it did happen to me.i knew my sd card was fine and readable by others. I seem to remember it was something in the system settings that had to changed followed by a restart and all was fine. As far as charging, in my case it was the Samsung cable. it's not a solution but a hint
    07-07-2019 11:33 PM
  8. mustang7757's Avatar
    Assuming that it still happens in Safe Mode, the next step would probably be a factory reset. If that doesn't work, you may need to reinstall the firmware, using either Smart Switch or Odin.
    This I agree reinstall firmware
    07-07-2019 11:49 PM

Similar Threads

  1. Why is calendar mostly blank after update
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 06-18-2019, 10:19 PM
  2. samsung j6 fingerprint sensor not working after update 9.0
    By Android Central Question in forum Samsung Galaxy J Series
    Replies: 1
    Last Post: 06-17-2019, 03:15 PM
  3. Why the background messages setting gone after the installation of android pie?
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 06-17-2019, 04:57 AM
  4. samsung j6 fingerprint sensor not working after update 9.0
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-17-2019, 02:03 AM
  5. Why the background messages setting gine after I installed the android pie up?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-16-2019, 10:11 PM
LINK TO POST COPIED TO CLIPBOARD