1. Android Central Question's Avatar
    I have tried restarting the phone multiple times, resetting all network connections, wiped the cache partition, and reset my wifi router. I can stream HD videos, etc. on other devices as well as on my phone over wifi. When it comes to loading media on most apps (like twitter, gmail, signal and some others) the pictures and videos won't load over wifi; it just sits and spins. Gmail will not download emails right away, but I can easily load facebook videos and such over wifi. Once I switch to mobile data, everything on all apps loads normally.

    I have the most recent update and this problem has occurred over multiple update versions. Ookla Speedtest shows 99.6 mbps download and 5.89 upload
    06-04-2020 01:43 PM
  2. mustang7757's Avatar
    Try this guide , sounds like your WiFi a issue
    https://forums.androidcentral.com/sh...d.php?t=326698

    I'll leave a Link to register so you can communicate here as a guest account you can only post questions but can't reply
    https://forums.androidcentral.com/sh...d.php?t=409154
    Stephen 3 likes this.
    06-04-2020 01:45 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Are you able to try this on a different wi-fi network? Do you control your network, or is it supervised by someone else?
    mustang7757 and Stephen 3 like this.
    06-04-2020 02:03 PM
  4. Stephen 3's Avatar
    Welcome to Android Central! Are you able to try this on a different wi-fi network? Do you control your network, or is it supervised by someone else?
    Unfortunately I don't control the network, but I was able to log in to the xfinity public wifi of my neighbor and things already started to work better.
    Thank you for your help. I restarted the router once again and this time it seemed to have fixed the problem for now. I'll update if the problem persists, but thank you both!
    B. Diddy and mustang7757 like this.
    06-04-2020 02:40 PM
  5. mustang7757's Avatar
    06-04-2020 02:44 PM

Similar Threads

  1. Advice on Xiaomi phones, please.
    By villylr in forum General Help and How To
    Replies: 10
    Last Post: 06-11-2020, 08:44 AM
  2. Gmail App, can I use a custom "Sent" sound?
    By THEBDC in forum General Help and How To
    Replies: 6
    Last Post: 06-04-2020, 05:33 PM
  3. Gmail App, can I use a custom "Sent" sound?
    By THEBDC in forum Android Apps
    Replies: 0
    Last Post: 06-04-2020, 03:49 PM
  4. Advice on Xiaomi phones, please.
    By villylr in forum General News & Discussion
    Replies: 0
    Last Post: 06-04-2020, 03:03 PM
  5. Galaxy S9+ won't load media on some apps over Wi-Fi, but will on mobile data.
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 06-04-2020, 02:40 PM
LINK TO POST COPIED TO CLIPBOARD