1. BeadKnit's Avatar
    Greetings, all!

    I have a fairly "new" (but maybe not new? ) ongoing problem with my Android online connection.

    First, there have been intermittent problems over the past year or so with my home wifi connection not working well with my Android. Lagging screens, freezing screens, "slow connection" errors, grayed screens that normally have active buttons to tap, etc. Those issues were always resolved with a modem reboot, where everything worked great for months.

    Back about 3 weeks to a month ago, there was a brief power outage at my home. It knocked out the Fire TV connection and the only way to get it back was with a modem reboot. It had also knocked out my Android connection. Wifi wouldn't work, with all of the aforementioned problems occurring.

    A modem reboot fixed the Fire TV problem, but the Android problem stubbornly persisted. So I switched from wifi to the 4G connection.

    4G was reliable at first, but then it started to have similar problems. Lagging screens, freezing screens, "slow connection" errors, plus some apps would give an error message saying that there was "no internet connection" and it needed to "reconnect." (Too fast for a screenshot, unfortunately.)

    Our modem was found to have been incompatible with our provider, so we bought a new one. This one is certainly compatible.

    And I still have many of the same problems. Wifi is still mostly unusable.

    My computer worked okay most of the time and I can't say for sure any lagging errors on it were related to a modem/connection problem or not. My 4G connection works okay...sporadically. Wifi on my Android works a little bit of the time. I go back and forth from one to the other, trying to find something that will work.

    I'm tearing my hair out, not quite understanding what one electrical outage has to do with a perhaps month-long connection issue with my Android, and why it keeps a new, compatible modem from working and makes 4G continue to work sporadically.

    I thought maybe my mobile service provider was throttling my 4G connection, but after checking I was able to determine that I'm nowhere near the limit where they do that. (I have "unlimited" data, which I know isn't really unlimited.)

    Any ideas on what I should look at next? My phone needs to be upgraded eventually, but now isn't a good time for that. And I find it hard to believe it would suddenly decide after a power outage that it needs to be upgraded.

    Thank you in advance.
    12-17-2020 09:46 AM
  2. B. Diddy's Avatar
    You replaced your modem, but have you also tried a new router? (Or are you using a modem/router combination?)

    Also, do you use wi-fi extenders? Those are notorious for wonkiness, in my experience. A good mesh router system is preferable.
    J Dubbs likes this.
    12-19-2020 01:05 PM
  3. BeadKnit's Avatar
    B. Diddy,

    Thanks!

    The router is pretty new, though we're testing it to see if that's the problem. But it wouldn't explain why 4G is a mess.

    No wifi extenders. Thank you - good to know they're not very reliable, because with this latest issue, I was thinking of perhaps trying something. But probably not, now that you've mentioned it! I don't need more aggravation with something else not working right.
    12-19-2020 08:47 PM
  4. B. Diddy's Avatar
    See if the problem persists in Safe Mode: https://www.t-mobile.com/support/dev...sung-galaxy-s9

    Also try the Reset Network Settings option: https://www.t-mobile.com/support/dev...sung-galaxy-s9
    12-19-2020 08:50 PM

Similar Threads

  1. Can't connect to SYNC Bluetooth?
    By lhaff37 in forum Samsung Galaxy S7
    Replies: 48
    Last Post: 01-12-2021, 04:45 PM
  2. Email Issues
    By pilotbda in forum Huawei P20 & P20 Pro
    Replies: 2
    Last Post: 12-19-2020, 04:19 PM
  3. samsung tablet E doesn't connect with home broadband
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-19-2020, 02:06 PM
  4. Swipe Left Issue
    By ezdoit in forum Google Pixel 5
    Replies: 2
    Last Post: 12-15-2020, 10:37 PM
  5. Have you actually connected a galaxy s10 to ethernet?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-15-2020, 07:15 PM
LINK TO POST COPIED TO CLIPBOARD