1. Javier Girado's Avatar
    Hi,

    I got my shiny S9+ two days ago from T-Mobile and very happy with it although I have an issue with Android Auto.

    My previous phone, Galaxy S7, never had a problem connecting to my car using Android Auto. It worked from the beginning and no issues whatsoever.

    Now my S9+ refuses to connect with my car. Even manually launching Android Auto, the application still cannot register or recognize the car. The car also shows an error upon connecting the phone through USB (with or without Android Auto launched on the phone).

    Just in case I tried three different USB C cables, uninstall/install Android Auto, clean cache & memory, reboot the phone, change the phone USB settings (MTA, File Transfer, etc), nothing seems to work. Somebody suggested me to use USB developer mode but I doubt it'll fix this issue.

    I googled a little bit and found that Oreo 8.0 has issues with Android Auto that was fixed in 8.1. My phone currently has 8.0 so I wonder if somebody knows when Samsung will update their phones to Oreo 8.1.

    I posted the same question on T-Mobile support and they told me that it'll depend on Samgung, not them.


    Thanks,
    03-19-2018 08:31 PM
  2. GibMcFragger's Avatar
    I have no issues with Android Auto over USB. I never did with my previous Note 8 either, and it was running a leak of 8.0
    03-19-2018 09:50 PM
  3. anon(1733)'s Avatar
    I have not had any issues either with Android Auto and I use it via USB every day.
    03-19-2018 10:49 PM
  4. gazuga6176's Avatar
    have you tried removing the old phone profile from your headunit?
    03-20-2018 12:27 AM
  5. accapro's Avatar
    Mine is working perfectly. Maybe remove your old phone from the vehicle sync list?
    03-20-2018 12:38 AM
  6. Jaycemiskel's Avatar
    Mine works perfectly with Android Auto. Sometimes Samsung never updates to the X.1 release so you could be waiting until 9.0 comes out and that's likely going to be a year from now.
    03-20-2018 01:01 AM
  7. cactuspete23's Avatar
    Seems like this may not be an Android 8.0 Problem ?
    03-20-2018 07:46 AM
  8. Richard Felix's Avatar
    I'm not having any issues with my Android auto but I've learned over the years any major problems do a factory reset and that seems to fix everything. And do not use Smart Switch or any of those to bring old apps to new phone. make sure you wipe cache partition
    03-22-2018 07:51 PM
  9. Oscar Maradiaga's Avatar
    We wont see 8.1 the galaxy s8 just got oreo update
    03-22-2018 08:41 PM
  10. claykin's Avatar
    Unlikely Samsung will bring Oreo 8.1 to S9 devices. 8.1 was released early December. If they planned on 8.1, the S9 would have shipped with it. That said, the majority of the changes in 8.1 are for Pixel 2 devices.
    03-22-2018 08:48 PM
  11. Javier Girado's Avatar
    Thanks for the tips..I'll reset my car's multimedia system (I did remove my S7 profile but who knows) and see if this fixes the problem. if not I guess I'll have to wait until Samsung update Oreo (which it'll take a while).
    03-22-2018 09:12 PM
  12. claykin's Avatar
    Thanks for the tips..I'll reset my car's multimedia system (I did remove my S7 profile but who knows) and see if this fixes the problem. if not I guess I'll have to wait until Samsung update Oreo (which it'll take a while).
    Your car might need a software update. Ask dealer. Check forums.
    03-22-2018 10:34 PM
  13. pseudotrash's Avatar
    open android auto app. go into settings, connected cars and the menu dots on upper right and select "forget all cars". Make sure "add new cars to android auto" is turned on. this resolved your exact situation for my wife and I in 2 cars.
    03-23-2018 12:00 AM
  14. neil74's Avatar
    I think the speed at which we see 8.1 will be a proper test of project treble. In theory it should come quite quickly.
    03-23-2018 03:24 AM
  15. ghaleon92's Avatar
    hi,
    i was having issues with my s9+ and android auto as well when i first got the phone it would launch but it wouldn't let me control my pandora app. in fact pandora wouldn't even show as a music player option. but i had got an OTA update and since then its been working fine and im still on O8.0 so you may need to see if theres any updates you have not got yet. good luck getting it resolved.
    03-23-2018 01:14 PM
  16. Jaycemiskel's Avatar
    I think the speed at which we see 8.1 will be a proper test of project treble. In theory it should come quite quickly.
    A lot of times Samsung skips the X.1 updates though. It may not be an update they ever plan to release. So project treble won't really have anything to do with it.
    03-23-2018 08:25 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-21-2018, 04:11 PM
  2. Why won't my Samsung keyboard ever come up?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-21-2018, 03:59 PM
  3. Can't convert .Avi to play on Moto e4
    By esjayy in forum Moto E4 & E4 Plus
    Replies: 1
    Last Post: 03-16-2018, 05:07 PM
  4. Galaxy Tab A with S Pen, no sound from bluetooth
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-16-2018, 01:17 PM
  5. Unicorn adblocker for Samsung internet
    By 30k in forum Ask a Question
    Replies: 1
    Last Post: 03-15-2018, 05:56 PM
LINK TO POST COPIED TO CLIPBOARD