1. Wooohah's Avatar
    Anyone have issues with a poor signal on an unlocked Galaxy S9 Plus (Dual Sim)?
    I upgraded to this phone from an iphone 5c and I noticed I generally have very low bars. I checked my dBm and It seems to be worse than the iphone. My speeds are also pretty slow.
    I was getting single digits when I was doing a speedtest at one point.

    I went to my carrier (T-mobile) and had them check the phone up. They verified the APN settings and said all the settings were good to go. When I was in the store, I was getting full bars, walk out of the store, take a left and literally 50 feet away my bars drop to 2.

    I also never seem to get the LTE symbol in my taskbar. The phone shows as being connected to LTE, however it just shows as 4G. Though I've heard this is a feature specific to the "international" version.

    Anyone have experience on how to fix this? I like the phone, but I can't deal with a poor signal.
    The T-mobile employee said that he's seen signal issues with a lot of the S9's and he says it seems to be just the unlocked versions. However he didn't have much in terms of how to fix it.

    Everything is up to date.
    11-25-2018 05:30 AM
  2. Adam Frix's Avatar
    so it's not just an unlocked S9; it's an international version S9. That's a huge distinction to note.

    It would be interesting to see how a US unlocked S9 behaves in that same spot, as well as how a T-Mobile S9 behaves. My guess is that the international version is your problem.
    11-25-2018 07:24 AM
  3. mary beth hale's Avatar
    It is normal for the international version to show 4G instead of lte. I think the international version has different bands than the US unlocked.
    11-25-2018 07:59 AM
  4. InitialKev's Avatar
    I have the same problem but with AT&T and an US unlocked S9. I use the app Network Signal Info and my dBm is anywhere between -99 and -115. Under the cell location tab it doesn't even show that it's connecting to any towers near by.

    I also don't have the option to change the network mode like I do with my S5 Mini.

    AT&T was unable to solve the issue but I am 99% sure it's a sim card problem.
    11-25-2018 08:06 AM
  5. InitialKev's Avatar
    I finally got my phone to work as it should. I had to use a non default Access Point Name (APN).
    11-29-2018 08:02 AM
  6. bhatech's Avatar
    As others as have noted the problem is you are using the international unlocked not the official US unlocked version. I'm using the official US unlocked version on T-Mobile and all TMobile specific features work and signal is great as well. Unless you wanted the dual SIM not sure why you went with that version instead of US unlocked version. Sure you may find the international unlocked version little cheaper but personally I would always suggest go with the US unlocked model with official warranty if you are in US.
    11-29-2018 10:15 AM

Similar Threads

  1. Samsung Pay
    By dmelvin in forum Samsung Galaxy S9 & S9+
    Replies: 4
    Last Post: 11-30-2018, 07:17 PM
  2. Cant find accuracy mode on my itel prime 4
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-27-2018, 11:48 AM
  3. I did first system update on my galaxy s8 and now it wont boot.
    By Android Central Question in forum Samsung Galaxy S8 & S8+
    Replies: 3
    Last Post: 11-26-2018, 01:14 PM
  4. Is there a way to move my flashlight widget icon to my home screen on pixel 3?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-26-2018, 01:58 AM
  5. Why does my Galaxy s7 jump and stutter when I scroll on a web page
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-24-2018, 10:53 PM
LINK TO POST COPIED TO CLIPBOARD