1. jaymzb0nd's Avatar
    After the update, I can no longer receive Gmail notifications. I've checked the settings and everything is set up the same as before. I even tried to turn off the notifications and turn it back on but no luck. Restarted the phone a number of times but again no luck. Any ideas?
    02-19-2019 08:41 PM
  2. pontiac005's Avatar
    maybe uninstall Gmail and reinstall?
    02-20-2019 11:55 AM
  3. daswooski's Avatar
    maybe uninstall Gmail and reinstall?
    I just tried to send myself an email and I did get the Notification as far as the Badge on the App Icon...it showed 1 unread email.
    Is that the Notification you are referring to?
    02-20-2019 01:04 PM
  4. Gabriel619's Avatar
    After the update, I can no longer receive Gmail notifications. I've checked the settings and everything is set up the same as before. I even tried to turn off the notifications and turn it back on but no luck. Restarted the phone a number of times but again no luck. Any ideas?
    I'm experiencing the same thing. It's a syncing issue. Gmail doesn't want to sync while running in the background, therefore there are no notifications of new mail. I have to actually go into the app and refresh it in order to get my new mail. I'm experiencing the same issue with my Yahoo email app as well.

    I tried reinstalling and went as far as wiping my phone. No luck.
    02-23-2019 11:57 AM
  5. recDNA's Avatar
    I'm experiencing the same thing. It's a syncing issue. Gmail doesn't want to sync while running in the background, therefore there are no notifications of new mail. I have to actually go into the app and refresh it in order to get my new mail. I'm experiencing the same issue with my Yahoo email app as well.

    I tried reinstalling and went as far as wiping my phone. No luck.
    Have you tried going into battery settings and turning off the power saving option? On my phone you choose power saving exclusions under battery settings.
    CocoBunnyxx and tube517 like this.
    02-23-2019 12:39 PM
  6. daswooski's Avatar
    Have you tried going into battery settings and turning off the power saving option? On my phone you choose power saving exclusions under battery settings.
    Yes, this solves other issues as well. Life 360 won't show my location to others unless I am in Performa Mode. Any battery saving setting more stops several apps from running in the background
    CocoBunnyxx likes this.
    02-23-2019 01:17 PM
  7. Gabriel619's Avatar
    Have you tried going into battery settings and turning off the power saving option? On my phone you choose power saving exclusions under battery settings.
    Yes, I checked battery settings as well. I even tried adding my Yahoo account to the Gmail app so I can get timed syncing, but still no luck.

    Any other suggestions would be most welcome.
    recDNA likes this.
    02-23-2019 04:54 PM
  8. recDNA's Avatar
    Yes, I checked battery settings as well. I even tried adding my Yahoo account to the Gmail app so I can get timed syncing, but still no luck.

    Any other suggestions would be most welcome.
    Have you tried wiping data in gmail and google then signing back in?
    02-23-2019 05:49 PM
  9. Gabriel619's Avatar
    Have you tried wiping data in gmail and google then signing back in?
    Yes, I've tried wiping the app and wiping the phone. No luck.
    02-23-2019 06:28 PM
  10. jayven's Avatar
    I found a solution! When my S9+ on T-Mobile was upgraded to Pie, Gmail notifications worked perfectly. Then two or three days ago, my Gmail app was updated with the new Gmail look [yuck], and suddenly Gmail notifications stopped working. Here's how I just solved the problem: Open Gmail. Tap the hamburger menu and go way down the list to Settings. Rather than choosing "General settings", choose your Gmail address's settings. In the Notifications section, tap "Inbox notifications". On my phone, "Label notifications" was deselected, and "Notify for every message" was grayed out. I selected "Label notifications", and now the notifications are working once again.
    recDNA and Jayymes like this.
    02-25-2019 09:37 PM
  11. recDNA's Avatar
    This is Yuge! This answer should be stickied!
    02-27-2019 09:40 PM
  12. Jayymes's Avatar
    @jayven Finally a fix! My notifications hadn't been working for gmail (Galaxy S9 on T-mobile) and every setting change/reset/reinstall I tried didn't work until I unchecked "Label notifications" and then checked it again.
    03-23-2019 09:05 PM
  13. CocoBunnyxx's Avatar
    Have you tried going into battery settings and turning off the power saving option? On my phone you choose power saving exclusions under battery settings.
    OMG THIS WORKED (Galaxy s10+) Thank you!!
    1. In settings search "Optimize battery usage"
    2. At the top, change the view to All apps
    3. UNCHECK Gmail (when blue goes away)

    And your notifications will come in! I sent myself an email and got the notification.
    recDNA, pontiac005 and Shar0426 like this.
    03-30-2019 05:19 PM
  14. recDNA's Avatar
    OMG THIS WORKED (Galaxy s10+) Thank you!!
    1. In settings search "Optimize battery usage"
    2. At the top, change the view to All apps
    3. UNCHECK Gmail (when blue goes away)

    And your notifications will come in! I sent myself an email and got the notification.
    I'm so happy it worked for you! So many people have helped me here and I seldom get the chance to help someone else.
    Shar0426 likes this.
    03-30-2019 05:27 PM
  15. Shar0426's Avatar
    YES!!!! The 'Optimized Battery Usage' find worked on my Galaxy Note 9. Thanks for this great find!!!!
    04-17-2019 11:27 AM
  16. dolfan1284's Avatar
    Here's what solved it for me. For my S10E, I had to go into Settings->Account and backup->Accounts->"My email" (which says Google below it and has the familiar red, yellow, green, blue Google logo)->Sync Account and in there I had to click every single service to be on for the notifications to come through. Oddly, the same goes for my Yahoo Mail, once, the Mail and the Contacts were working, all of it seemed to come through!
    04-24-2019 03:09 PM
  17. Nicola Mangani's Avatar
    It worked !! In my case the inbox sync was ticked but the all mail sync box wasn't. Set it to sync all mail et voila! THANK YOU


    I found a solution! When my S9+ on T-Mobile was upgraded to Pie, Gmail notifications worked perfectly. Then two or three days ago, my Gmail app was updated with the new Gmail look [yuck], and suddenly Gmail notifications stopped working. Here's how I just solved the problem: Open Gmail. Tap the hamburger menu and go way down the list to Settings. Rather than choosing "General settings", choose your Gmail address's settings. In the Notifications section, tap "Inbox notifications". On my phone, "Label notifications" was deselected, and "Notify for every message" was grayed out. I selected "Label notifications", and now the notifications are working once again.
    07-01-2019 05:52 AM

Similar Threads

  1. Now Playing History option has disappeared
    By Krak-a-Lakn in forum Google Pixel 3 & Pixel 3 XL
    Replies: 10
    Last Post: 03-04-2019, 09:45 AM
  2. I have forced stop wear os app in watch, now i am not able to see options.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-23-2019, 05:41 PM
  3. Hidden storage files nowhere to be found
    By Jesus Delgadillo in forum Samsung Galaxy S9 & S9+
    Replies: 4
    Last Post: 02-20-2019, 06:11 AM
  4. Latest Android update keeps Nokia phones from accessing GPS location
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-19-2019, 08:13 PM
  5. Why Note 9 Freezing after latest updates
    By Android Central Question in forum Samsung Galaxy Note 9
    Replies: 2
    Last Post: 02-19-2019, 05:48 PM
LINK TO POST COPIED TO CLIPBOARD