1. JPRobertson6's Avatar
    I updated to Pie a couple of days ago and ever since then, I keep getting a notification saying "Wi-Fi calling preferences updated to optimize network experience." I keep getting that notification every few minutes with Wi-Fi calling on. When I go to try and turn the notifications off the option is grayed out. When I try to disable from the notification it says "these notifications can't be turned off." I don't have cellular service where I work, so Wi-Fi calling is a must. I know it says they can't be turned off, but I didn't know if anyone found a work around.

    Thanks in advance!
    sleepy_dad likes this.
    02-22-2019 11:59 AM
  2. Rukbat's Avatar
    Not with the stock ROM. Check on XDA, to see if anyone has a custom ROM that allows it (or even an app that does it)
    02-22-2019 02:43 PM
  3. Gayle Lynn's Avatar
    Delete cache and data for apps incl. system apps.
    Reset network prefs.
    Not normal.

    Developer mode has agressive mobile when WiFi is weak. Wonder if it's polling and scanning and switching over.
    I'd also reboot the router. That may help. How good is wifi signal and clear channel?
    02-22-2019 03:52 PM
  4. manfred33's Avatar
    I have the same problem- I need to have Wifi Calling on because of the lack of cellular signal at my house, but damn if that notification isn't crazy annoying! I could not find anything either on how to disable it, the only thing that I did figure out was how to "mute" it in a sense. When the notification pops up, I long press on it, which usually gives you a few options for notifications, one of which is to turn the notification off. In this case, you are not allowed and it tells you, as you already surmised. However, a "Details" link pops up and if you tap on that, it takes you to Wi-Fi Calling settings, which is no longer in the Communications section of settings... Anyways, only two settings that are listed, top one being "App Icon Badges" and the lower one is "Wi-Fi Calling" which is enabled and does not allow you to disable, but if you tap on that you can adjust the notifications for Wi-Fi Calling and I played with the first setting which is Notification Style. When you tap on it it expands a menu which has "Sound and pop-up, Sound, Silent and Silent and Minimized". I chose "Silent and Minimized" and have not seen a notification since, unless I go back in and change it back, which I just did now to write this how-to. Hope this helps...
    I have always been eager when it comes to updates to the Android OS, but this one for PIE has left me quite unhappy with all of the changes, especially when they design annoying notifications that they don't even allow you to disable... Anyways, I was glad to find a work-around and hopefully it meets your needs!

    Manfred
    02-23-2019 05:28 PM
  5. Schlubbe's Avatar
    Open phone app, click on the three dots in upper right corner, settings, and there's a toggle for wifi calling.

    Found this thread while looking for the answer, then found answer elsewhere. Thought I should come back here and share.

    Cheers
    03-02-2019 01:24 PM

Similar Threads

  1. Replies: 10
    Last Post: 12-09-2020, 12:44 AM
  2. What is the character limit in Hangout messages (not SMS)
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-22-2019, 04:48 PM
  3. timer lock how to unhide
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-22-2019, 02:45 PM
  4. Android auto do not disturb turning on automatically.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-22-2019, 11:07 AM
  5. Samsung Galaxy S6 w/Android 7.0
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-2019, 10:59 AM
LINK TO POST COPIED TO CLIPBOARD