02-11-2020 10:53 AM
31 12
tools
  1. MattTheMatt's Avatar
    Here's what's happening:

    -GPS is now almost always 20m+ away from my real location.
    -GPS position keeps stopping and then jumping forward and stopping again.
    -Turning off WiFi scanning causes Google maps to ask for location services to be enabled (even though it's already enabled), which re-enables wifi scanning, which is not what I want because it has caused inaccuracy in the past

    What I've tried:
    -Clear data/cache/force stop of: Location Services, Google Play Services, Google maps
    -Uninstalling Google play services updates and manually reinstalling

    It seems I'm not the only one. What else can I try before factory reset? I should also note my phone software is not and has never been modified, it is running stock.
    02-09-2020 01:11 PM
  2. mustang7757's Avatar
    You can try in settings>general management>reset>reset network

    'll leave a Link to register so you can communicate here as a guest account you can only post questions but can't reply.
    https://forums.androidcentral.com/sh...d.php?t=409154
    02-09-2020 01:15 PM
  3. MattTheMatt's Avatar
    OP here, thanks for the registration link. I should further mention that when I turn off WiFi scanning, keeping location turned on mind you, and then go to use google maps, it asks me to turn on location services, even though I did not turn location services off but only turned off WiFi scanning. Tapping to "turn location services on" then just re-enables wifi scanning.
    02-09-2020 02:20 PM
  4. mustang7757's Avatar
    OP here, thanks for the registration link. I should further mention that when I turn off WiFi scanning, keeping location turned on mind you, and then go to use google maps, it asks me to turn on location services, even though I did not turn location services off but only turned off WiFi scanning. Tapping to "turn location services on" then just re-enables wifi scanning.
    Hi,welcome!
    Have you tried what I suggested earlier?
    02-09-2020 02:31 PM
  5. MattTheMatt's Avatar
    Also I tried both resetting network settings and resetting settings. Unfortunately neither worked.
    02-09-2020 02:31 PM
  6. mustang7757's Avatar
    02-09-2020 02:33 PM
  7. B. Diddy's Avatar
    Welcome to Android Central! I'd try wiping the system cache partition.
    pizza_pablo likes this.
    02-09-2020 02:33 PM
  8. mustang7757's Avatar
    Also I tried both resetting network settings and resetting settings. Unfortunately neither worked.
    This happened after update to android 10?
    02-09-2020 02:34 PM
  9. MattTheMatt's Avatar
    Yes, after the update. Also, my back button also seems to not be working properly. It does not take me back to the last webpage, nor the last page/screen in whatever app I'm using. Also, how do I reply/quote on here? I see no options to.
    02-09-2020 02:37 PM
  10. MattTheMatt's Avatar
    Nvm about the back button, they got switched around.
    pizza_pablo likes this.
    02-09-2020 02:39 PM
  11. mustang7757's Avatar
    Yes, after the update. Also, my back button also seems to not be working properly. It does not take me back to the last webpage, nor the last page/screen in whatever app I'm using. Also, how do I reply/quote on here? I see no options to.
    You on chrome ?
    02-09-2020 02:39 PM
  12. mustang7757's Avatar
    Nvm about the back button, they got switched around.
    Was going say lol new gestures
    02-09-2020 02:39 PM
  13. mustang7757's Avatar
    Yes, after the update. Also, my back button also seems to not be working properly. It does not take me back to the last webpage, nor the last page/screen in whatever app I'm using. Also, how do I reply/quote on here? I see no options to.
    Screenshot:One UI 2.0 broke my gps-20200209_144500.jpeg
    Laura Knotek likes this.
    02-09-2020 02:45 PM
  14. MattTheMatt's Avatar
    Odd, it's not showing any of those buttons for me. Neither on mobile nor on mobile desktop.
    02-09-2020 03:04 PM
  15. mustang7757's Avatar
    Odd, it's not showing any of those buttons for me. Neither on mobile nor on mobile desktop.
    Try refreshing
    02-09-2020 03:05 PM
  16. MattTheMatt's Avatar
    I tried that many times, still nothing.
    02-09-2020 03:08 PM
  17. mustang7757's Avatar
    Maybe sign out then back in ?
    02-09-2020 03:10 PM
  18. MattTheMatt's Avatar
    Here's a screenshot of what I'm seeing. I don't see any buttons to submit an image, so I uploaded to imgur: http://imgur.com/a/5tpGCIE
    02-09-2020 03:10 PM
  19. mustang7757's Avatar
    I'll post your picture here :
    That's strange

    One UI 2.0 broke my gps-screenshot_20200209-151120.jpeg
    02-09-2020 03:11 PM
  20. MattTheMatt's Avatar
    Maybe sign out then back in ?
    Yep that did it, lol.

    Also I just wiped my system cache partition, and will go and try my GPS accuracy again.
    mustang7757 and Laura Knotek like this.
    02-09-2020 03:11 PM
  21. mustang7757's Avatar
    Perfect
    Yep that did it, lol.
    02-09-2020 03:12 PM
  22. mustang7757's Avatar
    So try b. Diddy suggestion clear cache in recovery if that doesn't help might have to do factory reset , most times no recommend after a update but few scenarios it might have to .
    02-09-2020 03:16 PM
  23. MattTheMatt's Avatar
    I've tested my GPS after a system cache partition wipe and sadly that was not the solution.
    02-09-2020 03:31 PM
  24. mustang7757's Avatar
    I've tested my GPS after a system cache partition and sadly that was not the solution.
    Which Samsung device you have I can put in correct forum maybe someone else had the issue.
    02-09-2020 03:32 PM
  25. MattTheMatt's Avatar
    Which Samsung device you have I can put in correct forum maybe someone else had the issue.
    Samsung Galaxy S9+. Thank you for being so eager to help!
    mustang7757 likes this.
    02-09-2020 03:36 PM
31 12

Similar Threads

  1. Replies: 2
    Last Post: 02-09-2020, 05:01 PM
  2. Leaving home without my note 9
    By Android Central Question in forum Ask a Question
    Replies: 6
    Last Post: 02-09-2020, 04:47 PM
  3. GPS signal lost
    By Cvmars24 in forum Samsung Galaxy S9 & S9+
    Replies: 3
    Last Post: 02-09-2020, 03:41 PM
  4. Why can't i see my imo friends numbers?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-09-2020, 12:45 PM
  5. Why my headphone on my stylo 5 will not go off?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 02-09-2020, 12:44 PM
LINK TO POST COPIED TO CLIPBOARD