04-02-2018 07:42 AM
56 123
  1. Dhendy91's Avatar
    Please read this guide in full before trying to flash anything. Also if you are unsure about anything please ask as it is much easier for me to answer questions then help people get out of a mess.


    Hey Guys
    Now we have our own sub forum I thought it was time to introduce people to Odin. Odin is a tool for flashing stock firmware’s released by Samsung. Odin is usually the best way to keep your phone up to date with the most recent firmware releases from Samsung and can also be used for removing carrier bloat and restoring your phone if you run into any issues while hacking,rooting or tinkering.As useful as Odin is though it should be respected as it has access to parts of your device that if you mess with could render it useless.

    You follow this guide and use the software at your own risk I will no be held responsible for anything that happens to you or your device if you choose to follow it or use the software. Everything you do you choose to do yourself and is nothing to do with me!

    That being said I will try my best to help you if anything goes wrong

    Warning: Using ODIN can change your bootloader to show that the system is MODIFIED and may increase your ODIN flash count. This may void your Warrenty.

    First lets take a look at the different sections in Odin where we can insert files and what these sections represent:
    PIT This is for .Pit files you will only need to use this if a firmware update needs to change your partition layout (very very unlikely) or if you mess up you partition table (you don’t want to do this) . You will probably never have to use this so just leave it alone unless you I say you need to do it or you know what you are doing.
    Bootloader This is for a new bootloader, however I have never heard of this being used or ever had to use it myself so again leave this section alone
    PDA This is the file where the software is actually contained and its name refers to the version of the software.
    PHONE This is for the file that contains the modem.
    CSC This stands for consumer software customization this file relates to specific carrier and geographical software, such as APN settings for data connection. This has nothing to do with the languages the firmware or keyboard support.

    1.Make sure you have the GT-I9300 drivers installed. You can get them from the Samsung website or by installing Kies.

    2.Make sure kies isn't running. Kies and Odin don't get on!!

    3. Download Odin (below) and extract it.Then double click on the Odin.exe file to run it (It will have to run as admin)

    4. Choose the firmware you want from here [http://forums.androidcentral.com/sam...l#post2133357] and extract it to get the .tar or tar.md5 file or files then save it somewhere you will remember.
    Flashing Firmware with Odin

    1. Put your phone into download mode. To do this turn the phone off and then press volume down+home button+power button at the same time. You will then get a warning saying press up to continue and down to cancel, press volume up and you are now in download mode

    2. Start Odin

    3.At this point please make sure that ONLY TWO OPTIONS TICKED are "Auto Reboot" and "F.Reset Time" (otherwise you could end up with a very expensive paperweight)

    4. If there was only one tar file when you extracted the firmware put it in the PDA section.This just means this file contains the PDA+PHONE+CSC all in one firmware

    If there are three files they should have one of PDA/PHONE/CSC in their names look for this and put them in the corresponding section.

    5. Plug your GT-I9300 into the computer, wait for the drivers to install and then wait for the ID:COM section to turn blue.


    7.Press start and the flash will begin, once this has started do not remove the usb cable or turn of your computer or the device the phone will reboot once the flash has finished. [I]Ocsasionally Odin may hang on setting up connection, if this happens it is ok to detach and re-attach the USB cable and Odin should continue[/I]

    How to Remove Carrier Bloat Using Odin
    Coming soon
    How to Root Using Odin
    Coming Soon
    Complete Stock Firmware Thread for GT-I9300
    Coming Soon
    So that's it for now guys, and please if you are unsure of anything don't hesitate to ask!

    Much Android Loving
    09-03-2012 01:56 PM
  2. Dhendy91's Avatar
    Reserved just in case....
    09-03-2012 06:33 PM
  3. mpshah's Avatar
    This has to be a sticky

    Sent from my GT-I9300 using Tapatalk 2
    Dhendy91 and funkylogik like this.
    09-04-2012 08:08 AM
  4. Dhendy91's Avatar
    This has to be a sticky
    Sent from my GT-I9300 using Tapatalk 2
    Haha thanks it did take me a while so nice to hear you think it's going to be useful, I have just added the links to the firmware page which I will populating with firmware as people request it so if there is anything you want just ask
    funkylogik and Nada Hagab like this.
    09-04-2012 02:09 PM
  5. sdulwich's Avatar
    Great guide.

    Any update when the guide to "How to root using odin" will be available?
    10-03-2012 08:32 AM
  6. funkylogik's Avatar
    This has to be a sticky

    Sent from my GT-I9300 using Tapatalk 2

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    10-04-2012 08:13 AM
  7. Dhendy91's Avatar
    Hi Sorry Guys
    I have recently been away with the army so haven't had time to keep up with this. I got back at the weekend and today got the nice message that this has become a sticky so I will begin writing guides again. Once again apologies. Both threads will be updated soon.
    10-23-2012 03:17 PM
  8. funkylogik's Avatar
    congrats and well done mate.

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    Tom Lukwiya Lakony likes this.
    10-29-2012 12:19 AM
  9. Tom Lukwiya Lakony's Avatar
    Hey... Thanks a bunch.

    i have a samsung galaxy s3 which doesnt get past the first black and white screen which shows Samsung GALAXY SIII, GT-I9300.

    it can go in download mode.
    ....and shows the following:
    CURRENT BINARY: Samsung Official
    SYSTEM STATUS: Custom.

    Do not turn off target !!

    further still, it cannot go in recovery.

    How can odin help me?

    please help.


    Tom LL
    12-17-2012 07:40 AM
  10. Erin Jacob's Avatar
    Hi Dhendy,

    I seem to be suffering the same issue as Tom above this post. I have a separate thread open but would really appreciate any help you can provide. Here is a link to the thread that I opened

    12-18-2012 02:53 PM
  11. teksil's Avatar
    Hi - Has the link to Odin been removed as I can not see it.

    Kind regards

    04-29-2013 05:14 AM
  12. TayyabKhalid's Avatar
    thnx, for the guide mate!

    Sent from my GT-I9300 using Tapatalk 4 Beta
    05-10-2013 06:42 PM
  13. Eden Dadi's Avatar
    I have just updated my phone's firmware to the unofficial release of 4.2.2 JellyBean, using Odin.
    Will I be able, later on, to upgrade to the official 4.2.2 firmware when Samsung releases it, using Odin?
    05-27-2013 08:00 PM
  14. Wanderlust101's Avatar
    Well my phone passed and after I turn it on I see Hot Mobile logo and the Jewish letters appear and then the Samsung screen shows up like a troll, so if you could let me know what are my options regarding this it would be very much appreciated as I really like this phone and want to keep on using it. Thanking you in anticipation !
    06-24-2013 07:55 PM
  15. justin sinaswee's Avatar
    hi there i've got a samsung galaxy s3 i9300 and one day the battery died and after leaving it to charge and then trying to power it , it was stock on the samsung s3 screen after watching and reading several methods i've come to using the odin i downloaded a firmware named jelly bean 4.1.1 and the phone did the same thing after i followed all the instructions then i tryed the new release jellybean 4.2 and i got it to pass that screen showing a red and white screen thing but then its stock on the samsung screen where it just marked samsung and blinking with a blue on the led, after doing some more research i came to the stock firmware which is what it came with and this one now its passes the samsung galaxy s3 screen and the animation with the blue circle thing comes up like there original just bought s3 but then the samsung sign comes up stays like ten seconds then the blue circle start up animation does its thing again and it goes back to samsung and it does that and don't pass there please help me please also too i'm getting an failed to mount efs with an android man with a caution sign
    Budi Utomo3 likes this.
    07-16-2013 10:18 AM
  16. Jennie Ryan's Avatar
    thanks for this. I successfully used it on two S3's
    11-23-2013 10:59 AM
  17. simpmg's Avatar
    Hey, I just saw this thread. I posted this yesterday, after my phone failed when I tried upgrading the firmware using Kies.

    From what I've read, I'll probably have to flash the firmware. Trouble is, all the links to k0ane's or Sammobile have dead links to the firmware downloads. I'm wondering where I can download this stuff now.

    12-08-2013 12:32 PM
  18. GSDer's Avatar
    http://www.sammobile.com/firmwares/ the links seem to be live

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    12-09-2013 05:56 PM
  19. Kai Klauber's Avatar
    does this work with the Verizon GS4? and where should i look to download 4.3 or 4.4 for the US? sorry, I am completely new to all of this.
    12-18-2013 12:07 AM
  20. GSDer's Avatar
    does this work with the Verizon GS4? and where should i look to download 4.3 or 4.4 for the US?

    Welcome to the forums!

    Please note that if you have a question about a specific carrier's phone (in this case Verizon) you should really be posting in that sub-forum.

    You should also try to post in the forum for your model - this is a Galaxy S3 forum.

    Finally, saying 'this' doesn't tell any of us what you're referring to - it could be the previous post or some earlier post, or even a specific part of some post. Whenever possible, quote the specific item you're referencing, and if at all possible edit out all the irrelevant stuff rather than just quoting some essay.

    To try to answer your question - 4.4 is not available on any Verizon Samsung phone, unless you want to root your phone and put a custom ROM on it. I thought the S4s had already received the 4.3 update, but I don't pay attention to the S4 progress since I don't have one. If 4.3 isn't on your phone but is available through Verizon you should be able to perform a software update or use the Kies software on your PC to update it.

    Edit: try this http://forums.androidcentral.com/sho...d.php?t=327957
    Verizon Samsung Galaxy S4 - Official Android 4.3 is here!!!!

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    12-18-2013 12:47 PM
  21. Navanithan Muniandy's Avatar
    Hi there

    i already do the same step ..but my phone keep showing the " samsung galaxy " logo
    01-06-2014 06:04 AM
  22. Shortyzsly's Avatar
    Hi guys my name is dave. I have a strange issue with my Samsung galaxy GT-I9300. It boots up by itself if the battery has a charge. And it doesn't show the Samsung logo at all. The screen is a mix off black, white and green static covering the full screen. It doesn't disappear until I turn it off again. I can't access recovery mode because I cannot see what happens when I use the vol +, home and power button combo. However the vol -, home and power button combo brings me straight into download mode... Without any static, the downloading mode displays properly and Odin detects it but it always fails saying no pit partition.

    My head is melted since yesterday I have exhausted all options. Assistance would be great.

    Posted via Android Central App
    02-12-2014 10:57 AM
  23. GSDer's Avatar
    Odin detects it but it always fails saying no pit partition.
    I only know enough to be dangerous, but you can probably find a .pit file for your phone over on XDA.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    02-13-2014 09:56 PM
  24. Shortyzsly's Avatar
    I've tried flashing a pit file on both windows and Linux. Same thing happens fails saying no pit partition. Symptoms point towards a new motherboard being needed from what I've read but I wanna be sure . however it did pass on jodin inside Linux. But that could have been a bug because I didn't really see it doing anything the both times i tried It completed within a few seconds. And said pass... Is that normal for flashing pit files?

    Posted via Android Central App
    02-14-2014 06:38 PM
  25. GSDer's Avatar
    It completed within a few seconds. And said pass... Is that normal for flashing pit files?
    Pit files are pretty small so it should be quick, but I'm no expert.

    If the XDA folks don't help out you can try http://mobiletechvideos.mybigcommerc...-brick-repair/

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    02-14-2014 11:10 PM
56 123