1. Schmidlapp84's Avatar
    Ok, i'm a complete noob to Android and got my first Galaxy S3 yesterday. When I'm using the phone the clock displaying in the top right corner does not change time until I lock the phone and then unlock it. The phone still keeps time as I've tested it by setting alarms but the phone will easily show the same time from when I unlocked the phone. If its been 20 minutes since I've locked it then it'll be 20 minutes behind. Going to the home screen does not make it change and expanding the top bar settings still shows the "behind" time. Only way I can update it is to lock it and unlock it. Any tips?
    11-05-2012 07:13 PM
  2. my3chis's Avatar
    Don't know what to tell you to fix it. Mine keeps regular time and doesn't take anything special.
    11-05-2012 07:18 PM
  3. Schmidlapp84's Avatar
    restarting the phone seems to have worked for now but i shouldn't have to do this on a brand new phone. ive only had it for less than 24 hours.
    11-05-2012 07:36 PM
  4. funkylogik's Avatar
    have you tried playing with the automatic time settings Why does my clock not change time until I lock my screen?-uploadfromtaptalk1352166794069.jpg
    think id return the phone.. ive only ever had that problem with clock widgets before, not the system clock

    maybe factory reset it since u havent spent too much time customising it etc...

    global s3, UK. Ask me anything and ill reply even if its just an intelligent (or stupid) guess
    11-05-2012 08:54 PM
  5. walcolm's Avatar
    I kept my screen on after reading to be sure I don't have this problem.

    I'm on jb and the clock works fine. You might want to return it if a factory reset doesn't solve the problem

    Sent from my GT-I9300 using Android Central Forums
    11-07-2012 07:58 AM
  6. Schmidlapp84's Avatar
    Haven't had the problem since restarting my phone.

    Sent from my GT-I9305T using Android Central Forums
    funkylogik likes this.
    11-07-2012 08:14 AM

Similar Threads

  1. Why does AT&T not give us the option to turn off LTE?
    By MattMJB0188 in forum HTC One X
    Replies: 40
    Last Post: 05-26-2012, 12:18 AM
  2. Replies: 1
    Last Post: 10-04-2011, 03:24 PM
  3. Clock not keeping time on honeycomb rooted nook
    By starbuckk in forum Barnes & Noble Nook Color
    Replies: 0
    Last Post: 09-10-2011, 03:19 PM
  4. why does this one not have the red search button?
    By edoublediz in forum Verizon Droid Incredible 2
    Replies: 2
    Last Post: 04-18-2011, 09:24 AM
  5. Replies: 5
    Last Post: 06-29-2010, 08:48 PM