1. oes_gafr_eto's Avatar
    Hello wonderful and wise people!

    I updated my S3 with a firmware update on Christmas Day. Ever since then accessing my photo galleries is nigh on impossible: they seem to take forever to load (if they do at all). I tried to stop it synching with Facebook albums but it even takes forever to load when I am not connected to the internet. Is anyone else having any problems...? Does anyone have any ideas how to fix the blessed thing?

    Many thanks!

    James
    funkylogik likes this.
    12-29-2012 07:45 AM
  2. AndroidS3's Avatar
    How many photos do you have? If you dont have many then try resetting your phone, take your battery out and leave it for about a min before you put it back in. If the gallery is still slow then id suggest a back up with kies and then restore it back to factory l.

    Sent from my GT-I9300 using Android Central Forums
    12-29-2012 07:52 AM
  3. oes_gafr_eto's Avatar
    Thanks for the reply! I did as you suggested in the first place (battery out) and still not much better. I then moved all the pics from the camera gallery (which appear first) and it seemed to help a little. I can send from the gallery okay but if I'm in what's app it gets really slow (I have to go into the gallery and send from there rather than through the app)

    Muchly appreciate the suggestions
    12-29-2012 11:36 AM
  4. AndroidS3's Avatar
    Ahh right fair enought mate, its strange as ive never experienced this, anyway hope it gets better or you find a permanent fix

    Sent from my GT-I9300 using Android Central Forums
    12-29-2012 12:02 PM
  5. funkylogik's Avatar
    Try a less fancy gallery mate.
    I recomend QuickPic


    Unbranded international rooted s3 with Official 4.1.2 JB. Paisley, Scotland, Western Europe :beer:
    01-05-2013 06:02 AM
  6. Sammfieuk's Avatar
    I have the same problem after update. Also can't upload top Facebook albums anymore either and only one pic at a time v annoying. Also since update can't get my phones contacts to show on kies or back up. Everything I update something pisses up! last time I lost swipe/continuous input function which I still haven't boot back it still shows on settings but it's greyed out so you can't select it. :o

    Sent from my GT-I9300 using Android Central Forums
    01-05-2013 09:15 AM
  7. gepo87's Avatar
    Anche io ho problemi con la galleria del mio S3, non mi piace come sono organizzate le cartelle! E voi?


    Sent from my GT-I9300 using Android Central Forums
    01-05-2013 01:55 PM
  8. oes_gafr_eto's Avatar
    It seems that it may have been something to do with the sync with my facebook photos. I disconnected the album sync function between phone and fb and now the galleries load up fine.
    03-23-2013 08:18 AM

Similar Threads

  1. Problems with Gallery in CM7 Alpha 3
    By BenDQ in forum HP Touchpad
    Replies: 1
    Last Post: 12-15-2011, 06:08 AM
  2. Problems with Gallery crashing
    By lynter in forum Verizon HTC Thunderbolt
    Replies: 3
    Last Post: 05-01-2011, 07:11 PM
  3. Problems With Gallery!
    By The Pre Meister in forum General Help and How To
    Replies: 2
    Last Post: 03-22-2011, 10:26 AM
  4. Problem with gallery
    By mhans311 in forum Motorola Droid X
    Replies: 4
    Last Post: 02-15-2011, 12:39 PM
  5. Having Problems With Gallery
    By Genetic_Bloom in forum Motorola Droid
    Replies: 26
    Last Post: 05-24-2010, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD