1. 2shortplanks's Avatar
    Hi,
    Any one know how to stop the screen turning off during a call? When the call is over, the screen is completely blank, no way to find the hang up key on the keypad. I have been into call settings and removed the tick from "Turn off screen during calls" but it doesn't seem to have made any difference.
    Any help greatly appreciated.

    2shortplanks
    05-01-2013 11:14 AM
  2. meyerweb#CB's Avatar
    In the Phone app, tap Menu, settings, and uncheck "Auto screen off during calls." But the screen is supposed to turn back on when the call is over.

    Is this happening on speakerphone calls? If so, it's the normal screen timeout setting that's causing it to go black. Just press the power key to turn it back on.
    05-01-2013 12:33 PM
  3. 2shortplanks's Avatar
    Done that bit, it's a UK model, so I presume "auto screen off during calls" is the same as "Turn off screen during calls" This is happening during normal calls, not speakerphone. The screen timeout is set at 2 mins, but even if a call lasts only 30secs, as soon as the phone is away from your ear the screen is completely blank. I have to press the power button to bring the screen back to life then disconnect the call, usually the the other caller has hung up by the time I get to do this.
    05-01-2013 12:57 PM
  4. schtroumpf's Avatar
    I have the same problem. I like the screen turning off during call but I would like it to turn back on when it is not in my ear.
    My s4 is US tmobile.
    Any solution to this bug?
    Thanks
    07-05-2013 12:00 PM
  5. pinkyb01's Avatar
    Is there any way to keep the screen on while on a call? My settings are all on the correct settings. This is very frustrating. Can anyone please help?
    07-18-2013 12:13 AM
  6. Nino Sidari's Avatar
    I have the same problem. Mine WAS working fine (screen off when it's at your ear; turns back on when you move it away), but now is not. Once you put the phone to your ear, it stays off.

    The problem occurred either after the latest Verizon update, or possibly after installing "Battery Doctor".

    Any ideas?
    07-19-2013 10:27 AM
  7. Philip Coulthurst's Avatar
    Same here (Galaxy Note 2)

    If I stop the Battery Doctor App there is no problem. If I start up Battery Doctor then the screen goes blank as soon as I call someone.

    Just tested it with Battery Doctor on and off a few times and this is always the case. In my case Battery Doctor seems to be the culprit. I can't find any setting in battery doctor to stop this, but I confess I've not spent much time looking.

    Anyone find a solution I'd be interested to know. May have to look at Easy Battery Saver or one of the others, or contact them.
    08-02-2013 10:58 AM
  8. Lesley Miller's Avatar
    Thanks for the advice to go into the Phone app. and turning off "Turn Off Screen During Calls" - when Samsung Kies performed the update/upgrade of the latest firmware, it must have reset these settings automatically to turn the phone off when answering calls. I also could not end the call or press anything on my Touchscreen -it went blank when in a call - whether or not it was on Speakerphone - it was annoying as all get out. More specifically, I just want to say that it really wasn't clear when Meyerweb at first said said: "Goto the Phone App" - because some of us are less technically inclined than others, basically I wanted to be a little more detailed: Goto your homescreen, see the phone icon (Green) and press it then go to the lower left hand 3 bar function key (sorry, don't know what it's called) and then press it to get a Menu, and press "Call Settings" , "Turn Off Screen During Calls" and tick or untick it. Solution - big thanks to Meyerweb, who provided that solution.. ....just thought I'd be more detailed. Thanks very much! Didn't realize the recent Kies firmware update would've reset all my call settings!
    08-24-2013 09:07 PM
  9. RSPC's Avatar
    On my Note II the problem was the Gyroscope calibration, As soon as i calibrated it the screen started working normally. The phone now knows when it is brought back to a horizontal position and turns the screen back on.
    menu/settings/motion/advanced settings/Gyroscope calibration
    Then follow the directions.
    I hope that helps someone...
    11-07-2013 01:39 PM
  10. matchmade's Avatar
    Many thanks for breaking down these steps: this has solved my problem too. I was worried because I thought there was a problem with my Power button: my screen went black as soon as a call started and the power button would not power up the Home page; it also didn't appear to work after I hung up, so I was messing around taking off the back of my phone and removing and replacing the battery in order to get the phone to restart and power up.

    I've no idea why anyone would want to use "screen off during calls": I find it useful to have the screen ON, so that if someone asks during a call for someone else's number, say, I can return to my screen and look the number up in my phonebook whilst keeping the call live.
    11-26-2013 06:35 AM
  11. GSDer's Avatar
    I've no idea why anyone would want to use "screen off during calls"
    Perhaps you have no idea because the feature has never worked correctly for you - in my case, the screen goes off (preventing accidental screen touches, and saving battery) whenever I place the phone next to my face, and when I move the phone away from my face the screen comes back on. Very useful indeed.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    Siva1986 likes this.
    11-29-2013 11:35 PM
  12. cubbie65's Avatar
    I had this problem with my phone and after checking my settings and everything was set correctly I then took the case off my phone and it worked fine. I guess my case was blocking my sensor.

    Posted via Android Central App
    GSDer likes this.
    12-03-2013 06:18 PM
  13. Ashley Powell2's Avatar
    Excellent suggestion but now my face keeps hanging up on people as it touches the end call button everytime argh.
    01-07-2014 01:02 PM
  14. chirag05's Avatar
    I would let the proximity sensor do its job

    Sent from my GSIII
    01-16-2014 05:09 AM
  15. ABHI FlaMe's Avatar
    If your using a custom ROM. you can fix the problem by keeping the screen on.

    Go to dialler app->3dots->settings->calls->turn off 'Enable proximity sensor'

    Doing this will keep your screen on during calls.
    04-13-2016 01:26 AM
  16. Siva1986's Avatar
    I have the same problem. Mine WAS working fine (screen off when it's at your ear; turns back on when you move it away), but now is not. Once you put the phone to your ear, it stays off.

    The problem occurred either after the latest Verizon update, or possibly after installing "Battery Doctor".

    Any ideas?
    Hi bro i faced the same problem with my mobile now that has been rectified try my suggention.....phone - settings - calls - calling accounts - display duration keep in off mode
    problem solved.......
    02-07-2018 01:20 AM

Similar Threads

  1. Screen shuts off during calls
    By mike31082 in forum HTC EVO 4G LTE
    Replies: 10
    Last Post: 11-06-2016, 01:49 PM
  2. Replies: 16
    Last Post: 11-01-2013, 05:38 PM
  3. Screen off during calls
    By CT77 in forum Verizon HTC Rezound
    Replies: 16
    Last Post: 07-11-2013, 01:33 PM
  4. how to keep screen off during bluetooth calls?
    By karsdroid in forum Samsung Galaxy S3
    Replies: 7
    Last Post: 09-15-2012, 04:58 PM
  5. screen off during calls and can't turn it back on
    By brandontj in forum Samsung Galaxy S II Skyrocket
    Replies: 5
    Last Post: 01-09-2012, 06:44 PM
LINK TO POST COPIED TO CLIPBOARD