05-14-2018 05:42 PM
37 12
tools
  1. cfs6254's Avatar
    Hi
    So i just bought a power bank for my phone so i can recharge it during outdoor hiking trips where im not near a power socket for several days.

    The problem is that my SGS3 wont recharge using that power source. I have tried another one and the same issue is with the other one.

    When wired to a power socket it charges perfectly so its only when connected to a power bank that is a problem.

    With the first power bank i tried, it didn't seem to charge at all. The new power bank which i just bought soes charge it but only for a few seconds.

    Any clues what to do?
    05-30-2013 01:07 PM
  2. friedtators's Avatar
    sounds like the powerbank is not giving the phone the correct amount of power. that does not mean the bank is defective just not going to work with the s3. they can be finicky. the s2 will cause big issues so i would image the s3 as well.
    05-30-2013 04:35 PM
  3. cfs6254's Avatar
    Thanks for the answer. However, the same powerbank works fine with my 2 friends S3 phones. So i was wondering whether its a setting somewhere....or if a factory reset would solve the issue
    05-31-2013 02:42 AM
  4. cuek80's Avatar
    Try to use different cable?
    Did you try to reboot the phone first? I had experience similar like this before with my bb 9860. Rebooting the phone solve the problem, but not a fix solution. It will occur again.

    Good luck
    05-31-2013 03:38 AM
  5. cfs6254's Avatar
    I did try to reboot the phone. One if my friends has the same problem. It seems that some phones are just not that compatible With a power bank

    sendt fra min Samsung galaxy S3 med Tapatalk2
    06-01-2013 07:11 AM
  6. cuek80's Avatar
    If the power bank have more than 1 usb port, try the other one. Sometimes the ampherage is too high, or low for the phone to charge.
    But i guess u already try that
    Or try battery app? That can make the phone trickle charge or something. Not sure.
    06-01-2013 08:42 PM
  7. Sing Lum's Avatar
    you'd best read the instructions at first.
    06-06-2013 11:03 PM
  8. cfs6254's Avatar
    you'd best read the instructions at first.
    Read the instructions for the Phone or the power bank?

    sendt fra min Samsung galaxy S3 med Tapatalk2
    06-09-2013 04:55 PM
  9. Ahmedmad's Avatar
    This situation , maybe have 2 reason ,. 1 . your power bank is not working 2. you misusing , maybe take the wrong adapter, hope can help you , any other questions, leave me a message
    08-06-2013 02:44 AM
  10. wilika87's Avatar
    I guess that it's mostly a phone issue.
    I have a Sony Xperia P. There are about 3 other Xperia P-s around in the office. All of them, and a few other devices charge fine from the powerbank. Even my phone does, when I don't need it that much (like when I have socket nearby). But while on the go and I really need it, it fails mostly.
    I plug in the cable, the phone shows charging, but within a few seconds, the powerbank switches off, and that's all. First I thought it's the powerbank's issue. But it looks like the phone rejects the charge after a few seconds, making the powerbank to switch off. Rebooting doesn't help. I haven't tried reinstalling de phone yet, but since it's quite a new install (stock 4.1 ROM without rooting), I'd reject that option.
    09-30-2013 02:31 AM
  11. peterk_21114's Avatar
    My droid will not take a charge from the Power Bank.. .
    I have tired different cables
    the power bank can charge my son's IPOD
    11-21-2013 09:01 AM
  12. Kondao's Avatar
    Is it because power bank output is only 1A? I know SGS4 original charger has output of 2A.
    I'm facing the same problem here too.
    04-10-2014 01:53 AM
  13. GSDer's Avatar
    Is it because power bank output is only 1A? I know SGS4 original charger has output of 2A.
    I'm facing the same problem here too.
    Welcome to the forums!

    1A should be adequate (the USB specification lists as little as 500mA) - it'll just take longer to charge with less than the maximum current.

    Have you tried a different cable?
    Does the power bank charge other devices?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-10-2014 12:17 PM
  14. norbertsited's Avatar
    I have tried several power banks, I have a samsung galaxy Note 2, for a couple of days I had charging issues after using a very cheap chinese power bank, I bought a dynex power bank (2200 mAh) and It is working like a charm, the other two cheap chinese PB are just a piece of crap, and a waste of money, try buying the dynex one at best buy, I bought one today and my phone is being charged with not problems, hope this is helpful to you.

    greetings,
    Norbertsited.
    07-09-2014 11:26 PM
  15. Abdullah Amer1's Avatar
    I have the same problem with my power bank, I plug it to the charging plug all the blue lights turns on, but when I take it out and I press the test button no lights go on...i open it there is no damage in the circuit, any advice??



    07-31-2014 04:59 AM
  16. GSDer's Avatar
    Welcome to the forums!
    i open it there is no damage in the circuit, any advice?
    Are you really going to trust a company that can't spell 'dispose' correctly?
    You just ignored Caution #2...

    Anyway, sounds like you need to return it where you got it from - likely a defective unit.



    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    07-31-2014 10:25 PM
  17. Claudine Roxas's Avatar
    My powerbank wouldnt chrge also. My phone is sony. I tried charging my ipad and my other phones, it didnt charge. I tried charging a samsung phone. It seems like its the only phone it charges. What might be the problem? My powerbank is 20,000 mAh
    08-23-2014 12:26 AM
  18. GSDer's Avatar
    Welcome to the forums!
    What might be the problem?
    Did you buy a well known brand of power bank? Did it have good reviews? Can you post a link to the one that you purchased?

    Assuming that it has different amperage output ports, have you tried them both?

    Have you tried using a different cable than the one that came with it?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-23-2014 09:16 AM
  19. dubbyluv's Avatar
    i also have a galaxy note 2, and my 5600 mah power bank would only charge for one second, and then stop. i switched usb/micro usb cable to my charger cable, and it works fine. so, the powerbank problems are more likely the cable, not the unit itself.
    09-02-2014 09:12 AM
  20. Shower Chan's Avatar
    I newly bought a 12000 mAh power bank. It charges my iPad, my wife galaxy s3, iPhone 3gs perfectly but not my galaxy s3. I swap with 4 cables I have but it just stop charge after raised 2 percent.

    After all type of testing. It was because of the battery i used was not original. I changed to a 3100mAh battery a while back for better battery capacity.

    I swap back to original 2100mAh Samsung battery and the power bank is now working perfectly.

    Hope this help.
    10-13-2014 08:45 AM
  21. Mary Rankin's Avatar
    I had the same issue where my power bank would not charge. I was so frustrated that I considered getting rid of it. I tried two different things. I let the power bank stay on the charger for a little longer than it needed just to make sure it had a full charge, plus when I plugged the bank into my phone I slightly pulled it almost out. It took a little wiggling but it worked. Hope this helps. Oh Btw I have a Samsung Galaxy S3.
    02-27-2015 05:24 PM
  22. Yoink676's Avatar
    I had a 23000mah power bank s3 didn't charge with stock USB cable , tried charging with nexus 9 cable ...
    It worked!
    Heck it even supports 2100ma current which charges the whole battery in just 50minutes!
    04-15-2015 04:32 AM
  23. rich6440's Avatar
    The usb port on Your phone has cracked loose.I found the 5 volt pin on My phone cracked loose.Needs to be re-soldered.
    04-17-2015 10:23 AM
  24. Scotty Olry's Avatar
    TRY THIS:
    I recently bought a power bank (gold) from eBay for my nexus 6 phablet.. I came across the same issue where my phone (on) would only charge for a couple seconds and then would stop charging from the power bank - which was fully charged! I tried turning my phone off and then I plugged it into the power bank.. And it worked for me. So try that and see if it works
    04-24-2015 12:29 AM
  25. Waltsteg's Avatar
    powerbank is charging my galaxy's (s3 and s4) ONLY when phone is powered off. Thanks for this tip
    07-04-2015 01:03 PM
37 12

Similar Threads

  1. Photon wont charge or power up - Dead
    By cdubya1 in forum Sprint Photon
    Replies: 10
    Last Post: 10-29-2014, 10:12 PM
  2. Wont't Charge from 12V DC (car battery)
    By nrothschild in forum LG Optimus S
    Replies: 7
    Last Post: 03-31-2013, 04:36 PM
  3. Help!! Apps wont download from market.
    By droidX1991 in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 10-28-2010, 10:31 PM
  4. when i try to charge while powered off, clockwork starts automatically
    By theartialmartist in forum Software Development and Hacking
    Replies: 0
    Last Post: 08-16-2010, 09:38 PM
  5. Not getting txt notifications from my Bank since Sprint/Evo
    By PM-Performance in forum HTC EVO 4G
    Replies: 23
    Last Post: 07-28-2010, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD