1. manthanvyas's Avatar
    Hello friends,
    I am having Samsung galaxy S3 GTI9300 (India) from last 9 months, its not rooted and within the warranty.Android 4.1.1 Jellybean.
    Yesterday my phone screen suddenly starts to go up and down, like it is flickering, black stripes goes up and down. I tried to turn off the phone immediately but it was not responding, so I removed the battery, plugged in once again and tried to power up. But the phone won't starts. I tried my friend's S3 battery but it won't start.
    This happened when I was surfing on Google chrome, with WiFi on and my battery level was 18%.
    Did anybody faced this before ? I hope the LCD comes under warranty.
    08-07-2013 01:37 AM
  2. Golfdriver97's Avatar
    Hello friends,
    I am having Samsung galaxy S3 GTI9300 (India) from last 9 months, its not rooted and within the warranty.Android 4.1.1 Jellybean.
    Yesterday my phone screen suddenly starts to go up and down, like it is flickering, black stripes goes up and down. I tried to turn off the phone immediately but it was not responding, so I removed the battery, plugged in once again and tried to power up. But the phone won't starts. I tried my friend's S3 battery but it won't start.
    This happened when I was surfing on Google chrome, with WiFi on and my battery level was 18%.
    Did anybody faced this before ? I hope the LCD comes under warranty.
    I would suggest to take it wherever you can get someone to look at it. Your carrier, etc. This sounds like it might be a hardware problem.
    manthanvyas likes this.
    08-08-2013 08:44 AM
  3. AmericanPride's Avatar
    I've faced this issue before. It was always the battery, it got below 20 percent and the screen flickered. It wouldn't power up, it was just a faulty battery. Try picking up a new battery, hopefully that helps. If not, you're on warranty and can get it serviced. Good luck!

    Whoops, didn't notice you've tried the battery. Service then definitely. Good luck!

    Sent from my SAMSUNG-SGH-I747 using Tapatalk 4
    manthanvyas likes this.
    08-08-2013 10:09 AM
  4. manthanvyas's Avatar
    I took it to the service center. They said that motherboard is dead so the phone. It will take minimum 5 days.
    Will keep you guys posted if any of having same problem.
    08-12-2013 12:36 AM
  5. manthanvyas's Avatar
    My phone just got back from service center.
    They replaced motherboard.
    08-16-2013 10:59 AM

Similar Threads

  1. Nexus 4 won't boot
    By RugbyMan in forum Google Nexus 4
    Replies: 7
    Last Post: 09-19-2013, 12:13 AM
  2. Replies: 5
    Last Post: 09-17-2013, 11:06 PM
  3. Replies: 7
    Last Post: 08-09-2013, 01:12 AM
  4. Replies: 2
    Last Post: 08-07-2013, 02:14 PM
  5. Galaxy S4 lag when opening some apps
    By singjai in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 08-07-2013, 12:56 AM
LINK TO POST COPIED TO CLIPBOARD