1. humanracer's Avatar
    Can anyone please help? My S3 was working fine up until a few days ago. Programs started opening on their own without me touching anything and when I started to charge the phone it came up with an odd message like "phone is docked". Most of the answers I read online seemed to suggest that it is the battery or charging cable. I bought replacements for both. I put them in today but it did not seem to resolve issue. The new battery says it has 63% power. When I plug the cable in it says charging but the charge does not increase. The red light in the corner also only comes on when the display goes onto standby.

    I have tried wiping the cache and even do a hard reset along with a restore. I have also checked for viruses with Avast.

    My brother gave this phone to me for free because the screen is a bit broken so I cannot afford and don't want to get Samsung to repair it.

    The only thing I can think of is I was listening to music while washing the dishes and some water did splash on the screen. Maybe water damage?

    Any other suggestions?
    05-08-2014 01:34 PM
  2. Golfdriver97's Avatar
    Have you tried a restart?

    Sent from my HTC One_M8 using AC Forums mobile app
    05-08-2014 04:33 PM
  3. GSDer's Avatar
    Welcome to the forums!
    Programs started opening on their own without me touching anything
    You mentioned that the screen is damaged - the digitizer could be recording false touch events, causing random things on the screen to be selected.

    It should be fairly straightforward to determine if the apps that are starting happen to have shortcuts on the Home screen. If so, then you really need to look at a screen assembly replacement.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    Golfdriver97 likes this.
    05-09-2014 12:42 AM
  4. humanracer's Avatar
    Odd...I did another hard reset to the factory settings and it is charging again but not as fast as before. So is this a hardware or software issue??
    05-09-2014 03:25 PM
  5. humanracer's Avatar
    Odd..I did a hard reset and it now charges, not though as fast as normal. Is this a hardware or software issue with the phone?
    05-09-2014 03:42 PM
  6. Golfdriver97's Avatar
    Have you tried a different cable now that it is charging?

    Sent from my HTC One_M8 using AC Forums mobile app
    05-09-2014 03:54 PM

Similar Threads

  1. Why are Android phones made of plastic?
    By Trackr in forum General News & Discussion
    Replies: 79
    Last Post: 09-10-2016, 07:36 AM
  2. How can I improve my battery life?
    By Rajeev Kumar5 in forum Moto X (2013)
    Replies: 9
    Last Post: 05-09-2014, 11:31 AM
  3. Happy day! My wife switched to Android!!
    By OceanSD in forum Introductions
    Replies: 11
    Last Post: 05-09-2014, 12:05 AM
  4. Thanks to this forum I'm having a rocking good time with my S5
    By Jon Jackson in forum Samsung Galaxy S5
    Replies: 20
    Last Post: 05-08-2014, 02:49 PM
  5. is there a Samsung Apps app on my Note 10.1 2014 edition
    By jimcapraro in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 4
    Last Post: 05-08-2014, 12:51 PM