1. TomNGN's Avatar
    My PC won't recognize my galaxy S3, but it has no problem with other S3. My phone doesn't even show connection options up.

    Things I have tried:
    1) Factory reset
    2) Dial *#7284# and change it to UART (Modem) and USB (PDA) and every combination.
    3) Kies and reinstall drivers
    4) I tried to upgrade android to 4.3 from 4.1.2 to see if it help
    5) Try other other cabel and PC
    6) Debugging mode USB

    I'm pretty sure that my phone has a problem not my PC and I don't know how to reinstall or change drivers in my phone.
    I didn't really it until, because I have found another way to transfer, but now I want to root my phone and all guide I read said that I need to connect my phone with PC.
    07-09-2016 03:49 PM
  2. Golfdriver97's Avatar
    It may be the port on the phone is having issues with the data pins. Is it charging ok?
    07-09-2016 04:15 PM
  3. TomNGN's Avatar
    Charging is absolutely ok, never had problem with it.
    07-10-2016 04:55 AM
  4. Golfdriver97's Avatar
    Charging is absolutely ok, never had problem with it.
    A possible damaged data pin is the only thing I can think of. Since there isn't a change when you use different cables, it would have to be the port in the device.
    07-10-2016 09:34 AM
  5. TomNGN's Avatar
    Well whole time I was hoping that is not the damaged pin, but you are probably right. Anyway could I root my phone without connection to PC?
    07-10-2016 02:37 PM
  6. TomNGN's Avatar
    I just found out the on the working GS3 MTP app have 12kb size, while my don't have any. Is there anyway to reinstall or fix that app in my phone?
    07-11-2016 02:07 AM
  7. Weards's Avatar
    Lately my Galaxy S3 wasn't connecting with my computer, was charging the battery but sometimes connect then fail at the middle of a transference or updating firmware with Smart Switch, any help?
    09-23-2016 07:08 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-09-2016, 09:43 PM
  2. Replies: 1
    Last Post: 07-09-2016, 03:05 PM
  3. Replies: 0
    Last Post: 07-09-2016, 02:49 PM
  4. I am not getting air command in my galaxy note 4 edge
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-09-2016, 11:22 AM
  5. Really slow bluetooth connect time after 6.0.1 update
    By 1arryb in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 07-09-2016, 11:17 AM
LINK TO POST COPIED TO CLIPBOARD