09-29-2014 08:24 PM
26 12
  1. oneobserver's Avatar
    When I bought my 10.1 tab from Verizon I also purchased the USB adapter, thinking that it would allow me to access a thumb drive from my tab. I have tried several thumb drives so far and not been successful. When I plug in my older smaller ones (<4Gb), I get a warning in the tray that I plugged in a high power USB device, but nothing shows up in file manager. I have tried both Astro and Ghost Commander, and while both show a USBDrive mount point at the top of the file system, no files ever show up on the drive. Attempting to put a file in that directory, corrupts the thumb drive that is attached and I have to reformat it next time I plug it back in my laptop. Using a larger drive >= 4Gb just highlights the USB icon, but has the same behavior. Do I have to have a specific format on my USB thumb drive to see it on the tablet, and if so is there an app to do that? Or am I just missing a driver?

    I have a 4G tablet and am running version 3.1.

    Also, I have seen mention of SD Card access supposedly part of the USB adpater kit. Mine did not come with that. was there supposed to be another part besides the adapter itself?


    11-09-2011 09:50 PM
  2. silverthornne's Avatar
    Mine didn't include a card reader. It wouldn't fit in the box...

    Anyway, the thumb drive you're using demands too much power. It will probably work if you connect it through a powered USB hub...

    Sent from my GT-P7510 using Tapatalk
    11-09-2011 11:55 PM
  3. oneobserver's Avatar
    What kinds of thumb drives has anybody had luck with (brand and size)?
    11-10-2011 02:11 AM
  4. Sambo41's Avatar
    My Sandisk, cruizer 16GB works. Make sure sure you safely remove it or it won't work again until you put it in a computer and scan it for errors.
    11-10-2011 06:31 AM
  5. anon(549921)'s Avatar
    I've used a cheapy 4gb one I picked up at the checkout in Walmart and an sdhc card plugged into the sd card adapter and both worked fine. I did ditch Astro for Es File Manager as Astro wouldn't pick up the usb
    11-10-2011 09:31 AM
  6. oneobserver's Avatar
    Ok. And just to confirm, it does show up at the /usbdrive mount in the file system? And when you said I would need to "repair" the drive if i did not cleanly dismount it, what did you mean? The reformat it was making me do?
    11-10-2011 12:34 PM
  7. Sambo41's Avatar
    No, don't reformat it. If you remove the jumpdrive without dismounting it first the tablet will not see the drive again until you put it in a computer and let Widows check for errors. Mine didn't find any but after the scan it worked in the SGT again.
    11-10-2011 02:01 PM
  8. Kevin Gossett's Avatar
    I successfully connected a 500 Seagate Free Agent via a powered hub, but that was before the TW update (wifi model). Now it won't recognize anything
    11-10-2011 08:35 PM
  9. oneobserver's Avatar
    OK. Just tried it again and I have a PNY 4Gb drive. It reads just fine on the PC and when scanned for errors, comes back clean. WHen I plug it into the USB adapter, it brings up the USB symbol in the tray, but nothing appears under /usbdrive in Ghost Commander. I then clicked the USB symbol and the Click here to remove safely that pops up, so I know it knows the device is there. I really liked Ghost Commanders SMB implementation, but will uninstall and go try the ES File manager and see if that works.
    11-10-2011 09:52 PM
  10. oneobserver's Avatar
    I have now attached a powered hub (kinda defeats the purpose) and switched over to ES File Manager. Still no joy. Beginning to think I have a bad adapter... Need to find something else to try in this.
    11-11-2011 07:01 PM
  11. oneobserver's Avatar
    Just tried it with a USB keyboard and that worked, so the adapter is more or less OK. Not sure why it is being so picky about these drives.
    11-11-2011 07:13 PM
  12. Anonymous98134001's Avatar
    I am a new Galaxy Tab owner, and I think my question fits into this thread. I have my laptop, and my 1.5 TB external portable hard drive, my Galaxy Tab, and the USB conversion drive, or stick, whatever. Do I need to use my laptop as a HUB between the external and my Tab, or is there a way to just plug in the External to the Tab? I heard I need to format the disk or something from the Best Buy kid, but he didn't sound too sure of himself. I just want to watch movies on my Tab instead of using the laptop. I'm currently deployed on a Navy ship and we sleep in small coffin size beds. The laptop is just too bulky for the bed and I can't open the screen up all the way. The Tab is perfect. So that's the back story on my intentions for this. If I can't make this work I will punch that Best Buy kid in the face for talking me out of a Netbook and into the Tab.
    11-18-2011 07:22 AM
  13. anon(549921)'s Avatar
    I cannot get my external HDD to work with the Tab, so I just plug the Tab into the PC and connect it MTB mode so it effectively works as another drive, I then copy what ever movies/TV I want to watch from the external HDD to the Tab. What memory does your Tab have, even if its 16mb you can still fit a fair few movies on it. Alternatively get a large capacity memory stick and fill it up with movies and connect it to the Tab and play movies from their.

    Either way it will solve your problem and in the Tab you have a much better piece of kit than a netbook.
    11-18-2011 10:45 AM
  14. Stang68's Avatar
    I'm pretty sure the Verizon version of the 10.1 has problems with USB hosting/mounting. I still cannot connect my Verizon Tab 10.1 to my Mac, even with Android File Transfer connected. It says "MTP Connected" on my Tab, but nothing happens on the Mac...
    11-19-2011 10:58 AM
  15. anon(549921)'s Avatar
    Easy way to find out, connect it to a PC and see if it recognises it.

    I'm pretty sure the Verizon version of the 10.1 has problems with USB hosting/mounting. I still cannot connect my Verizon Tab 10.1 to my Mac, even with Android File Transfer connected. It says "MTP Connected" on my Tab, but nothing happens on the Mac...
    11-19-2011 08:01 PM
  16. Stang68's Avatar
    Easy way to find out, connect it to a PC and see if it recognises it.
    I figured it out. Just an app called XNJB and it allows me to use MTP on a Mac. Transferring files now!
    11-20-2011 04:24 PM
  17. datastar's Avatar
    I got two working fine; a cheap $6 4GB from Micro Center and an 8GB biometric McAfee that reads my fingerprint to allow access
    11-21-2011 09:10 PM
  18. bjorn.toss's Avatar
    Hi, I have a Samsung tablet 8.9 with WiFi and 3G. Have tried a lot of different ways to connect a 500 GB USB external 2.5 drive. Whatever I do I get the message that a high power USB device is connected. The storage is blank or has unsupported file system. Also a warning triangle saying can not access to this device.

    Does anyone have a solution to this problem?
    Thankful for advice.

    Bjorn Toss
    03-15-2012 08:02 PM
  19. meyerweb#CB's Avatar
    Two things. You can't connect a hard drive unless the drive has it's own power supply, or you connect it through a powered USB hub. Hard drives require more power than the tablet can provide.

    And I believe the tablet will only recognize drives that are formatted as FAT32, which limits you to 32GB partitions. Your 500GB drive is probably formatted as NTFS.
    04-09-2012 11:38 AM
  20. meyerweb#CB's Avatar
    OK, anyone have any ideas?

    I've got the USB kit for my Tab 10.1. Using a powered hub, it reads my thumb drive just fine. But when I plug in an external hard disk, whether powered through the hub or powering the drive directly, the same thing happens. The drive opens, briefly, and I see a flash of the file and folder that are on the disk, but then the drive disconnects, and I get an error message in the notification area that says the USB device disconnetec unexpectedly.

    The drive is formatted as a 32GB, FAT 32 drive.

    Any and all ideas selcome.
    04-16-2012 08:49 PM
  21. Ak_cute's Avatar
    Bought Samsung tab2 P3100 few days back.Not able to connect my hard disk to it and everytime I connect it always displays high power device connected as a warning message.
    Same issue happens when I connect my reliance data card to it.Is there anyway I can connect these devices to my tab?Please help.
    12-05-2012 01:15 AM
  22. kraski's Avatar
    I started another thread because I didn't see this one. I've now figured out 99% of my problem was I was looking for USBdrive instead of extStorage, which shows up in all my file handlers, including Ghost Commander. But I still have one other question.

    If I'm playing music or watching movies from a thumb drive, that drains the battery, without a way to recharge while in use. If I'm streaming from online, I can plug in the Tab and recharge while I'm using it. So, I'm wondering if using a "Y" adaptor in the USB plug would allow charging (either from an A/C plug or from a USB connection to a PC) on one leg while playing media off a USB stick. Would that work? Could it damage either the Tab or the USB drive?
    12-09-2012 11:30 AM
  23. ruki12's Avatar
    MY problm look in another topic coz when i used my tablet 4.0ics only a week, i enjoyed using 3g usb stick which my droid supports it, my problem is when i unplug my usb to my devic, and put it back again it didnt show any pop up or recognition to my usb device. how is that? "PLEASE I NeED UR HELP aDROID ExPERTS" pls reply ill wait thank you to all!!
    01-20-2013 09:58 PM
  24. ruki12's Avatar
    we have the same problem i cannot connect my flash drive to my tablet but my tablet can connect to the pc, i so not know wats the problem can u help me through?
    02-03-2013 11:26 PM
  25. Marco Carrillo's Avatar
    you have to put the flash drive in a pc and format it then it will open up right away when you plug it in with the otg cable i just did this today.
    05-13-2014 01:50 PM
26 12