1. mrweatherbee's Avatar
    This is the second time I've had this problem. Any app I bring up will launch and run fine as long as no keyboard call is made. Chrome can launch pages by clicking on bookmarks, can read and highlight PDFs in Acrobat reader, Netflix works, on and on and on. But as soon as I try to invoke the keyboard in an app, that app stops, e.g., "Unfortunately, Chrome has stopped".

    Circumstances where this happens, consistently when the application makes a call to the keyboard:
    • Tapping URL box in Chrome
    • Tapping search icon in Google Play
    • Opening note for editing in Evernote
    • Reporting a stopped app! "Unfortunately, Market Feedback agent has stopped"

    The first time this happened I was using the stock Samsung Keyboard. This time my standard keyboard is SwiftKey. Last time the only thing I could do to solve the problem was to do a full factory data reset, wiping everything and starting fresh. Ridiculous. I can't trust the device to store any data, notes, etc. now, because I don't know when it's going to crash and wipe out everything requiring a reset. Nothing is rooted, this is standard ICS v4.0.3 (I checked for update, ICSv4.0.4 isn't showing for me).

    Has anyone else seen this problem? If so, any hints, other than dump it and get a Nexus 7, which I am now seriously debating?
    07-12-2012 11:18 AM
  2. ph0000's Avatar
    I have got to the same problem just few days ago. My tab is rooted 4.0.3. And all keyboard-demanding apps are crashing with all keyboards I have, and even with a hardware USB keyboard. Any idea?

    The same problem is described on a swype forum, but it is obviously not related to swype since I have never had swype on my tab:
    Apps crash when the keyboard is brought up on Tab 2 7.0"

    Surprisingly, two apps survive(!) calling a keyboard - terminal emulator and terminal ide. Then, Samsung keyboard reports a crash, but other input methods work well. Hence it seems to be related to Samsung keyboard somehow...
    07-23-2012 05:27 PM
  3. jmw0806's Avatar
    I've got the exact same issue. It has happened twice within a 3 month period. Obviously it's a problem with these tablets. I'm going to attempt to contact samsung about the issue. Although likely that won't solve anything.
    08-06-2012 09:56 AM
  4. mrweatherbee's Avatar
    I never found a way around the problem. It happened twice, and both times I had to hard reset and essentially start over. Immensely frustrating. On the bright side, it has not happened since I updated my non-rooted Tab 2 to Android v4.0.4
    08-11-2012 04:58 PM
  5. kevin.efurd's Avatar
    (non-rooted, non-modded, two-day old tablet)

    i just ran into the same problem this afternoon. i've had the tablet for less than 48 hours and the tablet has all current updates (4.0.4). here's a lead-up to what happened for posterity's sake:

    * wanted to test music unlimited's offline mode when no wifi was available. had to 'forget' my home wifi network since MU detects if i disable wifi and exits
    * after testing (FAILED, can't believe i pay money for that damn service), tapped my wifi network to enter creds and reconnect, settings crashed.
    * tried restarting, powering off, various other crap.

    so to reiterate the symptoms: any time the keyboard is called (for a text box field for example), the app in question hangs for about 7 seconds, crashes, and i get 'unfortunately, [Settings] has crashed.'

    I called Samsung and got through to a person surprisingly quick. The person on the phone would not acknowledge any kind of keyboard crash issue. after some standard IT phone support crap (i'm an IT professional and very good at this stuff), they recommended i factory reset the phone. so i whined about how inconvenient their solution is and the phone call ended.

    so i've got 28 days to return this thing. if it happens again, i'll be going with a different manufacturer. good luck all!
    08-16-2012 07:58 PM
  6. dronsick's Avatar
    I have GT-P5110 and Android 4.0.3, I understand that main problem is the keyboard.
    In my case the samsung keyboard crashes when I open any app. And this happened each week! I mean, I had to reset for each week.. , so, I fix it resetting my tablet and firstly installing app "Ice Cream Sandwich Keyboard Free" from Play Store previously to install all the apps.
    Until the moment has not crash any app.

    Also, try to install some antivirus and try to never use the Samsung keyboard until there is an update from samsung or android.

    Hope it works!
    09-18-2012 03:41 PM
  7. mmuetst's Avatar
    I have the same problem. On forum.xda-developers.com is a solution but i think it can only be done with a rooted tab: The solution was to remove /data/clipboard. This is a system forder and is not Accessible if your not root. It is clear, there is a bug in this tab of Samsung. I never have this problem with my Asus TF300 tab. I try to find a e-mail address of Samsung to mail dis bug, does someone knows a e-mail address to support of Samsung? I suggest to mail with as many people as possible.
    I hope Samsung accepts There bug and comes with a solution.
    10-28-2012 08:40 AM
  8. hanni's Avatar
    "Good" to know that somebody else have same problem, mine has existed couple of weeks now.
    I sent my question to below link, unfortunately it is in finnish, but I am sure you will find out more civilized site:
    Email Product Support - Samsung

    I will follow this blog and let you know if I get any response from Samsung.
    11-03-2012 06:41 AM
  9. hanni's Avatar
    I have received an answer from Samsung Customer Support Center:

    "I understand the problems as the keyboard application is malfunctioning and only shuts down. There is one possible solution for this problems that I can find right now and this is to restore the tablets settings to it's original state. The restoration will delete all the files, settings and apps that you have installed and stored on the tablet so I recommend that you take a backup before. The backup can be done to your computer with help of the Samsung Kies program.
    When you have made a backup of all the files you want to save you can find the option for a restoration from the tablets settings by opening settings and then choosing backup & restore. (From here you can also make a backup to your google account)."

    Not exactly what I wanted to hear from them.
    11-06-2012 11:18 AM
  10. donnellfms's Avatar
    Hi fellas.

    Ive been thru the same problem last week. I found a solution at XDA Dev Forum (also mentioned by mmuetst).

    It really was a problem with the embedded clipboard application from Samsung.

    The good news are that you just need to clean the clipboard cache existing at /data/clipboard and the problem disappear.
    The bad news (for some people at least) are that you must get your device rooted to get access to /data/clipboard folder.

    So that your decision: do a factory reset every time this problem comes up (theres a workaround using the "Ice Cream Sandwich Keyboard Free", but I didn't tested) or get your device rooted. I've chosen the second one.

    Let's get the hands on:

    There are several ways to get your GT-P5100 rooted. I've followed this tutorial Root Samsung Galaxy Tab 2 (10.1 inch display) Model Numbers GT-P5100, GT-P5110 and GT-P5113, it worked like a charm.

    Provided that your device is already rooted, you just need open your favorite file manager (I used ES Explorer), mount/get root RW access to your file system, navigate to the folder /data/clipboard, clear the content of this folder (you can perform backup of this data to another location prior deleting if you are afraid of lose some useful information) and reboot your device. Your keyboard should be working once again.

    Mr. wd5gnr also suggests that you change the /data/clipboard folder permissions to prevent this problem to happen again.

    For doing this download and install on your rooted device the Terminal Emulator (available at Play Store https://play.google.com/store/apps/d...dterm&hl=pt_BR) then open it and enter the command lines as bellow:

    chmod 775 /data/clipboard
    chown system.system /data/clipboard

    And reboot again.


    renatovisk and kozlov like this.
    11-12-2012 08:43 AM
  11. FredAnoniem's Avatar

    Could anyone tell me were to find the /data/clipboard directory?


    12-05-2012 01:05 PM
  12. renatovisk's Avatar
    Very helpful! Solved my problem!
    12-28-2012 11:44 AM
  13. Stoian Anastasov's Avatar
    Solved my problem too!!! Thanks!!!
    01-15-2013 02:06 AM
  14. gusr6's Avatar
    Hi Everyone,

    I've been having the same issue. I've managed to get root access (I'm no techie, so it took me a while!), but.... /data is empty. There is no clipboard folder contained within. I'm running 4.0.3 if that makes any difference.

    Any ideas?

    If it helps, I can see the following folders in my root directory - acct, cache, config, d, data, dev, efs, etc, factory, lib, mnt, preload, proc, root, sbin, sdcard, sys, system, vendor.

    Any help would be very much appreciated and might prevent me from hurling this device through a window
    02-23-2013 12:49 AM
  15. gusr6's Avatar
    all good - I hadn't mounted my file system correctly in ES file explorer - I went here for instructions: http://androidforums.com/optimus-v-a...perations.html

    If you're as dumb as me, it isn't immediately obvious how to get into the settings, ie. tap the little icon at the bottom made up of three horizontal lines

    Finally, this device is working again. I'm not sure I have the confidence to do the permanent fix, but at least I can fix if (when) it happens again.

    thanks again for your help everyone.
    02-23-2013 05:57 PM
  16. Hemant Shah's Avatar
    Just have check permissions,
    Or chqnge your stock keyboard, and install some other keyboards

    ★Does thanking cost any Money,
    ★NOO!!!! $O Just Hit THANKS I Helped You
    Time is LIFE,
    02-24-2013 09:38 PM