1. leprechaunshawn's Avatar
    So, I bought my first tablet yesterday and since I posted in this forum it was obviously a Galaxy Tab 2 7.0

    I fully charged it before turning it on. Once powered up, I signed into my Samsung Account (I also have a Galaxy S3) and my Google account. The GT2 started downloading all the apps associated with my Google account, this was kind of nice since it was simple to remove the apps I dont need on my tablet like the Swiftkey keyboard for my phone, Shazam and a few others. After I removed the apps I didnt want on the tablet, I downloaded Lookout Mobile Security and the Swiftkey keyboard for tablets.

    At this point, what I described above is literally all I had done to the tablet. Then the screen locked up, shut off and now I cannot even power it up. I tried a few methods that I found online to restart, such as holding the power button and volume down button for 10 seconds then releasing the volume down button while continuing to hold the power button for 10 more seconds. Ive also tried simply holding the power button for up to 30 seconds. Nothing is working.

    Has anybody experienced this problem and if so, how did you fix it? Since I bought it yesterday, I guess I could always exchange it at Best Buy but since Ive already logged into my Samsung and Google accounts on the device, Id be a little worried about my personal information that may be on the device.

    If you have any advice, thank you in advance.
    11-26-2012 10:33 AM
  2. melog69's Avatar
    The only advice I can give is to take it back to the store and have them give you a new one, this might be a defective unit
    11-28-2012 11:02 AM
  3. leprechaunshawn's Avatar
    I meant to update this thread yesterday but that's exactly what I ended up doing.
    11-28-2012 11:39 AM

Similar Threads

  1. Flyer won't power up
    By djrakowski in forum HTC Flyer
    Replies: 4
    Last Post: 01-25-2013, 07:16 PM
  2. HTC Sensation Won't Power Up
    By Androidfiend in forum T-Mobile HTC Sensation
    Replies: 6
    Last Post: 05-15-2012, 12:21 PM
  3. Unit won't power up
    By dherrick in forum ASUS EeePad Transformer
    Replies: 3
    Last Post: 01-11-2012, 02:03 PM
  4. Droid (A855) won't power up - at all. Interesting case..
    By paintba11er89 in forum Motorola Droid
    Replies: 3
    Last Post: 10-28-2011, 11:46 AM
  5. D2 (A955) won't power up/boot up... did I kill it?
    By Nza in forum Droid 2 Rooting, ROMs, and Hacks
    Replies: 0
    Last Post: 07-10-2011, 04:25 AM