1. Pro2535's Avatar
    The screen flashes the charging icon in the middle on for about 3 seconds then goes off for a little bit then repeats over and over but does not charge at all.

    But before this all happened, when the tablet was on it had an X through the battery icon? And thought it was charging with no charger plugged in... It dies fast but charges slow..

    I am using the official charger it came with. Can anyone please help!?
    08-21-2015 08:14 PM
  2. Dngrsone's Avatar
    You likely have a bad cable: the X means that the device thinks it is attached to a computer and limits its charge to .5 amps, which is not enough to charge a completely dead battery.

    Try finding another cable which has intact data lines and see if it charges better that way.

    Sent from my SPH-L720T using Tapatalk
    08-21-2015 08:17 PM
  3. Pro2535's Avatar
    Ok, I will look into getting a new charger. But, how come the tablet thinks it's being charged with no charger plugged in?? Not to mention the fact the tablet has been doing this for about a week or so, and it used to charge it even when it was dead?
    08-21-2015 09:16 PM

Similar Threads

  1. When will the next nexus be announced?
    By streetkilln in forum Nexus 5X
    Replies: 15
    Last Post: 08-30-2015, 12:21 PM
  2. Replies: 1
    Last Post: 08-22-2015, 01:19 AM
  3. Replies: 0
    Last Post: 08-21-2015, 07:48 PM
  4. Can I get some help with my SD Card?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 08-21-2015, 07:41 PM
LINK TO POST COPIED TO CLIPBOARD