1. Magellan's Avatar
    I have a Galaxy Tab 3 7.0 from Tmo. I am the owner, and my son is a second user. When I open the play store, it stays open for about 10 seconds, then closes with the message "Unfortunately, Google Play has stopped working". When I switch users to my sons account, the play store is fine. I have tried uninstalling updates to the play store, clearing the cache and data, clearing google play services, and making sure download manager is on. I even removed my gmail account and added it back.

    Any ideas?
    06-02-2014 09:58 AM
  2. rabijlassi's Avatar
    - Open Application manager
    - Go to the "all" tab
    - scroll all the way to the bottom and you will see download manager is disabled.
    -Ope and enable.

    Hope this helps!!!
    06-02-2014 11:52 AM
  3. Magellan's Avatar
    Thanks, I tried that but no go. I finally fixed it though. I started uninstalling my most recent apps, and uninstalling Google wallet fixed it. Strange..
    06-03-2014 12:31 PM

Similar Threads

  1. The past day my s3 has been acting weird..
    By itslawrahh in forum AT&T Galaxy S III
    Replies: 3
    Last Post: 06-02-2014, 12:24 PM
  2. HTC one (M7) massive ram usage
    By Sharpblade1997 in forum General News & Discussion
    Replies: 0
    Last Post: 06-02-2014, 09:48 AM
  3. Play Music using a ton of storage and mobile data
    By raptir in forum General Help and How To
    Replies: 0
    Last Post: 06-02-2014, 09:23 AM